Hi All,

got my picoreplayer installed on Raspberry Pi3+, playing music from /mnt/music, which is a ext4 filesystem, and largely works.

as soon as i import records with accents (`'^) in the filename, they turn up in the file system with ?? in the name instead of accents. Example: "Estampes II. La soirée dans Grenade.m4a" turns up as "Estampes II. La soir??e dans Grenade", "10 Children’s Corner II. Jimbo’s Lullaby.m4a" turns up as "Children???s Corner II. Jimbo???s Lullaby.m4a". Guess this will turn out true for danish, spanish, etc. titles, but haven't tried that yet. (Just seeing in the Preview that the board isn't happy with accents either. Sorry about that, but take my word, that the titles mentioned acually contain proper syntax ;-) )

So, i tried extending cmdline.txt with either LANG=de.DE_UTF8, de._DE_UTF8/UTF8, en.EN_UTF8, en.EN_UTF8/UTF8, us.US_UTF8 and us.US_UTF8/UTF8, wich are all in /usr/local/share/getlocale/SUPPORTED.

I tried employing getlocale.sh, which, run as "sudo getlocale.sh", doesn't seem to do anything, because the output is empty instead of "Now processing ... locale installed ...etc".

I know that changing the locale does not work witch DOS filesystems, but should work with libux filesystems (did that before with my linuxes).

Has anyone tried changing the locale before? How did you do that? Does anyone know how to get getlocale.sh to work? Are you playing "french titles" on piCore? How do you do that without the player complaining about broken paths?

Looking forward to your answers, perhaps some help.

Best Regards