Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 58
  1. #21
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    536
    Quote Originally Posted by bpa View Post
    A Unix executable is unlikely to run on macOS. Can you run it in Terminal window to check you have a compatible version ?
    I went ahead and double-clicked it and got this in Terminal ...

    libxvid --enable-libzimg --enable-libzmq --enable-libzvbi --enable-version3 --pkg-config-flags=--static --disable-ffplay
    libavutil 56. 26.100 / 56. 26.100
    libavcodec 58. 51.100 / 58. 51.100
    libavformat 58. 27.102 / 58. 27.102
    libavdevice 58. 7.100 / 58. 7.100
    libavfilter 7. 48.100 / 7. 48.100
    libswscale 5. 4.100 / 5. 4.100
    libswresample 3. 4.100 / 3. 4.100
    libpostproc 55. 4.100 / 55. 4.100
    Hyper fast Audio and Video encoder
    usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

    Use -h to get full help or, even better, run 'man ffmpeg'
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.
    Deleting expired sessions...46 completed.

    [Process completed]

  2. #22
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,324
    Attached is a zipped file. The zip file is called custom-convert.zip and it contains one file called custom-convert.conf

    Before you attempts the steps below you need to find out where LMS convert.conf file is located on your system. I don't know which directory is used on OSX.macOS system. The directory will contain file such as convert.conf and types.conf . Check there is no custom-convert.conf file already in the directory as replacing the existing file will break something else.

    1. Download the attached zip file.
    2. Unzip the zip file and save the file custom-convert.conf
    3. Copy the file custom-convert.conf into the directory which has convert.conf
    4. Make sure custom-convert.conf has the same ownership and permissions as convert.conf
    5. Restart LMS
    6. Check MPEG-4 entries in WebUI Settings/Advanced/FileTypes - that is showing ffmpeg and not faad (e.g. ffmpeg vs faad/flac)
    Attached Files Attached Files

  3. #23
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    536
    I've followed your instructions, but now in MPEG4 in Settings/Advanced/FileTypes I get only "Native" next to AAC, rest greyed out Disabled. No sign of ffmpeg, and no sign of faad/flac, which was next to FLAC before.

  4. #24
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,324
    Quote Originally Posted by whitman View Post
    I've followed your instructions, but now in MPEG4 in Settings/Advanced/FileTypes I get only "Native" next to AAC, rest greyed out Disabled. No sign of ffmpeg, and no sign of faad/flac, which was next to FLAC before.
    That probably means LMS cannot "see" ffmpeg.

    Which directory is ffmpeg executable installed ?

    In WebUI Settings/Information - at the bottom there is a list of directories besides "Helper Applications Folder" - ffmpeg has to be in one of those directories and with permissions such that the LMS userid can execute it. This is macOS stuff - I don't know specifics, can only guide.

  5. #25
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    536
    Ha, I'd forgotten to put ffmpeg into the relevant folder, it was still floating around on my desktop. Once I did that, it all fired up as expectedŚand the Scala Listen Again URLs work perfectly.

    Thanks again, bpa, as ever, for your patience and help.

    And if any other macOS users ever look at this, using macOS 10.14.4, I went to top level/Library/PreferencePanes/Squeezebox.prefPane, then right clicked and Show Package Contents, then I put bpa's custom-convert.conf file in Contents/server (which is where convert.conf and types.conf etc already reside), then dropped the downloaded ffmpeg file into Contents/server, which directed it into Contents/server/Bin.

  6. #26
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    536
    A further report, now I have the MPEG4 streams working, related to the Scala Listen Again URLs, as given in post no. 7.

    I tried the William Orbit In The Space one for Monday, as noted in that post, and made a URL for a Thursday version. Unfortunately, these streams run only for 10 minutes or so and then stop. Not sure if this is some sort of limitation that Scala puts on them, though that seems unlikely for what are supposed to be Listen Agains.

    Anyway, no great problem for me, as those two short stretches of In The Space I heard were disappointing.

    But thought I'd point it out.

  7. #27
    Senior Member Heuer's Avatar
    Join Date
    Nov 2005
    Posts
    589

    Scala streaming broken

    This stream stopped working for me when I installed the latest LMS 8.0.0-1597033155 nightly on 12th August. Track information is displayed but no sound except on my Radio and Transporter. Nothing on SB3 or Boom.

    I have been using the url at the beginning of this thread: https://stream-mz.planetradio.co.uk/scalahigh.aac

    Reverted to my previous working version of 8.0.0-1592130094 which is dated 17th June and everything is back to normal streaming at 127kbps CBR, AAC. I can get a Tunein url to work but that is a dismal 48kb stream.

    Something broken in nightlies?

  8. #28
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,008
    Quote Originally Posted by Heuer View Post
    This stream stopped working for me when I installed the latest LMS 8.0.0-1597033155 nightly on 12th August. Track information is displayed but no sound except on my Radio and Transporter. Nothing on SB3 or Boom.

    I have been using the url at the beginning of this thread: https://stream-mz.planetradio.co.uk/scalahigh.aac

    Reverted to my previous working version of 8.0.0-1592130094 which is dated 17th June and everything is back to normal streaming at 127kbps CBR, AAC. I can get a Tunein url to work but that is a dismal 48kb stream.

    Something broken in nightlies?
    I'm listening via http://opml.radiotime.com/Tune.ashx?id=s307703 which is 112kbps mp3
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  9. #29
    Senior Member Heuer's Avatar
    Join Date
    Nov 2005
    Posts
    589
    Thanks, that works but why has the latest LMS 8 changed to not allow the previous link?

  10. #30
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,145
    Quote Originally Posted by Heuer View Post
    This stream stopped working for me when I installed the latest LMS 8.0.0-1597033155 nightly on 12th August. Track information is displayed but no sound except on my Radio and Transporter. Nothing on SB3 or Boom.

    I have been using the url at the beginning of this thread: https://stream-mz.planetradio.co.uk/scalahigh.aac

    Reverted to my previous working version of 8.0.0-1592130094 which is dated 17th June and everything is back to normal streaming at 127kbps CBR, AAC. I can get a Tunein url to work but that is a dismal 48kb stream.

    Something broken in nightlies?
    What are your file type settings for AAC? If it works with an older nightly it shouldn't be an issue but worth checking.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •