Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Senior Member
    Join Date
    Jul 2009
    Posts
    304

    piCorePlayer v4.1.0 odd Date & Time

    There have been some discussions already about time setting in pCP, but I think in my case, there is really something odd going on:
    I am running:
    piCorePlayer | piCorePlayer v4.1.0 | linux 4.14.81-pcpCore | piCore v9.2pCP | Squeezelite v1.9.0-1121-pCP
    (Which I think is the latest version; I installed this version from scratch, so no updates etc)
    on a PiZeroW

    When I boot, pCP Webpage lists a 1970ies date in the bottom.
    (I definetely have Internet access; I also tried to change the time server and also time zone w/o success in correcting the time)

    But what is really strange is that when I manually want to change the date via ssh and do i.e. "sudo date 20190126",
    the date does not adjust accordingly, but just increments by one year to "Sat Aug 19 01:26:00 CEST 1971"!
    If I redo the above sudo command, the date increments again by 1 year. And so on.
    So, I can not even manually change the date.

    This is more a cosmetic issue, but it bugs me a little and I guess it will cause trouble at some point with plugins, as this is also the date/time LMS is reporting in logs etc.

    Is anyone else seeing this with the above pCP build and a PiZero connected via WLAN?

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,277
    Try
    date -s "1/26/2019 15:59:00"
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  3. #3
    I had other issues with pCP 4.1.0 on a Pi ZeroW - but the date on mine seems fine:
    DeepThought | piCorePlayer v4.1.0 | linux 4.14.81-pcpCore | piCore v9.2pCP | Squeezelite v1.9.0-1121-pCP | Sat Jan 26 16:25:41 GMT 2019

    This was a pCP 4.0.0 install that I did an in situ update to 4.1.0 with yesterday. I just rebooted it to have a look.

    Robert
    Home: Raspberry Pi 3/piCoreplayer/LMS7.9.2 with files on QNAP TS-251A
    Touch > DacMagic 100 > Naim Audio Nait 3 > Mission 752 (plus Rega Planar 3 > Rega Fono Mini; Naim CD3)
    PiCorePlayer(Pi2) with IQAudIO DAC+>Sennheisers
    2 x Squeezebox Radios, 1 X Squeezebox 3 (retired), spare Pi2/piCorePlayer
    Office: LMS7.9.2 running on WiFi MyPassport drive > piCorePlayer(PiB)/HiFiBerryDAC > Amptastic Amplifier
    SqueezePad, iPeng as controllers

    last.fm/user/GrumpyBob

  4. #4
    Senior Member
    Join Date
    Jul 2009
    Posts
    304
    Thanks for the feednack.

    When I try sudo date -s "1/26/2019 15:59:00"
    I get:
    date: invalid date '1/26/2019 15:59:00'

  5. #5
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,598
    busybox probably doesn't handle as many different formats as you are used to with full systems.

    sudo date -s "2019-01-26 12:20:00"

    You might check to see it something is blocking access to pool.ntp.org

    If so, you can change by using the ntpserver boot code.
    Last edited by paul-; 2019-01-26 at 10:24.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,277
    I had not spotted that Busybox saved a few more bytes (I presume) by supporting fewer formats for date/time input.
    Useful guide https://busybox.net/downloads/BusyBox.html
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  7. #7
    Senior Member
    Join Date
    Jul 2009
    Posts
    304
    Quote Originally Posted by paul- View Post
    busybox probably doesn't handle as many different formats as you are used to with full systems.

    sudo date -s "2019-01-26 12:20:00"

    You might check to see it something is blocking access to pool.ntp.org

    If so, you can change by using the ntpserver boot code.
    Thanks, Paul - the above date syntax works for manual time setting!

    However, automatic time setting still does not work - I used already several different ntp servers.
    Also I pinged pool.ntp.org from pCP and that worked as well.

    I am puzzeled.

  8. #8
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,569
    Hi slimhase,

    The web server on pCP starts before the time is set. So this means it is possible for any pCP setup to access a setup web page before ntp has done its thing. This will result the epoch date displaying on the web pages. Usually a refresh is all that is required. As this is reasonably rare it was decided that waiting for ntp to complete before starting the web server was not warranted.

    So we are looking for something different with your pCP setup or an issue with your network.

    Try tis, what is the result?

    Code:
    sudo /usr/sbin/ntpd -w -p pool.ntp.org
    regards
    Greg

  9. #9
    Senior Member
    Join Date
    Jul 2009
    Posts
    304
    Quote Originally Posted by Greg Erskine View Post
    Hi slimhase,

    The web server on pCP starts before the time is set. So this means it is possible for any pCP setup to access a setup web page before ntp has done its thing. This will result the epoch date displaying on the web pages. Usually a refresh is all that is required. As this is reasonably rare it was decided that waiting for ntp to complete before starting the web server was not warranted.

    So we are looking for something different with your pCP setup or an issue with your network.

    Try tis, what is the result?

    Code:
    sudo /usr/sbin/ntpd -w -p pool.ntp.org
    regards
    Greg
    Thanks, Greg!
    The above command results in this response:
    ntpd: timed out waiting for 193.183.98.38, reach 0x00, next query in 2s
    So, in this case, it looks like it can not reach the ntp server.

    However, when I do (from the same ssh session): ping pool.ntp.org
    I get: PING pool.ntp.org (193.183.98.38): 56 data bytes
    64 bytes from 193.183.98.38: seq=0 ttl=52 time=66.725 ms
    So in this case, it seems to see the server.

    How can that be?
    Still very puzzeled....

  10. #10
    Senior Member
    Join Date
    Sep 2007
    Posts
    157
    I bet you have port 123 blocked but allow ICMP, 80 and 443.

    Firewall issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •