Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 10
  1. #1
    Junior Member
    Join Date
    Mar 2018
    Posts
    15

    Moving Configured PCP to Different Network

    Is it possible to easily reconfigure a PCP/LMS install to another network? All music is local (USB drive) and LMS is configured locally on the Pi. I just wanted to move the unit to a different SSID. Can I just change the wpa_supplicant.conf file to reflect the new network credentials?

    Thanks in advance!

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,048
    That should work just fine
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Mar 2018
    Posts
    15
    Quote Originally Posted by paul- View Post
    That should work just fine
    Having trouble getting PCP to connect to a network via wireless setup.

    I have reflashed the software multiple times and edited the wpa_supplicant file using both quotes and without, and trying both WPA and WPA2. The green Pi comm/network LED flashes on and off and then goes dark. No matter what I try, it's not connecting. What am I doing wrong?

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,048
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Junior Member
    Join Date
    Mar 2018
    Posts
    15
    Quote Originally Posted by paul- View Post
    Yes, of course. I finally had to configure via ethernet, but it was problematic at best to do so. By way of a suggestion, perhaps the instructions are a bit vague for those of us without linux chops - for example, should our SSID and PW be in the quotes, or not? Just a thought.

    Thanks!

  6. #6
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,048
    Quote Originally Posted by Hammerhead View Post
    Yes, of course. I finally had to configure via ethernet, but it was problematic at best to do so. By way of a suggestion, perhaps the instructions are a bit vague for those of us without linux chops - for example, should our SSID and PW be in the quotes, or not? Just a thought.

    Thanks!
    That document shows the exact format that you need. Deviations wont work. You also need to make sure windows is not adding .txt to the end of the file.

    SSID and PSK are quoted.

    You may see PSK without quotes, but then that is a fully coded password. (output of wpa_passphrase)
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  7. #7
    Senior Member
    Join Date
    Jan 2016
    Location
    Germany
    Posts
    170
    Is there a possibility in PiCorePlayer to set up two different WiFi networks?
    Due to the move from home office to university, my son's PicorePlayer-based Squeezeplayer has to be reconfigured many times.
    And removing the SD card is a little difficult there. So a permanent solution would be fine.

    I tried this:
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=staff
    country=DE
    update_config=1
    
    network={
        ssid="SCHOOLS NETWORK NAME"
        psk="SCHOOLS PASSWORD"
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        id_str="school"
    }
    
    network={
        ssid="HOME NETWORK NAME"
        psk="HOME PASSWORD"
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        id_str="home"
    }
    ... but it doesent work.

    Regards
    PiPlayer

  8. #8
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,227
    It should work.

    You need to add this as the first line, otherwise piCorePlayer will clobber it.

    Code:
    # Maintained by user

  9. #9
    Senior Member
    Join Date
    Jan 2016
    Location
    Germany
    Posts
    170
    Quote Originally Posted by Greg Erskine View Post
    Code:
    # Maintained by user
    Ahh, this line was always missing in my wpa_supplicant.conf. I will try that. Thank you very much!

  10. #10
    Senior Member
    Join Date
    Jan 2016
    Location
    Germany
    Posts
    170
    Quote Originally Posted by Greg Erskine View Post
    Code:
    # Maintained by user
    Quote Originally Posted by piPlayer View Post
    I will try that.
    The wpa_supplicant.conf with several WLAN settings now works. Additionally I had to add the line scan_ssid = 1, otherwise it won't work.

    This file works for me:
    Code:
    # Maintained by user
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=staff
    country=DE
    update_config=1
    
    network={
        ssid="SCHOOLS NETWORK NAME"
        scan_ssid=1
        psk="SCHOOLS PASSWORD"
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        id_str="school"
    }
    
    network={
        ssid="HOME NETWORK NAME"
        scan_ssid=1
        psk="HOME PASSWORD"
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        id_str="home"
    }

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •