Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 19

Hybrid View

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    13

    Squeezelite/Picoreplayer not playing a lot of ALAC files

    Setup is LMS on a W10 PC and picoreplayer running on a 3b pi. Files are all ALAC. I have configured LMS & Picoreplayer to play these natively.

    Problem is, some of my files only play the first few seconds or are completely silent. When I view the playback in the LMS console, it's playing the same few seconds over and over again, but there's no output.

    Any ideas?

    cheers

  2. #2
    Junior Member
    Join Date
    Dec 2018
    Posts
    13
    Same files play fine in PCP using the FLAC & PCM streams, BTW.

  3. #3
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,215
    Anything in the LMS logs ?
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 7.5 VM on ESXi 6.5.0U2 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1660 albums with 23087 songs by 5204 artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,642
    WebUI Timer running withouts audio really means nothing except that play has been pressed - timer is only real when audio is playing.

    Most likely some part of the transcoding has failed (e.g. sox for resampling or alac decoding) - check that player can play source natively - not only format but also sample size and sample rate

  5. #5
    Junior Member
    Join Date
    Dec 2018
    Posts
    13
    Nothing being generated in the LMS about these events. The only error in the log is: Slim::Networking::SqueezeNetwork::Players::_player s_error (354) Unable to get players from SN: Couldn't resolve IP address for: www.mysqueezebox.com, retrying in 604800 seconds

  6. #6
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,642
    Enable player.source logging to INFO and, note time and then try to play the track.
    After a 10 secs, clear playlist and look at server.log file.

    Copy ALL lines from log into a plain text files (e.g. use Notepad) between noted start time and when track was stopped.

    Save file, zip and attach to a post so it can be examined.

    If you are familiar with the trasncoding process - look at the log for the file paths of the applications doing transcoding and check the application are present and executable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •