Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    13

    Squeezelite/Picoreplayer not playing a lot of ALAC files

    Setup is LMS on a W10 PC and picoreplayer running on a 3b pi. Files are all ALAC. I have configured LMS & Picoreplayer to play these natively.

    Problem is, some of my files only play the first few seconds or are completely silent. When I view the playback in the LMS console, it's playing the same few seconds over and over again, but there's no output.

    Any ideas?

    cheers

  2. #2
    Junior Member
    Join Date
    Dec 2018
    Posts
    13
    Same files play fine in PCP using the FLAC & PCM streams, BTW.

  3. #3
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,215
    Anything in the LMS logs ?
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 7.5 VM on ESXi 6.5.0U2 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1660 albums with 23087 songs by 5204 artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,640
    WebUI Timer running withouts audio really means nothing except that play has been pressed - timer is only real when audio is playing.

    Most likely some part of the transcoding has failed (e.g. sox for resampling or alac decoding) - check that player can play source natively - not only format but also sample size and sample rate

  5. #5
    Junior Member
    Join Date
    Dec 2018
    Posts
    13
    Nothing being generated in the LMS about these events. The only error in the log is: Slim::Networking::SqueezeNetwork::Players::_player s_error (354) Unable to get players from SN: Couldn't resolve IP address for: www.mysqueezebox.com, retrying in 604800 seconds

  6. #6
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,640
    Enable player.source logging to INFO and, note time and then try to play the track.
    After a 10 secs, clear playlist and look at server.log file.

    Copy ALL lines from log into a plain text files (e.g. use Notepad) between noted start time and when track was stopped.

    Save file, zip and attach to a post so it can be examined.

    If you are familiar with the trasncoding process - look at the log for the file paths of the applications doing transcoding and check the application are present and executable.

  7. #7
    Junior Member
    Join Date
    Dec 2018
    Posts
    13
    Log text attached. (the VBulletin file upload utility wouldn't let me upload the zipped file).

    The log's recording something called a player Output Underrun at the point that playback stops. Is this a buffer issue? Why might it affect some files and not others?

    For info, the file being played here is actually mono, so lower bitrate than almost all my other ALAC files.

    I'll check the transcoding logs.

    For info, these files play back perfectly when set to steram to FLAC or PCM and on KODI and iTunes, so I doubt there is an issue with file integrity.

    The PCP client is a 3b using onboard wireless and is working fine with loads of hi res files, so I don't think it's LAN bandwidth issue, either.

    cheers
    Attached Files Attached Files
    Last edited by foxwelljsly; 2019-01-10 at 03:35.

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,640
    No transcoding - player is expected to play format natively

    But there seems to be a difficulty in sending the file to the player.
    Can you play other files OK ?
    If so then you need to enable squeezelite logging.

    Code:
    19-01-10 10:02:35.0881] Slim::Player::TranscodingHelper::getConvertCommand2 (428) Matched: alc->alc via: -
    [19-01-10 10:02:40.0061] Slim::Player::StreamingController::playerOutputUnderrun (2325) b8:27:eb:a4:0c:04: decoder: 2097151 / output: 0
    [19-01-10 10:02:40.0066] Slim::Player::StreamingController::_setPlayingState (2474) new playing state BUFFERING
    [19-01-10 10:02:40.1299] Slim::Player::Player::_buffering (1182) Buffering... 2097151 / 260615

  9. #9
    Junior Member
    Join Date
    Dec 2018
    Posts
    13
    Quote Originally Posted by bpa View Post
    No transcoding - player is expected to play format natively

    But there seems to be a difficulty in sending the file to the player.
    Can you play other files OK ?
    If so then you need to enable squeezelite logging.

    Code:
    19-01-10 10:02:35.0881] Slim::Player::TranscodingHelper::getConvertCommand2 (428) Matched: alc->alc via: -
    [19-01-10 10:02:40.0061] Slim::Player::StreamingController::playerOutputUnderrun (2325) b8:27:eb:a4:0c:04: decoder: 2097151 / output: 0
    [19-01-10 10:02:40.0066] Slim::Player::StreamingController::_setPlayingState (2474) new playing state BUFFERING
    [19-01-10 10:02:40.1299] Slim::Player::Player::_buffering (1182) Buffering... 2097151 / 260615
    Some files play fine, others don't. I've enabled logging on PCP to all:info. Forgive my ignorance, but do I use SSH to access the log file on the PCP client?

    thanks

  10. #10
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,640
    Quote Originally Posted by foxwelljsly View Post
    Forgive my ignorance, but do I use SSH to access the log file on the PCP client? thanks
    Don't know - I don't use PCP but I know squeezelite and its logging. I suspect PCP has provided an easy way to look at squeezelite log as I guess it will have been redirected into a file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •