Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Senior Member
    Join Date
    Jul 2009
    Posts
    286

    LMS becomes unresponive when using podcastplugin

    I use the podcast plugin w/o issues for many years on my home system.
    Now, I am using my "mobile system" - which is raspberry pi Zero based and LMS freezes / becomes unresponsive when I select a Podcast from the following (very long) feed:
    https://www1.wdr.de/mediathek/audio/...her150.podcast
    The Podcast never starts playing; LMS does not react anymore. Only way to recover is to restart LMS

    I checked "top" via ssh to see, if the pi zero is busy with anything, but no process is using more than 2-3%.

    In the error log, nothing is showing - until I reboot; then I see this:

    19-01-08 18:36:41.7832] Slim::Utils::Scanner::Remote::__ANON__ (193) Error: Can't connect to remote server to retrieve playlist for, https://wdrmedien-a.akamaihd.net/med...eg14_wdr3.mp3: Connect timed out: Connection timed out.
    [19-01-08 18:37:58.8933] main::init (387) Starting Logitech Media Server (v7.9.2, 1546952511, Tue Jan 8 14:22:37 CET 2019) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int

    I eliminated all other plugins, but problem remains.

    Two things to note:
    1) The podcast I tried to hear was "Kein Wort zu Oosterbeek", so I do not understand why in the above error log references "wdr3hoerspiel_2018-11-05_derapfelfaelltnichtweitvomkrieg14_wdr3.mp3". Maybe something gets mixed up due to the massive length of this podcast feed?
    2) I am currently in Italy - the podcast is from germany - could there be some geoblocking problems? (Although I can listen to the above podcast when using a tunein-app on my Iphone)

    Any help in fixing this is greatly appreciated.

    My System: Logitech Media Server Version: 7.9.2 - 1546952511 @ Tue Jan 8 14:22:37 CET 2019
    Hostname: pipal
    IP-Adresse des Servers: 192.168.1.5
    Server-HTTP-Portnummer: 9000
    Betriebssystem: piCore - DE - utf8
    Plattformarchitektur: armv7l-linux
    Perl-Version: 5.24.0 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 0.95
    IO::Socket::SSL: 2.056
    Datenbankversion: DBD::SQLite 1.58 (sqlite 3.22.0)
    Anzahl erkannter Player: 1

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,644
    Works OK for me on an x86 Ubuntu system so it means basic code & feed is OK & no geo-blocking. The podcast feed is only about 680kbytes long. So I'm guessing the isssue might be to do with memory (processing podcast feeds can a few take times more than original feed) shortage or processor and then you get a timeout.

    I suggest try to get another PCP user to test same podcast . Make a request on the PCP thread.
    Last edited by bpa; 2019-01-08 at 13:28. Reason: typo

  3. #3
    Senior Member
    Join Date
    Jul 2009
    Posts
    286
    Quote Originally Posted by bpa View Post
    Works OK for me on an x86 Ubuntu system so it means basic code & feed is OK & no geo-blocking. The podcast feed is only about 680kbytes long. So I'm guessing the isssue might be to do with memory (processing podcast feeds can a few take times more than original feed) shortage or processor and then you get a timeout.

    I suggest try to get another PCP user to test same podcast . Make a request on the PCP thread.
    Thanks for the feedback. As suggested, Ill move further discussion to PCP thread

    *update*: I leave it for now, as I saw that I get most of my podcasts through tunein / LMS Radio option.
    From there, the selecting a podcast from a large feed list (i.e. as above) is even much faster.
    Last edited by slimhase; 2019-01-09 at 06:16.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •