Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 10
  1. #1
    Junior Member
    Join Date
    Jan 2019
    Posts
    5

    RPI-3 piCorePlayer, LMS can not connect with WDMyCloud

    Hello,

    On my RPI 3 I installed the piCoreplayer. When I go to the IP address :9000 I can configure LMS. I try to make the connection with a media map on my WDMycloud. There is a share made with the name 'Music' and it contains FLAC files.
    With some kind of explorer I can choose /mnt/WDMyCloud but I can not choose the share 'Music'. So eventually there is no database built.

    There is maybe another possibility when I go to the IP address of the RPI and I see the configuration panel of piCorePlayer/LMS. Here I have the possibility to mount a Remote Network Share.

    I fill in:
    Mount Point: /mnt/WDMyCloud
    IP Address: 192.168.1.38 (this is the IP address of my NAS)
    Share Name: Music (I made this share and put in my FLAC files here)
    Share Type: CIFS (is this correct)

    When I push 'set NET Mount' I get the message 'Disk Mount Error'.

    What is going wrong?

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,285
    Quote Originally Posted by Dynaco_wjw View Post
    Hello,

    On my RPI 3 I installed the piCoreplayer. When I go to the IP address :9000 I can configure LMS. I try to make the connection with a media map on my WDMycloud. There is a share made with the name 'Music' and it contains FLAC files.
    With some kind of explorer I can choose /mnt/WDMyCloud but I can not choose the share 'Music'. So eventually there is no database built.

    There is maybe another possibility when I go to the IP address of the RPI and I see the configuration panel of piCorePlayer/LMS. Here I have the possibility to mount a Remote Network Share.

    I fill in:
    Mount Point: /mnt/WDMyCloud
    IP Address: 192.168.1.38 (this is the IP address of my NAS)
    Share Name: Music (I made this share and put in my FLAC files here)
    Share Type: CIFS (is this correct)

    When I push 'set NET Mount' I get the message 'Disk Mount Error'.


    What is going wrong?
    I use a WD MyCloud for my music storage, it works great.

    In the options field type "uid=1001,gid=50,vers=1.0" (without quotes).

    Name:  options.jpg
Views: 202
Size:  48.3 KB
    Server - LMS 7.9.2 Pi4B 4GB/Flirc case/pCP 6.0.0-b7 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  3. #3
    Junior Member
    Join Date
    Jan 2019
    Posts
    5
    Thank you for your answer. I tried it again but I get the next message:

    Name:  Schermafdruk 2019-01-05 18.26.15.jpg
Views: 205
Size:  134.5 KB

  4. #4
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,285
    Quote Originally Posted by Dynaco_wjw View Post
    Thank you for your answer. I tried it again but I get the next message:
    Have you installed the additional FileSystems?

    Name:  additional.jpg
Views: 195
Size:  23.3 KB
    Server - LMS 7.9.2 Pi4B 4GB/Flirc case/pCP 6.0.0-b7 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  5. #5
    Junior Member
    Join Date
    Jan 2019
    Posts
    5
    Many thanks. No I have not installed this. I will try this. I will put piCorePlayer again on a microSD card.
    In the meantime I installed Volumio on the RPI. Now I could attach the desired share on the WD Mycloud.
    Tomorrow I will take another microSD card and will install the extra item for additional filesystems.

  6. #6
    Junior Member
    Join Date
    Jan 2019
    Posts
    5
    Sorry for my late respons but first I wanted to try several things.

    Now I installed the Additional Filesystems but no good results. It still does not recognise my /WDMyCloud/Music share.
    I also installed a Samba server, but it does not start because I have to configure it and I have no idea how.

    Yesterday I format the SD again and I put Volumio on that card. It all went well and during the installation process I could even choose the desired Music share on my WDMyCoud.
    I installed the app Volumio on my Samsung Android A3 (2017) phone and I can play the files. Though the response is not very fast when playing files from the NAS. Playing from a USB stick in the RPi is quicker.

    This morning I took another microSD (4GB) and I installed piCorePlayer again. Everything works well, also with 4 x 32GB USB attached to the RPi. Except for the database on my NAS.

  7. #7
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,395
    Quote Originally Posted by Dynaco_wjw View Post
    Thank you for your answer. I tried it again but I get the next message:

    Name:  Schermafdruk 2019-01-05 18.26.15.jpg
Views: 205
Size:  134.5 KB
    Have you put in your username and password to the share ? They do not appear in the screenshot !

    You do not need a Samba Server to mount a CIFS share


    Name:  2019-01-06 16_27_01-pCP - Write to Disk Mounts.jpg
Views: 174
Size:  51.1 KB
    Last edited by Jeff07971; 2019-01-06 at 12:09.
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 8.0 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  8. #8
    Junior Member
    Join Date
    Jan 2019
    Posts
    5
    Hello Jeff, thank you very much. I tried before with my username and password but that did not work! I tried everything. Now I tried again and it works!! So thanks a lot to bring me back to this point. Maybe it has to do with installing extended files, I can't remember all the trial anymore. Strange thing is, for Volumio I did not need to fill in any username or password vor the WDMyCloud. I guess I don't have a username and password for this share. Now LMS is making a mediascan of this share now.

  9. #9
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,395
    Quote Originally Posted by Dynaco_wjw View Post
    Hello Jeff, thank you very much. I tried before with my username and password but that did not work! I tried everything. Now I tried again and it works!! So thanks a lot to bring me back to this point. Maybe it has to do with installing extended files, I can't remember all the trial anymore. Strange thing is, for Volumio I did not need to fill in any username or password vor the WDMyCloud. I guess I don't have a username and password for this share. Now LMS is making a mediascan of this share now.
    Enjoy !

    Jeff
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 8.0 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  10. #10
    Junior Member
    Join Date
    Jan 2019
    Posts
    19
    Quote Originally Posted by Dynaco_wjw View Post
    Many thanks. No I have not installed this. I will try this. I will put piCorePlayer again on a microSD card.
    In the meantime I installed Volumio on the RPI. Now I could attach the desired share on the WD Mycloud.
    Tomorrow I will take another microSD card and will install the extra item for additional filesystems.
    I had similar issues to you, got it working now I can't, any tips

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •