Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    3

    Asset UPnP on QNAP - Audio format streaming - FLAC to WAV

    Hi

    I've got Asset R6.1 running on my QNAP NAS.

    I've got my CD's ripped and saved as FLAC files.

    I wanted to test whether playback sounded better letting Asset send FLAC files as they are stored or whether converting them to WAV first before serving them up to my UPnP renderer was best, or if it made no difference.

    So to start with I went to the Asset Configure page and down to "Audio format streaming", and changed FLAC from "as is" to "as WAV".

    Using foobar2000 with a UPnP browser plugin on my PC I can play the files from Asset fine - and in the File Properties I can see File names like "d-8065562640914796164-co0B0B406D4D608D17.forced.wav" with the PCM codec etc. And they play fine.

    However on my Logitech Media Server running on a Raspberry Pi (running piCorePlayer) - I can see the Asset files in my Remote Music Library (UPnP renderer) and add them to the playlist of a Squeezelite player (another Raspberry Pi running piCorePlayer), but they won't play at all.

    Has anyone ever tried to do the same, and either had the same issue or found a way around it?
    Any suggestions for fixing this issue please?


    Regards,
    David

  2. #2
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    4,397

    Asset UPnP on QNAP - Audio format streaming - FLAC to WAV

    I know this is not the comment you’re looking for and you can tell me that if I don’t try to answer the question, I should not post but ... really it will sound the same. This is a lossless format and any perceived différence is as real as difference you hear between listening with or without a few glasses of wine. The comments about cpu noise and all is just BS. Now, everybody is free to use own time as one likes to.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  3. #3
    Junior Member
    Join Date
    Dec 2018
    Posts
    3
    Quote Originally Posted by philippe_44 View Post
    I know this is not the comment you’re looking for and you can tell me that if I don’t try to answer the question, I should not post but ... really it will sound the same. This is a lossless format and any perceived différence is as real as difference you hear between listening with or without a few glasses of wine. The comments about cpu noise and all is just BS. Now, everybody is free to use own time as one likes to.
    That's exactly why I wanted to listen for myself. To see if there was any difference or not - to my ears.


    I created an actual WAV file, saved it the QNAP NAS, and added that folder into the Asset library.

    I can play the WAV file if I navigate to the mounted QNAP NAS drive from my Logitech Media Server (LMS), but I can't play the WAV file over UPnP. Must be a limitation of LMS. Is this a known / documented limitation in the LMS community?

    Thanks for responding anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •