Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    2

    PcP powerscript is running when skipping to next song

    Hi,

    I have a Raspberry with Pcp, Jivelite, TFT touch screen and Allo DAC and IR remote. The LMS run on my Synology NAS. All is working fine ..... well almost.
    I like to switch my amplifiers when I switch on/off the above setup. I use the "Power On/Off script -S"option of squeezelite to run "powerscript.sh"
    So my Squeezelite setting look like "/usr/local/bin/squeezelite -n "Woonkamer" -o hw:CARD=BossDAC -a 80:4::1: -v -C 15 -S /home/tc/powerscript.sh"

    So far so good, the script runs and via an JSON call to Domoticz (I installed cURL) I can switch some powerplugs which in turn switches my amps.
    The problem is that this power script is also running when I change from one song to an other (it switches off and immediately on again) it also does this when I pauze a song.
    It doesn't show this behaviour when it just plays the next song on the same "CD".

    Can anyone explain this behaviour? Is their a setting I can change so it only triggers the script whem I use the "power" button? (either fron my IR remote or from the touch display)

    Regards Erik

  2. #2
    Junior Member
    Join Date
    Dec 2018
    Posts
    2
    Oh, just after posting this I found the culprit.
    The problem was solved after I turned off Shairport-sync.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •