Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Mar 2015
    Location
    Munich
    Posts
    52

    Squezzelite settings are lost after reboot.

    When I use the feature for 100% power saving and power afterwards RPi again, the squeezelite settings are kind of lost.

    The entries "Max sample rate" and "Upsample setting" are still filled as expected, but there is no music playing.
    I need to press the SAVE button. Only then music is playing.
    I already tried to "backup" the changes under Advanced Mode Operations, but in vain.

    Is this a bug or feature?
    What do I need to get the settings properly saved?
    Living Room / Hifi: piCorePlayer 4.0.0 on rPi 3B+ & Allo DigiOne & 1TB USB (LMS 7.9.2 & Squeezelite) & Keces DC-116, Mutec MC-3+ Smart Clock, Rega DAC R, Rotel RB/RC-1070, Klipsch Forte III
    Bedroom: Boom
    Kitchen: Radio
    Spare: SB3, Touch

  2. #2
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,547
    pCP does not have a "feature for 100% power saving"
    (Except for the power on/off switch )

  3. #3
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,225
    Quote Originally Posted by Greg Erskine View Post
    pCP does not have a "feature for 100% power saving"
    (Except for the power on/off switch )
    I think that was his joke (a reference to a recent similar comment by someone in pCP team).
    He is saying that after saving some settings and powering down pCP he finds that on rebooting something about the setup appears to have got lost.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  4. #4
    Member
    Join Date
    Mar 2015
    Location
    Munich
    Posts
    52
    Thanks Paul.
    Yes. I tried to make a joke w/ refernce to another thread.
    You are right. I do see some unexpected behaviour when I make changes to Squeezelite settings.
    Actually, I am doing further analysis looking at various scenarios:
    * just pressing the save button
    * Restarting Squeeelite on Main Screen
    * Rebooting pCB on Main Screen
    * Power off/on

    And it is not that seetings are lost, but that seettings are not applied. If I do look into the log, sometimes I do not see the applied change.
    I am still doing further investigations. Let's see if the problem is in front or behind the screen.

    One question: Is my assumption right, that all changes on squeezelite setting screen are automatically copied to RAM Disc?
    Living Room / Hifi: piCorePlayer 4.0.0 on rPi 3B+ & Allo DigiOne & 1TB USB (LMS 7.9.2 & Squeezelite) & Keces DC-116, Mutec MC-3+ Smart Clock, Rega DAC R, Rotel RB/RC-1070, Klipsch Forte III
    Bedroom: Boom
    Kitchen: Radio
    Spare: SB3, Touch

  5. #5
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,547
    hi schiff1108,

    Can you detail your issue?

    The Squeezelite Settings page is years old, if it was misbehaving I'd expect lots of feed back over the years.

    piCorePlayer is running in RAM. The config files are in RAM. The [Save] button writes to the config file in RAM and does a backup to the SD card.

    regards
    Greg

  6. #6
    Member
    Join Date
    Mar 2015
    Location
    Munich
    Posts
    52
    Well. I stop the analysis. I am not able to constantly reproduce the problem.
    The situation is that when I am changing something on squezzelite setting screen and press "save", it happens that there is either a message "[ ERROR ] Squeezelite not running" or everything green with "squezzelite running", but no music playing. I can solve this situation by pressing "save" again w/o changing anything. Sometimes I need to press save even one more to time to resolve the situation.
    Actually no problem for me, as I do have a work around.
    Living Room / Hifi: piCorePlayer 4.0.0 on rPi 3B+ & Allo DigiOne & 1TB USB (LMS 7.9.2 & Squeezelite) & Keces DC-116, Mutec MC-3+ Smart Clock, Rega DAC R, Rotel RB/RC-1070, Klipsch Forte III
    Bedroom: Boom
    Kitchen: Radio
    Spare: SB3, Touch

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •