Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5

Thread: Upgrading LMS

  1. #1
    Junior Member
    Join Date
    Jan 2015
    Posts
    17

    Upgrading LMS

    Hi,

    Since the version of LMS running on my server (Fedora 23...) is apparently too old to support the new Materials skin, I wanted to upgrade.

    So I downloaded the latest nightly build and tested the update. It failed:

    $rpm -Uvh --test logitechmediaserver-7.9.2-0.1.1543258616.noarch.rpm
    Preparing... ################################# [100%]
    package logitechmediaserver-1:7.9.0-0.126.20160422git1461319207.fc23.noarch (which is newer than logitechmediaserver-7.9.2-0.1.1543258616.noarch) is already installed

    followed by a bunch of conflicts.

    How can the 2 year old installed version be newer than the latest nightly?

  2. #2
    Senior Member
    Join Date
    Sep 2005
    Posts
    2,717
    Always start with making a backup

    then find your perl version

    find the matching lms here
    http://wiki.slimdevices.com/index.ph..._Perl_Versions

    upgrade perl
    http://rpm.pbone.net/index.php3?stat...srodzaj=3&dist[]=100

  3. #3
    Junior Member
    Join Date
    Jan 2015
    Posts
    17
    Quote Originally Posted by DJanGo View Post
    Always start with making a backup

    then find your perl version

    find the matching lms here
    http://wiki.slimdevices.com/index.ph..._Perl_Versions

    upgrade perl
    http://rpm.pbone.net/index.php3?stat...srodzaj=3&dist[]=100

    Thanks.

    My perl version is:
    $ perl -v|grep 5
    This is perl 5, version 22, subversion 2 (v5.22.2) built for x86_64-linux-thread-multi

    That seems to be OK for 7.9.2
    Your link refers to a Debian install. Is there also some documentation available for Fedora?

  4. #4
    Senior Member
    Join Date
    Sep 2005
    Posts
    2,717
    Quote Originally Posted by baggins View Post
    Your link refers to a Debian install. Is there also some documentation available for Fedora?
    After you fiddle that out - the wiki would be proud of having a fedora Howto like the Debian one ;-)

  5. #5
    Junior Member
    Join Date
    Jan 2015
    Posts
    17
    Quote Originally Posted by DJanGo View Post
    After you fiddle that out - the wiki would be proud of having a fedora Howto like the Debian one ;-)
    Well actually, two years ago I fiddled that out when I installed LMS, totally unaware of the perl hassles. It was only later that I realised there were some issues with perl and possibly other stuff.
    Unfortunately I have no idea anymore what I did then...
    That is in fact the reason why that server is still running F23. I disabled all updates in order to avoid breaking LMS...

    So it looks like I would have to do a forced update of the rpm package...

    On the other hand, I also downloaded the tarball and gave that a try on another machine without issues. So I could use that instead. I only wonder how upgrades are done then...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •