Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Senior Member Turnandcough's Avatar
    Join Date
    Jan 2007
    Location
    Montréal
    Posts
    129

    piCorePlayer, Allo DigiOne sig, RPi 4 + no music over wifi

    As the title says... for some reason I can't get music when switching from ethernet to wifi.

    Followed the steps for wifi connection on the piCorePlayer webpage ''how to'' section but no luck.

    Strangely enough the signal LED on my DAC lights up which indicates that there IS a network connection, there's just no sound until I plug the ethernet cable back in the RPi.

    Any tips?

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,520
    Make sure you are booting without the network cable plugged in, otherwise squeezelite will attach to that port, rather than wifi.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Senior Member Turnandcough's Avatar
    Join Date
    Jan 2007
    Location
    Montréal
    Posts
    129
    Quote Originally Posted by paul- View Post
    Make sure you are booting without the network cable plugged in, otherwise squeezelite will attach to that port, rather than wifi.

    Thanks will give it a try.

  4. #4
    Senior Member Turnandcough's Avatar
    Join Date
    Jan 2007
    Location
    Montréal
    Posts
    129
    Still no luck. I got a slow fading sound at the beginning, then nothing. Don't understand why the DAC LED shows a steady signal, normally if there's a network problem the LED will either flicker or not light up at all.

    Wifi works fine with my SB Touch.

  5. #5
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,520
    Can you access the pi when on WiFi. Do you have another Device you can run some network throughput testing with iperf?
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,099
    Power supply issue perhaps - built-in WiFi on RPi uses more than ethernet.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  7. #7
    Senior Member Turnandcough's Avatar
    Join Date
    Jan 2007
    Location
    Montréal
    Posts
    129
    I figured out at what point I needed to unplug network cable when rebooting and also changed the PSU on the DigiOne sig ''dirty side''.

    Originally I was using a 5V 2.5 amp linear PSU which I swapped out for a 5V 3 amp (5.1 actually) switch mode PSU. ''Clean side'' is powered by a good quality 5V 3 amp linear PSU.

    Now I'm getting music but at a much lower volume than with ethernet connection.

  8. #8
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,099
    Quote Originally Posted by Turnandcough View Post
    Now I'm getting music but at a much lower volume than with ethernet connection.
    The bits are the same size when switching from Ethernet to Wi-Fi so something else is happening.
    Perhaps use Alsamixer to change the volume and then
    pcp bu
    to make sure the settings are saved.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  9. #9
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,064
    Quote Originally Posted by Paul Webster View Post
    The bits are the same size when switching from Ethernet to Wi-Fi so something else is happening.
    Perhaps use Alsamixer to change the volume and then
    pcp bu
    to make sure the settings are saved.
    Don’t forget that LMS will see the WiFi and Ethernet as separate players. If you set the Ethernet player to output at 100% Fixed (for example) that won’t also automatically apply to the WiFi player. They have different MAC addresses but by default are both called piCorePlayer
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TXNR686 -> Celestion F20s
    Office - Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom - SB Touch ->Denon AVR ->Mordaunt Short M10s + Pioneer ceiling speakers
    Guest Room - Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •