Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 404

Threaded View

  1. #21
    Senior Member
    Join Date
    Jul 2009
    @philippe_44 and @sle118:
    Thank you for your feedback!

    I got it to work and - shame on me - I think the problem were incorrect permissions on the i2s.c file I replaced in the esp-idf/components/driver folder....

    But to answer some of the troubleshooting questions (maybe it helps other people):
    My esp-idf flavour:
    $ git show
    commit 6fe853a2c73437f74c0e6e79f9b15db68b231d32 (HEAD -> master, origin/master, origin/HEAD)
    Merge: e9b77d3a6 9b507c45c
    Author: Angus Gratton <angus@espressif.com>
    Date:   Mon Jul 29 19:25:30 2019 +0800
        Merge branch 'bugfix/ws_client_fix_static_analysis_warnings' into 'master'
        ws_client: fix double delete issue in ws client initialization
        See merge request espressif/esp-idf!5309
    My gcc Version is 5.2.0 - this is what I used to download it
    When I used sdkconfig from philippes master repo (overwriting sdkconfig post doing make menuconfig), I think it worked as well (But I didn't test long)

    WRT to flashing: That worked w/o problems by doing make flash (after changing the port to /dev/ttyS5 via menuconfig)

    P.S. I installed this on a Windows Unix Subsystem as described here: https://www.instructables.com/id/ESP...tem-for-Linux/
    P.P.S.: For flashing the barebone ESP module, I use this 'flasher' it works nicely: https://www.ebay.de/itm/1pcs-ESP32-P...72.m2749.l2649
    Last edited by slimhase; 2019-09-13 at 01:50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts