Home of the Squeezebox™ & Transporter® network music players.
Page 101 of 108 FirstFirst ... 519199100101102103 ... LastLast
Results 1,001 to 1,010 of 1073
  1. #1001
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,574
    Quote Originally Posted by StevePalmer View Post
    Hi Guys

    Had to recently re-install everything after a spectacular Windows10 crash. LMS and most of my plugins are working fine except 'BBCiPlayer Extras'.

    Whenever I choose a programme, I get the Album Art displayed on my Logitech Radio OK, BUT there's a brief message that says (something like) "Stream preference setting format missing format to play this program..." I suspect it's something I've done/not done - a 'schoolboy error' as they say... any advice appreciated!

    Cheers
    Odd I don't think the plugin generated any on screen messages only message in the log file. If there is no BBCiPlayer message in log file the issues may not be specially a plugin one.
    What version of the BBCiPlayer an BBCiPlayerExtras are installed ?

    In BBCiPlayer Settings - both stream preferences needs to be set to DASH > HLS > MP3 > FlashAAC. Extras specifically requires DASH and MP3 as there is no HLS content in Extras.

  2. #1002
    Senior Member StevePalmer's Avatar
    Join Date
    Jan 2011
    Posts
    211
    Hi BPA

    Cheers for the quick reply!. All sorted. Your suggestion of checking the stream preferences did the trick. Not sure why they weren't set as you suggested (probably me, faffing around!). Anyways, really appreciate your solution!

    Have fun! 👍😊
    Steve
    Kettering, UK

  3. #1003
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,574
    I've been testing LMS 8.0 on Windows 10 system. Not my normal setup. I found that playing any BBCiPlayer Live or Listen again program took about 10 secs to start compared to a Pi system sitting beside the Win10 PC. Both on Wifi and playing to same SBR in same room.

    Win10 took about 10 sec to start playing with plugin logging "long fetch" messages whereas Pi on 7.9.2. started immediately . I reinstalled 7.9.2. on Win10 and same issue so it was nto a 8.0 issue.

    I then turned off IPv6 on Win10 interface and BBCiPlayer streams started immediately. I noticed the same issue on some HLS station so it was not a BBC issue.

    My guess is that IPv6 DNS lookup was tried, timed out and then fell back to IPv4 DNS lookup. When IPv6 was disabled - no delay for IPV6 stuff.

    Is this a reasonable assumption ? Strange as Pi seems to have IPv6 enabled on its wifi .

  4. #1004
    Senior Member
    Join Date
    Dec 2010
    Location
    Cambridge, UK
    Posts
    961
    Unlikely given LMS has no IPv6 support at all. LMS only looks up A records, and it does the lookup itself so the OS doesn't get chance to decided to look for AAAA as well.

  5. #1005
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,574
    Quote Originally Posted by Owen Smith View Post
    Unlikely given LMS has no IPv6 support at all. LMS only looks up A records, and it does the lookup itself so the OS doesn't get chance to decided to look for AAAA as well.
    To use HTTP 1.1 in older version of LMS, BBCiPlayer and PlayHLS uses AnyEvent::HTTP which has IPv6 support. Also LMS uses AnyEvent:: DNS to resolve DNS lookup and which has IPv6 support built in and it does not look like LMS disables using IPv6 so while LMS may be IPv4 only - IPv6 DNS lookups happen. I think the AAAA lookups may only be AnyEvent related - calmradio was a standard MP3 stream.


    I ran DNSSnifferQuery which logs all DNS queries. Attached is screen shot showing IPv6 lookups.
    Name:  BBCiPlayerDNSCapture.PNG
Views: 268
Size:  24.0 KB

    edit:

    Interesting - this morning with IPv6 re-enabled - there is no delay. So something "wrong" with IPv6 DNS lookups on this W10 system yesterday.
    Last edited by bpa; 2020-04-03 at 00:08.

  6. #1006
    Junior Member
    Join Date
    Feb 2011
    Posts
    21
    I am getting the following messages on the LMS Server Plugin tab:

    Bad repository http://downloads.sourceforge.net/pro...lease-repo.xml - Connect timed out: Connection timed out

    Bad repository http://downloads.sourceforge.net/pro...repo-short.xml - Timed out waiting for data
    I am able to get to these addresses using my browser. I am running LMS 7.9.2 on piCorePlayer v6.0.0.

  7. #1007
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,453
    Happens a lot with SourceForge.
    You could switch to the alternate repo XML file ... but my guess is that a subsequent attempt to download the plugin would also fail since it comes from SourceForge as well.
    They seems to go through periods of this.
    Try again later if you are trying to install.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  8. #1008
    Member
    Join Date
    Nov 2011
    Location
    UK
    Posts
    39

    One particular BBC 6Music show that doesn't play

    I'm trying to listen to "Don Letts Culture Clash Radio" which is on 6Music at 2200 on Sundays. I used to be able to listen to this, but it's no longer working since last week. This is with a 7.9.2 server on a Rpi, latest versions of all plugins.

    A key difference between this and other 6Music shows that work OK seems to be that the URL has "mp3=" in it where most of the other shows are "dash=".

    URL: iplayer://aod?mp3=http://open.live.bbc.co.uk/mediaselector/6/redir/version/2.0/mediaset/audio-nondrm-download/proto/http/vpid/m000h83d.mp3&dash=http://open.live.bbc.co.uk/mediaselector/6/redir/version/2.0/mediaset/audio-syndication-dash/proto/http/vpid/m000h83d&dur=7200&icon=http://ichef.bbci.co.uk/images/ic/480x480/p01lcd8x.jpg&title=Don%20

    When I try to play it, this error appears in the logfile:

    [20-04-16 17:34:53.7223] Slim::Utils::Scanner::Remote::__ANON__ (192) Error: Can't connect to remote server to retrieve playlist for, http://open.live.bbc.co.uk/mediasele.../m000h83d.mp3: 404 Not Found.

    I wonder if this is this just a metadata error by the BBC or whether I really have a local problem with playing MP3s via Iplayer ?

  9. #1009
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,574
    Quote Originally Posted by tw99 View Post
    I'm trying to listen to "Don Letts Culture Clash Radio" which is on 6Music at 2200 on Sundays. I used to be able to listen to this, but it's no longer working since last week. This is with a 7.9.2 server on a Rpi, latest versions of all plugins.

    A key difference between this and other 6Music shows that work OK seems to be that the URL has "mp3=" in it where most of the other shows are "dash=".

    URL: iplayer://aod?mp3=http://open.live.bbc.co.uk/mediaselector/6/redir/version/2.0/mediaset/audio-nondrm-download/proto/http/vpid/m000h83d.mp3&dash=http://open.live.bbc.co.uk/mediaselector/6/redir/version/2.0/mediaset/audio-syndication-dash/proto/http/vpid/m000h83d&dur=7200&icon=http://ichef.bbci.co.uk/images/ic/480x480/p01lcd8x.jpg&title=Don%20

    When I try to play it, this error appears in the logfile:

    [20-04-16 17:34:53.7223] Slim::Utils::Scanner::Remote::__ANON__ (192) Error: Can't connect to remote server to retrieve playlist for, http://open.live.bbc.co.uk/mediasele.../m000h83d.mp3: 404 Not Found.

    I wonder if this is this just a metadata error by the BBC or whether I really have a local problem with playing MP3s via Iplayer ?
    MP3 just means BBC have made it available on BBC Sounds not just BBC iPlayer.

    It plays OK for me as AAC.

    1. What version of Plugin are you using ?
    2. What sort of player are you using ?
    3. Have you got MP3 in the BBCiPlayer "Stream Preference" settings - best setting is "DASH > HLS > MP3 > FlashAAC" for both "live" and "on demand"
    Last edited by bpa; 2020-04-16 at 11:10. Reason: remove MP3 playing OK

  10. #1010
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,081
    Quote Originally Posted by tw99 View Post
    I'm trying to listen to "Don Letts Culture Clash Radio" which is on 6Music at 2200 on Sundays. I used to be able to listen to this, but it's no longer working since last week. This is with a 7.9.2 server on a Rpi, latest versions of all plugins.

    A key difference between this and other 6Music shows that work OK seems to be that the URL has "mp3=" in it where most of the other shows are "dash=".

    URL: iplayer://aod?mp3=http://open.live.bbc.co.uk/mediaselector/6/redir/version/2.0/mediaset/audio-nondrm-download/proto/http/vpid/m000h83d.mp3&dash=http://open.live.bbc.co.uk/mediaselector/6/redir/version/2.0/mediaset/audio-syndication-dash/proto/http/vpid/m000h83d&dur=7200&icon=http://ichef.bbci.co.uk/images/ic/480x480/p01lcd8x.jpg&title=Don%20

    When I try to play it, this error appears in the logfile:

    [20-04-16 17:34:53.7223] Slim::Utils::Scanner::Remote::__ANON__ (192) Error: Can't connect to remote server to retrieve playlist for, http://open.live.bbc.co.uk/mediasele.../m000h83d.mp3: 404 Not Found.

    I wonder if this is this just a metadata error by the BBC or whether I really have a local problem with playing MP3s via Iplayer ?
    Using iPlayer it plays as 320kbps AAC for me.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •