Home of the Squeezebox™ & Transporter® network music players.
Page 8 of 8 FirstFirst ... 678
Results 71 to 74 of 74
  1. #71
    Senior Member
    Join Date
    Mar 2008
    Posts
    119
    Quote Originally Posted by bpa View Post
    The menus just above the MP3 ones.

    Problems is unlikely to be DNS as lookup only happens once with http 1.1.
    Any message in log file from bbciplayrer ?
    alt cdn is just the same.

    No interesting log file messages: just some of these:

    [18-12-11 21:07:11.0587] Plugins::BBCiPlayer::DASH::__ANON__ (777) Chunk fetch status 200 Long chunk fetch time 2027 1000
    [18-12-11 21:07:12.1629] Plugins::BBCiPlayer::DASH::__ANON__ (777) Chunk fetch status 200 Long chunk fetch time 3129 1000

  2. #72
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,470
    Quote Originally Posted by bstrulo View Post
    alt cdn is just the same.

    No interesting log file messages: just some of these:

    [18-12-11 21:07:11.0587] Plugins::BBCiPlayer:ASH::__ANON__ (777) Chunk fetch status 200 Long chunk fetch time 2027 1000
    [18-12-11 21:07:12.1629] Plugins::BBCiPlayer:ASH::__ANON__ (777) Chunk fetch status 200 Long chunk fetch time 3129 1000
    If there are a lot of them, they are indicative of slow response from BBC CDN servers which won't help things but the delays aren't big enough to be cause of rebuffering.

  3. #73
    Junior Member
    Join Date
    Sep 2015
    Posts
    26

    BBC iPlayer - RTMP for non-BBC streams.

    Hello again bpa,

    I posted earlier in the old thread that the fix you offered a year or so ago, to stream [Egyptian Radio & Television Union] ERTU audio to the Squeezebox Radio didn't work anymore. I was wrong, but a strange issue persists.

    Let me explain.

    The stream in question is the Local European service of Radio Cairo (and similar streams from ERTU: egradio.eg).

    The URL is:

    Code:
    rtmp://liveRadio.onlinehorizons.net/ElBernamegElOrobi   -W http://lr.onlinehorizons.net/player.swf -p http://lr.onlinehorizons.net/ElBernamegElOrobi.html -v  -y livestream -B 10
    The URL processed by the BBC iPlayer plugin entered as favorite in LMS is

    Code:
    rtmp://liveRadio.onlinehorizons.net:1935?streamname=bGl2Z XN0cmVhbQ==&app=RWxCZXJuYW1lZ0VsT3JvYmk=&live=MQ== &swfurl=aHR0cDovL2xyLm9ubGluZWhvcml6b25zLm5ldC9wbG F5ZXIuc3dm&tcurl=cnRtcDovL2xpdmVSYWRpby5vbmxpbmVob 3Jpem9ucy5uZXQvRWxCZXJuYW1lZ0VsT3JvYmk=&pageurl=aH R0cDovL2xyLm9ubGluZWhvcml6b25zLm5ldC9FbEJlcm5hbWVn RWxPcm9iaS5odG1s&.mp3
    As bpa explained, the BBCiPlayer "uses base64 encoding of the various params so it can be internally passed transparently" hence the conversion.

    The next part of the solution was to replace the rtmp.pm file in the plugin with a modified version he provided which supports the pageurl parameter (not used for BBC streams).

    The result then as now, is that bpa's version did not work INITIALLY. When I tried to play on an SB radio, I'd get 'Connection reset by remote host' on the Radio Console, and on the LMS display, it would stop trying to play after a few seconds.

    But then by chance, I found out that if I synchronized my two SBs to play together, I could start the stream on either of them and playback would work I could then turn off the one I didn't need on. This I found to be a very strange workaround.

    Any explanation, or fix ?


    gc

  4. #74
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,470
    Quote Originally Posted by George_C View Post
    Hello again bpa,

    I posted earlier in the old thread that the fix you offered a year or so ago, to stream [Egyptian Radio & Television Union] ERTU audio to the Squeezebox Radio didn't work anymore. I was wrong, but a strange issue persists.

    .
    .
    .

    gc
    I asked that this question be put into a spearate thread -. It is dealing with a non BBC Flash stream which will take a a number of post and clutter up this BBC only non Flash thread which doesl not involve RTMP.

    Having a separate thread will also make it easier to revist in the future if necessary.

    This problem feel like a setup problem so please include all system details in the new thread: your OS & system (If windows processor & mem) , LMS version, players types etc.
    What version of LMS

    Please post question in a separate dedicated thread of its own.
    Last edited by bpa; Yesterday at 01:47.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •