Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24
  1. #21
    Junior Member
    Join Date
    Oct 2018
    Posts
    18
    Quote Originally Posted by paul- View Post
    The pullup/down resistors are set via sbpd. (If that is what you are still using)

    GPIO 2 & 3 have internal pull up resistors.
    I'm using it actually, is there any alternative which gives some more control of it?
    I'll re-install the SD-card (I've cracked the old one...don't ask!) and then check the verbose output.
    Regards,
    Maeffjus

  2. #22
    Junior Member
    Join Date
    Oct 2018
    Posts
    18
    Some update guys:

    With the verbose output, there is almost random crap that comes out the on the shell.
    It looks like I'm pressing at least 3 random buttons at once for any random button that I press.

    I have had some idea, but did not try it (I'd like to hear about your opinion first):

    What if for some reason there is electricity flowing from the pressed button (for whatever reason) through one of the wires and back fro any else GPIO's?

    First idea:
    Could I probably use a diode to make sure that the voltage / current only goes one way? If yo, what diode would you recommend? (Do you have some spec suitable for the 3.3V and the GPIO)

    Second idea:
    Is it possible that somehow the electricity from the the touch-controller it "too much" or the voltage is too high?
    If you can agree here more that to the above (#1) - what if I will add some resistor? Actually the voltage output is roughly the 3.3V of the touch-controllers input.
    What would you recommend if terms of the resistance?

    Any help is highly appreciated! The wife acceptance factor of the radio is rapidly decreasing ;-)

    Regrads,
    Matthias

  3. #23
    Senior Member
    Join Date
    Jan 2006
    Posts
    219
    Quote Originally Posted by maeffjus View Post
    Any help is highly appreciated! The wife acceptance factor of the radio is rapidly decreasing ;-)
    I cannot help with debugging your switches but am definitely rooting for you to figure it out, as I already showed the photos of your controller buttons and display to my wife and she's now expecting me to build something like that!

    Greg

  4. #24
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,564
    I was playing with my sensors yesterday, and the are pretty sensitive. I didnĺt even have to touch them to activate the sensor. I think it could just be that the sensors are too close together, Not sure if you can remove the sensors and spread them out to see if the problem goes away.

    I was thinking about trying this device......https://www.adafruit.com/product/1602. This is an i2c device, so youĺll have to do some programming, but python isnĺt bad.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •