Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Junior Member
    Join Date
    Apr 2008
    Posts
    22

    logitech media server not visible on port

    I have a sheevaplug (debian 7.11) with logitechmediaserver_7.8.0_all.deb installed.
    All was working well until it seemed to have a problem scanning the music directory and I rebooted the sheevaplug.
    Now it is not broadcasing on 9000 i.e.

    nmap sheevaplug
    Not shown: 997 closed ports
    PORT STATE SERVICE
    22/tcp open ssh
    111/tcp open rpcbind
    2049/tcp open nfs

    any guidance?

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,473
    Check the LMS server.log file for any message - it looks like LMS is not running.

  3. #3
    Junior Member
    Join Date
    Apr 2008
    Posts
    22
    Quote Originally Posted by bpa View Post
    Check the LMS server.log file for any message - it looks like LMS is not running.
    Hi bpa,

    It seems to be running -- it appears in top.

    # ps -ef | grep squeezeboxserver
    103 4412 1 0 Nov12 ? 00:03:49 /bin/bash /usr/sbin/squeezeboxserver_safe /usr/sbin/squeezeboxserver --prefsdir /var/lib/squeezeboxserver/prefs --logdir /var/log/squeezeboxserver/ --cachedir /var/lib/squeezeboxserver/cache --charset=utf8

    103 19825 4412 90 19:33 ? 00:00:06 /usr/bin/perl /usr/sbin/squeezeboxserver --prefsdir /var/lib/squeezeboxserver/prefs --logdir /var/log/squeezeboxserver/ --cachedir /var/lib/squeezeboxserver/cache --charset=utf8 --norestart
    root 19828 19761 0 19:34 pts/0 00:00:00 grep squeezeboxserver

    but there are no log files in /var/log/squeezeboxserver

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,473
    Quote Originally Posted by parsifal9 View Post
    Hi bpa,

    It seems to be running -- it appears in top.

    # ps -ef | grep squeezeboxserver
    103 4412 1 0 Nov12 ? 00:03:49 /bin/bash /usr/sbin/squeezeboxserver_safe /usr/sbin/squeezeboxserver --prefsdir /var/lib/squeezeboxserver/prefs --logdir /var/log/squeezeboxserver/ --cachedir /var/lib/squeezeboxserver/cache --charset=utf8

    103 19825 4412 90 19:33 ? 00:00:06 /usr/bin/perl /usr/sbin/squeezeboxserver --prefsdir /var/lib/squeezeboxserver/prefs --logdir /var/log/squeezeboxserver/ --cachedir /var/lib/squeezeboxserver/cache --charset=utf8 --norestart
    root 19828 19761 0 19:34 pts/0 00:00:00 grep squeezeboxserver

    but there are no log files in /var/log/squeezeboxserver
    squeezeboxserver_safe has run for 3:49 CPU but squeezeboxserver has only 6 sec CPU and process id is very high compare to "-safe" ( and only 3 less than your grep !) - is squeezebixsever starting, crashing and then being restarted ? Look at process number with mulitple greps - does it change ?

    If no logs - have you run out of disk space ? have permissions be changed ? have you checked disk/filesystem is OK ? Could squeezeboxserver install be corrupted perhaps due to disk error ? Any messages in your system log ?

    edit:

    If you can, stop the daemon version of squeezeboxserver and try running from a shell prompt.
    Last edited by bpa; 2018-11-17 at 01:48.

  5. #5
    Senior Member
    Join Date
    Sep 2005
    Posts
    2,719
    Quote Originally Posted by parsifal9 View Post
    but there are no log files in /var/log/squeezeboxserver
    CHECK your permisons for /var/log/squeezeboxserver !

    When lms cant read/write the logs it would crash and -safe will restart it.

  6. #6
    Junior Member
    Join Date
    Apr 2008
    Posts
    22
    Hi bpa and DJanGo,

    1) when I first started having this problem, I noticed that there was no /var/log/squeezeboxserver so I made it
    ls -l
    drwxr-xr-x 2 root root 160 Nov 12 17:10 squeezeboxserver

    2) I have now made a world writable server.log
    cd squeezeboxserver/
    touch server.log
    chmod oug+wr server.log

    3) I am now getting messages in /var/log/squeezeboxserver/server.log
    2018-11-18 19:45:52 Logitech Media Server died. Restarting.
    2018-11-18 19:46:01 Logitech Media Server died. Restarting.
    2018-11-18 19:46:10 Logitech Media Server died. Restarting.

    There is nothing about this in syslog and there is no problem with diskspace.

    so thanks for your comments. I am one step closer than I was

  7. #7
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,171
    Perhaps the missing log directory is a sign of more significant file system corruption.
    Might be easier to wipe the Sheevaplug and start again - provided the various tooling is still available.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  8. #8
    Senior Member
    Join Date
    Sep 2005
    Posts
    2,719
    Quote Originally Posted by DJanGo View Post
    CHECK your permisons for /var/log/squeezeboxserver !

    When lms cant read/write the logs /var/log/squeezeboxserver it would crash and -safe will restart it.
    That means ALL logs not only server.log

    chown -R squeezeboxserver:nogroup /var/log/squeezeboxserver

  9. #9
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,473
    Quote Originally Posted by parsifal9 View Post
    3) I am now getting messages in /var/log/squeezeboxserver/server.log
    2018-11-18 19:45:52 Logitech Media Server died. Restarting.
    2018-11-18 19:46:01 Logitech Media Server died. Restarting.
    2018-11-18 19:46:10 Logitech Media Server died. Restarting.

    There is nothing about this in syslog and there is no problem with diskspace.
    Copnfirms that LMS is restartig and failing due to some problem.

    You need to be very careful checking all possible disk spaces - for example LMS Cache may have been assigned to a temp area perhaps on a different partition.

    Can you start LMS from a shell prompt with the additional commandline option "-d_startup" . If log file is not "working" running from a shell prompt will also generate log output on console.

  10. #10
    Junior Member
    Join Date
    Apr 2008
    Posts
    22
    Quote Originally Posted by DJanGo View Post
    That means ALL logs not only server.log

    chown -R squeezeboxserver:nogroup /var/log/squeezeboxserver
    I did that and it all seems to be working now. It made several log files, perfmon.log, scanner.log and server.log.
    There is some sort of exception in scanner.log but everything seems to be working as expected.
    -
    Thanks and Bye


    [18-11-19 17:26:10.8442] main::init (368) Starting Logitech Media Server (v7.8.0, 1395409907, Thu Mar 27 13:20:53 PDT 2014) perl 5.014002
    [18-11-19 17:26:20.4048] Slim::Utils::SQLiteHelper:ostConnect (359) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-11-19 17:26:50.4749] Slim::Schema::Storage::throw_exception (122) Error: DBI Exception: DBD::SQLite::db do failed: database is locked [for Statement "ANALYZE;"]
    [18-11-19 17:26:50.4857] Slim::Schema::Storage::throw_exception (122) Backtrace:

    frame 0: Slim::Utils::Log::logBacktrace (/usr/share/perl5/Slim/Schema/Storage.pm line 122)
    frame 1: Slim::Schema::Storage::throw_exception (/usr/share/squeezeboxserver/CPAN/DBIx/Class/Storage/DBI.pm line 1006)
    frame 2: DBIx::Class::Storage:BI::__ANON__ (/usr/share/perl5/Slim/Utils/SQLHelper.pm line 83)
    frame 3: (eval) (/usr/share/perl5/Slim/Utils/SQLHelper.pm line 83)
    frame 4: Slim::Utils::SQLHelper::executeSQLFile (/usr/share/perl5/Slim/Schema.pm line 445)
    frame 5: (eval) (/usr/share/perl5/Slim/Schema.pm line 444)
    frame 6: Slim::Schema:ptimizeDB (/usr/share/perl5/Slim/Utils/SQLiteHelper.pm line 360)
    frame 7: Slim::Utils::SQLiteHelper:ostConnect (/usr/share/perl5/Slim/Schema.pm line 314)
    frame 8: Slim::Schema::_connect (/usr/share/perl5/Slim/Schema.pm line 129)
    frame 9: Slim::Schema::init (/usr/sbin/squeezeboxserver line 526)
    frame 10: main::init (/usr/sbin/squeezeboxserver line 656)
    frame 11: main::main (/usr/sbin/squeezeboxserver line 1192)

    [18-11-19 17:26:50.4894] Slim::Utils::SQLHelper::executeSQLFile (85) Error: Couldn't execute SQL statement: [ANALYZE;] : [Carp::Clan::__ANON__(): DBI Exception: DBD::SQLite::db do failed: database is locked [for Statement "ANALYZE;"] at /usr/share/perl5/Slim/Schema/Storage.pm line 126

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •