Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,665
    Now that's great news! And thank you very much for the detailed information!
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  2. #12
    Senior Member pippin's Avatar
    Join Date
    Oct 2007
    Location
    Berlin
    Posts
    14,791
    Many thanks, Tony. Took a while (a ton of error in the tests) but actually works, well done!
    ---
    learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
    Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
    at penguinlovesmusic.com
    New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

  3. #13
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,187
    Quote Originally Posted by pippin View Post
    Many thanks, Tony. Took a while (a ton of error in the tests) but actually works, well done!
    Good to know that you were able to re-produce the update/install of those perl modules
    Tony
     SBTouch ♪ SBRadio ♬

  4. #14
    Hi,

    this is still weird

    updated to 8.1.1 to get FLAC working.
    noticed this error:
    Starting Squeezebox Server: You're using a rather old version of IO::Socket::SSL (v1.94) - please try to update to at least 2.020 for improved compatibility.

    Stoped LMS, updated IO::Socket::SSL (IO::Socket::SSL is up to date (2.070)) and still get the error on LMS startup


    I'm on Centos 7.8

    Reinhold

  5. #15
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,665

    =?utf-8?q?Error=3A_Can=27t_connect_t?==?utf-8?q?o_remote_server_to_retrieve=2E?=

    > Stoped LMS, updated IO::Socket::SSL (IO::Socket::SSL is up to date
    > (2.070)) and still get the error on LMS startup


    Could you please provide a little more context? server.log?

  6. #16
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,997
    Quote Originally Posted by mherger View Post
    > Stoped LMS, updated IO::Socket::SSL (IO::Socket::SSL is up to date
    > (2.070)) and still get the error on LMS startup


    Could you please provide a little more context? server.log?
    On another thread - a bit later.
    Quote Originally Posted by achtbit View Post
    LMS 8.1.1 and Deezer FLAC!!!

    Some minor glitches but all went fine. Got it working

    FLAC on SB Radio is a must

    May already be fixed ?

  7. #17
    I noticed two things:

    1) From systemctl status squeezeboxserver.service I get this message regarding IO::Socket::SSL . I found this thread abount IO::Socket::SSL to update it to the newest version. Error is still there after update.
    ...
    Mar 19 11:08:46 cube squeezeboxserver[5250]: Starting Squeezebox Server: You're using a rather old version of IO::Socket::SSL (v1.94) - please try to update to...atibility.
    ...
    server.log from startup just one line
    [21-03-19 15:03:21.9142] main::init (388) Starting Logitech Media Server (v8.1.1, 1610364019, Thu Jan 14 06:20:31 CET 2021) perl 5.016003 - x86_64-linux-thread-multi

    [root@cube squeezeboxserver]# /usr/bin/perl -MCPAN -e 'install IO::Socket::SSL'
    Reading '/root/.cpan/Metadata'
    Database was generated on Fri, 19 Mar 2021 05:41:03 GMT
    IO::Socket::SSL is up to date (2.070).


    2) SSL_verity_mode: having SSL verify enable in LMS I get the following error

    [21-03-19 11:43:45.0091] Slim::Utils::Misc::msg (1266) Warning: [11:43:45.0084]
    ************************************************** *****************
    Using the default of SSL_verify_mode of SSL_VERIFY_NONE for client
    is deprecated! Please set SSL_verify_mode to SSL_VERIFY_PEER
    possibly with SSL_ca_file|SSL_ca_path for verification.
    If you really don't want to verify the certificate and keep the
    connection open to Man-In-The-Middle attacks please set
    SSL_verify_mode explicitly to SSL_VERIFY_NONE in your application.
    ************************************************** *****************
    at /usr/lib64/perl5/Slim/Networking/Async/HTTP.pm line 144.

    To get rid of I disable SSL check in LMS.


    As I'm lazy on sorting this out I'm fine with SSL check disabled.
    @Michael, of course I can provide more info if requested

    btw. it's an rpm update installation from 7.???

    Edit:
    the warning about SSL is also in old logfiles
    Last edited by achtbit; 2021-03-19 at 07:21.

  8. #18
    Junior Member boboS's Avatar
    Join Date
    Sep 2021
    Posts
    4
    I had to do this today on my Mac Mini with macOS High Sierra 10.13.6:

    This is what worked for me:
    1. Install Homebrew, see https://brew.sh/. Currently this is done by >/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"
    2. >brew install openssl (install latest version of OpenSSL from the Terminal)
    3. >export CPATH=/usr/local/opt/openssl/include
    4. >export LIBRARY_PATH=/usr/local/opt/openssl/lib
    5. >sudo /usr/bin/perl -MCPAN -e 'install Net::SSLeay'
    6. >sudo /usr/bin/perl -MCPAN -e 'install IO::Socket::SSL'


    Remark: >cpan install Crypt::OpenSSL::RSA did produce errors and aborted - but I really do not know what I'm doing here. The above sequenced worked.

    LMS tells me in the info that I'm now using IO::Socket::SSL: 2.072 instead of the old 1.966. LMS is now able to download updates, etc.

  9. #19
    Junior Member
    Join Date
    Dec 2019
    Posts
    9
    We ran into similar issues on Fedora Linux.

    Our version did not have CPAN installed, so to upgrade IO::Socket::SSL to version 2.072, we used:

    yum install perl-CPAN
    /usr/bin/perl -MCPAN -e 'install Net::SSLeay'
    /usr/bin/perl -MCPAN -e 'install IO::Socket::SSL'

    It drops the updated perl modules into /usr/local/share/perl5/ and the version is for sure now up to date:

    # perl -MIO::Socket::SSL -e 'print $IO::Socket::SSL::VERSION ."\n";'
    2.072

    and also visible from within LMS

    Logitech Media Server Status
    IO::Socket::SSL: 2.072

    On fedora versions where the ca-certificates package is no longer updated, you can update the root certs as follows:

    curl --insecure https://curl.se/ca/cacert.pem -o /etc/pki/ca-trust/source/anchors/curl-cacert-updated.pem && update-ca-trust

    Then restart LMS and under the LMS Advanced/Security settings, you no longer will need to disable the certificate verification on HTTPS connections as a workaround.
    Last edited by FredericV; 2021-12-03 at 10:51.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •