Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6

Thread: pcp + LMS + NAS

  1. #1

    pcp + LMS + NAS

    Hi.
    I┤m new to picorePlayer and need some help.
    I'm trying to set up a raspberry B+ as a LMS server with a NETGEAR STORA NAS with all my music.
    I have different subfolders on the NAS.

    /FamilyLibrary/Familymusic/
    /MyLibrary/MyMusic/FLAC/
    /MyLibraryMyMusic/Mp3/
    /MyLibraryMyMusic/Hires/

    I┤ve tried pcp vers 3.50 and vers 4.0 and get the same problem.
    In the tab "LMS" for -Setup Network Disk Mount- I cannot specify the subfolders. (It refuses to accept any / or \ for path)

    Name:  LMS-tab.PNG
Views: 309
Size:  28.2 KB

    The additional filesystem is installed and Squeezelite and LMS are running.

    I have a VOLUMIO player and a SONOS system that recognize the path:s and the NAS is accessible in my windows computers.

    How can I get my NAS connectet to LMS?

    Thanks in advance
    /Lennart

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,171
    Try changing them to
    FamilyLibrary
    and
    MyLibrary

    and then put the remaining path into LMS itself
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  3. #3
    Thanks for the suggestion.
    Will try this tomorrow.

    /Lennart

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,505
    You also need to specify the SMB version to connect with, if you expand the more> in the section it describes the fields.

    Code:
    <Options> are a comma delimited list of mount options. Ref mount man pages.
    CIFS
    vers=2.0 - The linux kernel now defaults to SMB version 3.0, versions must be specified.
    uid=1001 - mounts the drive with user "tc". Useful if using ssh sessions to write data to share.
    gid=50 - mounts the drive with group "staff". Useful if using ssh sessions to write data to share.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    I normally just use Root in Mount Point then just pick folders if needed in LMS settings

  6. #6
    Now I┤m up and running.
    The trix was to just specify the parent folder in pcp and also set vers=1.0.
    Then I was able to point to the subfolders in LMS

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •