Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: pcp + LMS + NAS

  1. #21
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,146
    Maybe the Windows Event Viewer will show something.

    Open Event Viewer (and wait for it to build a display) and then expand Applications and Services Logs.
    Expand the Microsoft folder.
    Expand the Windows folder.
    Expand the SMBServer folder and then click the channels

    Then if that does not provide the answer ... it might mean that you will have to run a network tracer, such as Wireshark, to see what it sees.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  2. #22
    Senior Member
    Join Date
    May 2017
    Posts
    773
    Quote Originally Posted by Paul Webster View Post
    Maybe the Windows Event Viewer will show something.

    Open Event Viewer (and wait for it to build a display) and then expand Applications and Services Logs.
    Expand the Microsoft folder.
    Expand the Windows folder.
    Expand the SMBServer folder and then click the channels

    Then if that does not provide the answer ... it might mean that you will have to run a network tracer, such as Wireshark, to see what it sees.
    Whow, that helps. Found:
    SMB Session Authentication Failure

    Client Name: \\192.168.xxx.yy
    Client Address: 192.168.1xxx.yyy:57844
    User Name:
    Session ID: 0x6C0594000059
    Status: An invalid parameter was passed to a service or function. (0xC000000D)
    SPN: session setup failed before the SPN could be queried
    SPN Validation Policy: SPN optional / no validation

    Guidance:

    You should expect this error when attempting to connect to shares using incorrect credentials.

    This error does not always indicate a problem with authorization, but mainly authentication. It is more common with non-Windows clients.

    This error can occur when using incorrect usernames and passwords with NTLM, mismatched LmCompatibility settings between client and server, an incorrect service principal name, duplicate Kerberos service principal names, incorrect Kerberos ticket-granting service tickets, or Guest accounts without Guest access enabled

    Looks like it's either a vers issue or just a typo (could have sworn i used the right credentials). Will dig into this after the weekend.
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's (SB2, SB3, Boom, Touch)
    Server: LMS on Pi3B+ 8.1.2 on PcP 7.0.1
    Network: Draytek, Netgear Smart Switch 24p, Ubiquiti PoE, 3x Ubiquity

  3. #23
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    610
    Which domain is the Win server in?
    Are clocks the same on all machines? Windows auth can barf if they differ.
    Make sure you haven't got a non-std NTLM policy enabled on the server (GPO) as that can kick out many clients.
    Use a strong password as Windows often doesn't permit weak ones.

  4. #24
    Senior Member
    Join Date
    May 2017
    Posts
    773
    Quote Originally Posted by mr-b View Post
    Which domain is the Win server in?
    Are clocks the same on all machines? Windows auth can barf if they differ.
    Make sure you haven't got a non-std NTLM policy enabled on the server (GPO) as that can kick out many clients.
    Use a strong password as Windows often doesn't permit weak ones.
    Just a dot local domain, no self created GPO's.
    Clock should be ok since pi has rebooted several times and is running periodically Ntp sync.

    The password could be something interesting, even if I have loosen the policy on that.
    The non standard NTLM policy I don't get. Which one do you mean?
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's (SB2, SB3, Boom, Touch)
    Server: LMS on Pi3B+ 8.1.2 on PcP 7.0.1
    Network: Draytek, Netgear Smart Switch 24p, Ubiquiti PoE, 3x Ubiquity

  5. #25
    Senior Member
    Join Date
    May 2017
    Posts
    773
    Still the same strugle. Now installed NFS server role and tried to mount that. Still the same problem.
    Next will be to rebuild the pi with latest version but is bit hesitated about that because all the setting i would have to make again to get thing running like i'm (and the rest of the family) is used to.
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's (SB2, SB3, Boom, Touch)
    Server: LMS on Pi3B+ 8.1.2 on PcP 7.0.1
    Network: Draytek, Netgear Smart Switch 24p, Ubiquiti PoE, 3x Ubiquity

  6. #26
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    610
    Sorry to hear your continued woes. Does the nfs mount gave you the same errors as with SMB?

    To backup LMS config on PCP I've used WinSCP to copy everything under /usr/local/slimserver/prefs - then I restored it onto another PCP and LMS worked just fine.
    See also http://wiki.slimdevices.com/index.php/Backup

    I know PCP's "Backup" button backs up files to /mnt/mmcblk0p2/tce/mydata.tgz but I don't yet know exactly which functions that covers nor how to restore it (no Restore button).

  7. #27
    Senior Member
    Join Date
    May 2017
    Posts
    773
    Yes, nfs gave be basic the same error being no connection, please reboot or something like that. That gave me the idea that perhaps the problem lies in the older pcp version I use. Thanks for backup direction. Exactly what I needed.
    If this also fails I will have no other solution that installing lms on the server but I'm trying to avoid that. If lms on the server I can't tinkle with the server without hindering the rest of the family.
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's (SB2, SB3, Boom, Touch)
    Server: LMS on Pi3B+ 8.1.2 on PcP 7.0.1
    Network: Draytek, Netgear Smart Switch 24p, Ubiquiti PoE, 3x Ubiquity

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •