Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: pcp + LMS + NAS

  1. #1

    pcp + LMS + NAS

    Hi.
    I┤m new to picorePlayer and need some help.
    I'm trying to set up a raspberry B+ as a LMS server with a NETGEAR STORA NAS with all my music.
    I have different subfolders on the NAS.

    /FamilyLibrary/Familymusic/
    /MyLibrary/MyMusic/FLAC/
    /MyLibraryMyMusic/Mp3/
    /MyLibraryMyMusic/Hires/

    I┤ve tried pcp vers 3.50 and vers 4.0 and get the same problem.
    In the tab "LMS" for -Setup Network Disk Mount- I cannot specify the subfolders. (It refuses to accept any / or \ for path)

    Name:  LMS-tab.PNG
Views: 744
Size:  28.2 KB

    The additional filesystem is installed and Squeezelite and LMS are running.

    I have a VOLUMIO player and a SONOS system that recognize the path:s and the NAS is accessible in my windows computers.

    How can I get my NAS connectet to LMS?

    Thanks in advance
    /Lennart

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,599
    Try changing them to
    FamilyLibrary
    and
    MyLibrary

    and then put the remaining path into LMS itself
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #3
    Thanks for the suggestion.
    Will try this tomorrow.

    /Lennart

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,155
    You also need to specify the SMB version to connect with, if you expand the more> in the section it describes the fields.

    Code:
    <Options> are a comma delimited list of mount options. Ref mount man pages.
    CIFS
    vers=2.0 - The linux kernel now defaults to SMB version 3.0, versions must be specified.
    uid=1001 - mounts the drive with user "tc". Useful if using ssh sessions to write data to share.
    gid=50 - mounts the drive with group "staff". Useful if using ssh sessions to write data to share.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    I normally just use Root in Mount Point then just pick folders if needed in LMS settings

  6. #6
    Now I┤m up and running.
    The trix was to just specify the parent folder in pcp and also set vers=1.0.
    Then I was able to point to the subfolders in LMS

  7. #7
    Senior Member
    Join Date
    May 2017
    Posts
    652
    Just to resurrect an older thread.
    Trying to mount to a share located on a Windows Server 2019 box. Tried vers=1.0 and vers-2.0 without any luck despite the fact that i enabled SMB1 for testing purposes.

    edit. Running in circles. Unable to find the referred "mount man pages" Tried options like uid=1001,gid=50,vers=1.0 and vers=2.0 still no luck. Even tried adding domain=MyDomain
    Changed access rights of network share to allow everyone, no change. Unable to figure out where the problem lies. Is it plain access or credentials. Double checked credentials even logged in via android phone. No problem but pcp refuseses to make a proper connection while connecting to the old Windows XP box is no problem.
    Want to switch over to the new proper files server but LMS/PcP is preventing the last step at the moment.
    Last edited by edwin2006; 2020-05-10 at 08:40.
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's
    Server: LMS on Pi3 7.9.1. on PcP 3.21
    Network: AVM Fritzbox, Netgear Smart Switch 24p, 3x Ubiquity

  8. #8
    Senior Member
    Join Date
    May 2017
    Posts
    652
    Anyone?
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's
    Server: LMS on Pi3 7.9.1. on PcP 3.21
    Network: AVM Fritzbox, Netgear Smart Switch 24p, 3x Ubiquity

  9. #9
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,499
    Quote Originally Posted by edwin2006 View Post
    Anyone?
    Want to switch over to the new proper files server but LMS/PcP is preventing the last step at the moment.
    Why not install LMS on the server, a much better idea !

    Jeff

    Want a webapp ? Get SqueezeLite-X ! https://forums.slimdevices.com/showt...l=1#post903953

  10. #10
    Senior Member
    Join Date
    May 2017
    Posts
    652
    Because it runs perfectly on the pi
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's
    Server: LMS on Pi3 7.9.1. on PcP 3.21
    Network: AVM Fritzbox, Netgear Smart Switch 24p, 3x Ubiquity

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •