Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 35
  1. #11
    Senior Member Chunkywizard's Avatar
    Join Date
    Feb 2009
    Location
    Sindlesham, UK
    Posts
    878
    [root@wandboard ~]# sudo pacman -S perl-io-socket-ssl
    resolving dependencies...
    looking for conflicting packages...

    Packages (3) perl-net-ssleay-1.85-2 perl-uri-1.74-2
    perl-io-socket-ssl-2.060-1

    Total Download Size: 0.40 MiB
    Total Installed Size: 1.46 MiB

    :: Proceed with installation? [Y/n] Y
    :: Retrieving packages ...
    perl-net-ssleay-1.8... 198.4 KiB 1527K/s 00:00 [######################] 100%
    perl-uri-1.74-2-any 78.4 KiB 560K/s 00:00 [######################] 100%
    perl-io-socket-ssl-... 136.1 KiB 619K/s 00:00 [######################] 100%
    (3/3) checking keys in keyring [######################] 100%
    (3/3) checking package integrity [######################] 100%
    (3/3) loading package files [######################] 100%
    (3/3) checking for file conflicts [######################] 100%
    (3/3) checking available disk space [######################] 100%
    (1/3) installing perl-net-ssleay [######################] 100%
    (2/3) installing perl-uri [######################] 100%
    (3/3) installing perl-io-socket-ssl [######################] 100%
    [root@wandboard ~]#
    Squeezebox: Boom x2 (Kitchen and Office), Radio x2 (Lounge and Bedroom)
    Server: 7.8 for Wandboard Dual
    Plugins: Dynamic Playlists | SQL Playlist | Music Information Screen | TrackStat
    Remote: iPhone5/iPad Air running iPeng
    Music: Last.fm

  2. #12
    Senior Member Chunkywizard's Avatar
    Join Date
    Feb 2009
    Location
    Sindlesham, UK
    Posts
    878
    It all seems to have worked, but after a reboot, I still get the message

    Spotty requires the Perl module IO::Socket::SSL. You can NOT use Spotty without this module. Please use your operating system's package manager to install it.

    Any ideas?

    CW
    Squeezebox: Boom x2 (Kitchen and Office), Radio x2 (Lounge and Bedroom)
    Server: 7.8 for Wandboard Dual
    Plugins: Dynamic Playlists | SQL Playlist | Music Information Screen | TrackStat
    Remote: iPhone5/iPad Air running iPeng
    Music: Last.fm

  3. #13
    Junior Member
    Join Date
    Jul 2016
    Location
    Cumbria, UK
    Posts
    22
    Glad you have backed up

    Part 1: No problems there, 0 loaded units listed, is a good sign when listing failed units.

    Part 2: I don't think there is any major concern, it's a little difficult to tell as the output is truncated.

    The section [Nov 12 09:58:05-06 wandboard kernel:] has errors related to wifi and what looks like a camera, I don't think its a major worry unless it starts coming up a lot. I'm guessing you don't actually have a camera conected and your wifi is generally behaving?

    The section [Nov 12 09:58:18-19 wandboard nmbd[378]/smbd[381]:] relate to Samba which allows Linux and Windows to talk over a network. Again if you are not noticing any major problems with whatever file sharing you are doing I would not worry too much. Most of this section is trucated to it's difficult to tell without seeing the missing bits.

    The last entry [Nov 12 09:58:21 wandboard kernel]] Is trucated but I belive it reads "imx-ipuv3 imx-ipuv3.0: WARNING: adapt panel end blank lines" not sure but I think this relates to a problem with HDMI.

    Part 3: It says you have a conflict with ca-certificates-cacert. Digging around it looks like this might be a bug in Arch (not sure).

    Part 4: Installing perl-io-socket-ssl looks like it went fine. Unfortunately it has not helped
    It appears people have got around this by building perl-io-socket-ssl manually

    Sorry I've not really helped.
    Last edited by milk; 2018-11-12 at 13:46. Reason: Misread testing package version.

  4. #14
    Junior Member
    Join Date
    Jul 2016
    Location
    Cumbria, UK
    Posts
    22

  5. #15
    Senior Member Chunkywizard's Avatar
    Join Date
    Feb 2009
    Location
    Sindlesham, UK
    Posts
    878
    Good find! Iĺll try this tomorrow

    Cheers for all your help

    CW
    Squeezebox: Boom x2 (Kitchen and Office), Radio x2 (Lounge and Bedroom)
    Server: 7.8 for Wandboard Dual
    Plugins: Dynamic Playlists | SQL Playlist | Music Information Screen | TrackStat
    Remote: iPhone5/iPad Air running iPeng
    Music: Last.fm

  6. #16
    Senior Member Chunkywizard's Avatar
    Join Date
    Feb 2009
    Location
    Sindlesham, UK
    Posts
    878
    Oops, with this tinkering I seem to have broken my access to the wand board via Putty. I was just using the IP address (which is static) and port 22 with root/root, which used to work. It now doesnĺt. Any idea what I have done?

    CW
    Squeezebox: Boom x2 (Kitchen and Office), Radio x2 (Lounge and Bedroom)
    Server: 7.8 for Wandboard Dual
    Plugins: Dynamic Playlists | SQL Playlist | Music Information Screen | TrackStat
    Remote: iPhone5/iPad Air running iPeng
    Music: Last.fm

  7. #17
    Senior Member Chunkywizard's Avatar
    Join Date
    Feb 2009
    Location
    Sindlesham, UK
    Posts
    878
    A reboot fixed the login, here's what your link did

    root@wandboard ~]# sudo pacman -Scc

    Cache directory: /var/cache/pacman/pkg/
    :: Do you want to remove ALL files from cache? [y/N] y
    removing all files from cache...

    Database directory: /var/lib/pacman/
    :: Do you want to remove unused repositories? [Y/n] y
    removing unused sync repositories...
    [root@wandboard ~]# sudo pacman -S perl perl-digest-sha1 perl-io-socket-ssl perl-net-ssleay perl-uri perl-xml-parser
    warning: perl-io-socket-ssl-2.060-1 is up to date -- reinstalling
    warning: perl-net-ssleay-1.85-2 is up to date -- reinstalling
    warning: perl-uri-1.74-2 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: logitechmediaserver-7.9-cpan: requires perl<5.21
    :: logitechmediaserver-7.9-lms: requires perl<5.21
    Squeezebox: Boom x2 (Kitchen and Office), Radio x2 (Lounge and Bedroom)
    Server: 7.8 for Wandboard Dual
    Plugins: Dynamic Playlists | SQL Playlist | Music Information Screen | TrackStat
    Remote: iPhone5/iPad Air running iPeng
    Music: Last.fm

  8. #18
    Junior Member
    Join Date
    Jul 2016
    Location
    Cumbria, UK
    Posts
    22
    If you feeling adventurous you could try one of the other distributions.
    I notice there is a fairly recent version of Ubuntu available which you might find a little more accessible. I would not suggest wiping what you have rather try it in parallel.

    Oops, missed your last post.

    This is becoming painful. LMS is requiring an earlier version of perl.
    Last edited by milk; 2018-11-12 at 15:28. Reason: oops

  9. #19
    Junior Member
    Join Date
    Jul 2016
    Location
    Cumbria, UK
    Posts
    22
    It might be worth upgrading LMS

    http://downloads-origin.slimdevices....ex.php?ver=7.9

    I think you want logitechmediaserver_7.9.2~1541869104_arm.deb

    The changelog shows...
    Perl 5.24 modules for Linux on ARM and i386 systems have been added.

  10. #20
    Junior Member
    Join Date
    Jul 2016
    Location
    Cumbria, UK
    Posts
    22

    A PM later...

    Hi CW,
    The robust correct answer for installing the latest LMS on Arch is to create a PKGBUILD script for it or better still to search the Arch User Repository for a one the community has already written.

    However, given you have a back up there is perhaps no harm in trying out dpkg to install the .deb directly.

    I'm not 100% sure dpkg is installed by default but looking at it's man pages should both confirm and provide insight to what it does
    Code:
    man dpkg
    And then...
    Code:
    wget http://downloads-origin.slimdevices.com/nightly/7.9/sc/cf2920cf3d108ed1e5dd3e5cb3bd5a18b28c8d39/logitechmediaserver_7.9.2~1541869104_arm.deb
    sudo service logitechmediaserver stop 
    sudo service logitechmediaserver status # just to check, should be inactive
    sudo dpkg -i logitechmediaserver_7.9.2~1541869104_arm.deb
    sudo service logitechmediaserver status # just to check, should be active
    No guarantees this won't blow up you system, burn down your house and steel your car.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •