Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 46
  1. #11
    Junior Member
    Join Date
    Oct 2018
    Posts
    17
    I just don't understand. I keep trying to post a reply to the various people who have responded, but every time I do it seems to go in to moderation and never appears.

    What gives?

  2. #12
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,323

    Can't Play Digital Music Purchases! Help?

    > I just don't understand. I keep trying to post a reply to the various
    > people who have responded, but every time I do it seems to go in to
    > moderation and never appears.
    >
    > What gives?


    Moderators need some sleep every now and then. I'm sorry for the delay :-).

    --

    Michael

  3. #13
    Junior Member
    Join Date
    Oct 2018
    Posts
    17
    Quote Originally Posted by mherger View Post
    > I just don't understand. I keep trying to post a reply to the various
    > people who have responded, but every time I do it seems to go in to
    > moderation and never appears.
    >
    > What gives?


    Moderators need some sleep every now and then. I'm sorry for the delay :-).

    --

    Michael
    Thanks Michael, I see my post has now shown up on the previous page (and I deleted the duplicates). Sorry, I guess I'm not quite sure yet how the forum works. Are all posts moderated?

  4. #14
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Vństerňs Sweden
    Posts
    16,525
    Quote Originally Posted by Matt Hooper View Post
    Thanks Michael, I see my post has now shown up on the previous page (and I deleted the duplicates). Sorry, I guess I'm not quite sure yet how the forum works. Are all posts moderated?
    Afiak they are to begin with after some x posts not and after y post you can post links and pictures.
    Thats to insure youre not a bot , so when yo been here a while you wont notice and your posts go online as fast as you can type them
    --------------------------------------------------------------------
    Main hifi: Rasbery PI digi+ MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Loggia: Raspi hifiberry dac + Adams
    Bathroom : Radio (with battery)
    iPad with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server Intel NUC Esxi VM Linux mint 18 LMS 7.9.2

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  5. #15
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,192
    Quote Originally Posted by Matt Hooper View Post
    Thanks again for the help!

    mherger,

    I followed your instructions and ran another scan. It didn't seem to help. I checked the scanner log file and the digital albums did not show up there.

    slartibartfast,

    I dragged the digital albums in to my "New Music" folder, the same folder I drag all my newer CD rips in to. I just ripped another CD via itunes on my mac, dragged them in to the same folder, and they showed up. Just can't see those darned purchased digital albums!

    d6jg,

    Yes, files are unzipped.

    Mnyb,

    I have more than one iMac. My work iMac and a spare. Usually I use my spare to burn CDs and then drag them into my music folder on my external music drive. So that means I unhook my external drive from the Pi to hook to my Mac, drag the files on, hook back up to the PI, re-scan for new music, and it shows up.
    The only thing different this time is that I downloaded my purchased digital albums via my work iMac. Then I hooked up my external music drive, dragged the digital album on to my external drive, in to the usual "New Music" folder. Re-scanned...and won't show up. Does this help explain anything that might be going on? Not sure how the "permissions" problem would work. Thanks.

    w3wilkes,

    iTunes won't play flac. That's one reason I moved from streaming from iTunes to the logitech sever. Even though I don't own any flac files (until now) I wanted that capability. Plus I wanted to finally get in to trying high-res digital. Normally I just use iTunes to rip my CDs to AIF. But since the logitech server/Pi should be able to play flac, after downloading the album in AIFF didn't work, I tried downloading the FLAC version. So right now the album exists on my external hard drive in both FLAC and AIFF mode.

    Though a question arises: as I said, I normally rip to AIF...but the first download of the album was in AIFF....which shouldn't matter, should it?

    Thanks again everyone! I sure hope I can fix this because I really want to be able to be able to purchase albums on-line and play them via my server!
    LMS allows tracks to be played by drag and drop into the playing pane on the right hand side of the web GUI. What happens if you try that with one of these problem files?

    Sent from my SM-G900F using Tapatalk

  6. #16
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,323

    Can't Play Digital Music Purchases! Help?

    > Thanks Michael, I see my post has now shown up on the previous page (and
    > I deleted the duplicates). Sorry, I guess I'm not quite sure yet how
    > the forum works. Are all posts moderated?


    No, only _some_. What exact rules apply I don't know, tbh. I know that
    new members go through stronger rules. And posting log files or URLs
    etc. adds to the risk of being moderated, too. I guess it's based on
    some filter which tries to figure out whether somebody tried to
    obfuscate spammy messages and the like. Overall it's probably a hand
    full of messages a day.

    --

    Michael

  7. #17
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,162
    You said

    "The only thing different this time is that I downloaded my purchased digital albums via my work iMac. Then I hooked up my external music drive, dragged the digital album on to my external drive, in to the usual "New Music" folder. Re-scanned...and won't show up. Does this help explain anything that might be going on? Not sure how the "permissions" problem would work. Thanks."

    That is almost certainly the issue. You used a different machine and the permissions for the files you moved have those permissions. LMS can't read them. Try again via your home Mac.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  8. #18
    Junior Member
    Join Date
    Oct 2018
    Posts
    17
    slartibartfast

    I put the album on a thumb drive, and tried dragging the album folder in to the player window of the web interface. When I did I got the error:
    "No playable items found. Only audio files can be played."

    If I tried to drag a single song on to the player window, nothing would happen.

    I then dragged the album folder on to the left pane of the GUI, and then the window actually changed to an index of all the songs in that album folder, with each song highlighted in html. The only thing that happens if I click one of those songs is that it will download via the web browser to my mac. Not sure what use this is.

    BTW, on either of my Macs I can see the album folder and when I double click a song it opens in itunes and plays.

    d6jg,

    Unfortunately my links to the media are now expired. If I have to maybe I can contact the company to re-open the links for me (?). In any case, I'm still confused about the permissions aspect. Whether I download the album to my work mac, or my home mac, in both cases I have to copy it on to my external music driver to hook up to my Pi. Why should that work on one mac and not the other?

  9. #19
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,162
    Quote Originally Posted by Matt Hooper View Post
    slartibartfast

    I put the album on a thumb drive, and tried dragging the album folder in to the player window of the web interface. When I did I got the error:
    "No playable items found. Only audio files can be played."

    If I tried to drag a single song on to the player window, nothing would happen.

    I then dragged the album folder on to the left pane of the GUI, and then the window actually changed to an index of all the songs in that album folder, with each song highlighted in html. The only thing that happens if I click one of those songs is that it will download via the web browser to my mac. Not sure what use this is.

    BTW, on either of my Macs I can see the album folder and when I double click a song it opens in itunes and plays.

    d6jg,

    Unfortunately my links to the media are now expired. If I have to maybe I can contact the company to re-open the links for me (?). In any case, I'm still confused about the permissions aspect. Whether I download the album to my work mac, or my home mac, in both cases I have to copy it on to my external music driver to hook up to my Pi. Why should that work on one mac and not the other?
    Because a Mac is Linux and each user of a Linux system has a unique ID.

    What happens if you copy the files back from your external HD to your home Mac then put another copy back onto the external HD but in a different folder e.g. from Music/Some Artist/Some Album but back to Music/Some Artist/Some Album 2 ?
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  10. #20
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,530
    Not sure, but your description makes me think you havent actually downloaded the files. You just have links to the files. In the listing of files in the album folder on your thumb drive, what file types are shown? Name.flac, etc.
    Home: VBA 4TB (2.5)>LMS 7.9.2>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.4)>LMS 7.9.1>Touch>Benchmark DAC I, Boom, Radio w/Battery (ethernet, Radio WIFI)
    Office: Win10(64)>LMS 7.9.2>Squeezelite
    The Wild (no internet): PiCorePlayer 4.0 on rPi 3B+, hifiberry Dac+Pro, 4TB USB (LMS & Squeezelite)
    Controllers: iPhone6 & iPadAir2 (iPeng), CONTROLLER, or SqueezePlay 7.8 on Win10(64) laptop
    Files: ripping: dbpa > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •