Home of the Squeezebox™ & Transporter® network music players.
Page 371 of 926 FirstFirst ... 271321361369370371372373381421471871 ... LastLast
Results 3,701 to 3,710 of 9260
  1. #3701
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,776

    Announce: Material Skin

    > I think I mentioned that ONLY the Qobuz plugin/app talks german.
    > To be seen as soon as I dive down into the Qobuz submenu.


    But does this happen in all interfaces? On the player? In the default
    web UI?

    --

    Michael

  2. #3702
    Senior Member
    Join Date
    Nov 2009
    Location
    DUS
    Posts
    914
    Good point to check my controller apps.

    I just tried Orange Squeeze.
    All Qobuz Menus are english inside Orange Squeeze. And that's the same phone where also MS is running on Chrome.


    And yep, the issue is present on all my chrome browsers running MS in the network.

  3. #3703
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,776

    Announce: Material Skin

    > I just tried Orange Squeeze.
    > All Qobuz Menus are english. That's the same phone where MS is running.


    I just checked this. What I'm seeing is that in Material I would get
    _most_ menu items in the browser's language, no matter what the LMS
    language is. But not all of them: some of the main menu items like "My
    Music" would be in LMS' language, as is Material itself.

    So here's what I believe is happening:

    - Material is using LMS' language setting
    - requests sent to LMS once a player is connected are using the
    browser's language

    --

    Michael

  4. #3704
    Senior Member
    Join Date
    Nov 2009
    Location
    DUS
    Posts
    914
    Browser language (at least the menus) is also english on all my machines.

    I just attached another (new) player. And Qobuz-MS menus are still german.

  5. #3705
    Senior Member
    Join Date
    Mar 2017
    Posts
    3,736
    Quote Originally Posted by mherger View Post
    > I just tried Orange Squeeze.
    > All Qobuz Menus are english. That's the same phone where MS is running.


    I just checked this. What I'm seeing is that in Material I would get
    _most_ menu items in the browser's language, no matter what the LMS
    language is. But not all of them: some of the main menu items like "My
    Music" would be in LMS' language, as is Material itself.

    So here's what I believe is happening:

    - Material is using LMS' language setting
    - requests sent to LMS once a player is connected are using the
    browser's language
    Hmmm... I'm confused as to why this would only affect Qobuz? What Material does is:

    1. call ["pref", "language", "?"] to get LMS's language setting
    2. If lang==en, then I also check the browser's language, and set lang to this if the browser's lang starts with 'en'
    3. If lang==en Or lang==en-us then stop here - as Material's strings are in American english by default.
    4. Otherwise, I get attempt to load Material's translation file for the current lang
    5. If this translation can be loaded, it is used and 'Accept-Language' is set to that.

    I think the erro is that I should set 'Accept-Language' to LMS's setting regardless of the steps above. I've updated the code for this. Can someone (with Qobuz?) confirm the fix?
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

  6. #3706
    Senior Member
    Join Date
    Nov 2009
    Location
    DUS
    Posts
    914
    mhergers remark kept me thinking.

    I just tried Firefox on my cell. As mentioned I've been using Chrome on all my systems.

    Guess what. ALL MS menus, incl. Qobuz, are english on FF.


    We're getting closer.


    I btw removed all my cookies etc. on my Chrome browsers earlier to make sure not having any dead bodies around.

  7. #3707
    Senior Member
    Join Date
    Nov 2009
    Location
    DUS
    Posts
    914
    Quote Originally Posted by cpd73 View Post
    Hmmm... I'm confused as to why this would only affect Qobuz? What Material does is:

    1. call ["pref", "language", "?"] to get LMS's language setting
    2. If lang==en, then I also check the browser's language, and set lang to this if the browser's lang starts with 'en'
    3. If lang==en Or lang==en-us then stop here - as Material's strings are in American english by default.
    4. Otherwise, I get attempt to load Material's translation file for the current lang
    5. If this translation can be loaded, it is used and 'Accept-Language' is set to that.

    I think the erro is that I should set 'Accept-Language' to LMS's setting regardless of the steps above. I've updated the code for this. Can someone (with Qobuz?) confirm the fix?
    I'd do.

    What's the best way to update my installation from git?

    Just clone and copy?

  8. #3708
    Senior Member
    Join Date
    Mar 2017
    Posts
    3,736
    Quote Originally Posted by soundcheck View Post
    I'd do.

    What's the best way to update my installation from git?

    Just clone and copy?
    That should do. Remove the version of Material installed by LMS (in "Cache/InstalledPlugins/Plugins") and install into "Plugins" - e.g.if lms is installed at /usr/local/lms then use /usr/local/lms/Plugins. Or you can jsut overwrite the files in "Cache/InstalledPlugins/Plugins"- they'll just be re-overwitten by LMS if you update plugins
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

  9. #3709
    Senior Member
    Join Date
    Nov 2009
    Location
    DUS
    Posts
    914
    Quote Originally Posted by cpd73 View Post
    That should do. Remove the version of Material installed by LMS (in "Cache/InstalledPlugins/Plugins") and install into "Plugins" - e.g.if lms is installed at /usr/local/lms then use /usr/local/lms/Plugins. Or you can jsut overwrite the files in "Cache/InstalledPlugins/Plugins"- they'll just be re-overwitten by LMS if you update plugins
    OK. That'll do.

    However.

    I found the issue on my side. It had to be Chrome. FF was working.

    My Chrome menus as well as my entire OSes were all english.

    I checked again for that hidden german reference.

    Looking up Chrome/Advanced Settings/Languages.
    There you define if certain pages shall be shown in its original language
    or are to be translated.

    I had three languages configured: german, english, english-us - in that exact order

    I now figured that the order of languages as listed in that menu matters.
    MS-Qobuz gets the first entry in the list as reference as it seems.

    When putting english at top of the list the MS - Qobuz language turned to english.

    What a ride.

  10. #3710
    Senior Member
    Join Date
    Mar 2017
    Posts
    3,736
    Quote Originally Posted by soundcheck View Post
    OK. That'll do.

    ...

    I had three languages configured: german, english, english-us - in that exact order
    Yes, but when asking for the Qobuz strings Material should now be setting the 'Accept-Language' HTTP header to LMS's value (en). Therefore, regardless of browser lang setting, the Qobuz strings should be in LMS's language. Please keep your languages configured as is (german, english, english-us), and see if Material now acts correctly.
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •