Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 290 FirstFirst 12341252102 ... LastLast
Results 11 to 20 of 2899
  1. #11
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,104
    Quote Originally Posted by anadigi View Post
    This is my favorite skin so far! Thank you!
    The response is quick. I have it setup on iphone and works great. Looking forward to the next release!
    Any chance you could chcekout the version from git? To see if Spotify covers are fixed? As stated, I don't use any streaming services - so have no idea how well they are supported. If you don't know how to use git, you could just copy https://raw.githubusercontent.com/CD...al/js/utils.js to "MaterialSkin/HTML/material/js" on your LMS install (and re-start LMS). The change that might fix covers is in that file.

  2. #12
    Quote Originally Posted by cpd73 View Post
    Any chance you could chcekout the version from git? To see if Spotify covers are fixed? As stated, I don't use any streaming services - so have no idea how well they are supported. If you don't know how to use git, you could just copy https://raw.githubusercontent.com/CD...al/js/utils.js to "MaterialSkin/HTML/material/js" on your LMS install (and re-start LMS). The change that might fix covers is in that file.
    I haven't. I have followed your advise and edit the utils.js manually and works!

  3. #13
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,104
    Quote Originally Posted by anadigi View Post
    I haven't. I have followed your advise and edit the utils.js manually and works!
    So, spotify covers now show? If so, that's great! I'll try to do a 0.0.3 release tomorrow. I'd like to fix the issue with the plugin state on the plugin page, but not sure what to do there...

  4. #14
    Quote Originally Posted by cpd73 View Post
    So, spotify covers now show? If so, that's great! I'll try to do a 0.0.3 release tomorrow. I'd like to fix the issue with the plugin state on the plugin page, but not sure what to do there...
    Yes!
    So far only the radio is not working-trying to play; it plays all the song locally instead.

  5. #15
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,315

    Announce: Material Skin

    > I don't use streaming services such as Spotify, so I have no idea how
    > well it works with these. But (AFAIK) these are all just apps, so they
    > -should- work...


    Did you implement SlimBrowse/SlimMenu for the app? The services then
    should come "for free"...

    --

    Michael

  6. #16
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,104
    Quote Originally Posted by mherger View Post
    > I don't use streaming services such as Spotify, so I have no idea how
    > well it works with these. But (AFAIK) these are all just apps, so they
    > -should- work...


    Did you implement SlimBrowse/SlimMenu for the app? The services then
    should come "for free"...

    --

    Michael
    No, I simply use the JSONRPC interface. I did look at http://wiki.slimdevices.com/index.ph...Play_interface, but was unsure how to use it.

  7. #17
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,260
    Only local music working for me, all other (Radio Paradise, BBC iPlayer, YouTube, Bandcamp, Radio, Favourites) just results in a playlist of local tracks.
    Server - LMS 7.9.2 Pi4B 4GB/pCP 6.0.0-b7 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  8. #18
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,104
    Quote Originally Posted by kidstypike View Post
    Only local music working for me, all other (Radio Paradise, BBC iPlayer, YouTube, Bandcamp, Radio, Favourites) just results in a playlist of local tracks.
    Yeah, I know about YouTube and Radio - these are fixed in git/master, and I'll make a 0.0.3 release later. I'll check the others later. Favourites was working, but it's possible I changed some code without checking how it affected other parts.

    The skin is still under heavy development...

  9. #19
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,260
    Quote Originally Posted by cpd73 View Post
    Yeah, I know about YouTube and Radio - these are fixed in git/master, and I'll make a 0.0.3 release later. I'll check the others later. Favourites was working, but it's possible I changed some code without checking how it affected other parts.

    The skin is still under heavy development...
    No worries, not complaining, just reporting
    Server - LMS 7.9.2 Pi4B 4GB/pCP 6.0.0-b7 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  10. #20
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,104
    Quote Originally Posted by kidstypike View Post
    No worries, not complaining, just reporting
    Sorry - didn't mean to come across as defensive :-) I released early for this sort of feedback. All non-library URL loading is broken in 0.0.2 (sorry!) - fixed in git/master, but I need to work on it to clean up a bit more.

    I also need to look into it not working when set as Default (which I would not recommend, anyway) and issues with the plugin page thinking there is an update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •