Home of the Squeezebox™ & Transporter® network music players.
Page 475 of 475 FirstFirst ... 375425465473474475
Results 4,741 to 4,750 of 4750
  1. #4741
    Quote Originally Posted by slartibartfast View Post
    Create MusicIP is there for me as is TuneIn Radio.

    Sent from my Pixel 3a using Tapatalk

    Yes, I have had the same report from others, it is clearly "my issue".

    After much effort to gain Music IP functionality I attempted a "clear library and rescan", as I had feared this failed and left me with no library except for playlists created outside of MIP. It interestingly showed that it did indeed import all tracks in my Music IP library, but it did not add them to the LMS library. Odd.

    In the end I reconfigured MIP in server settings to "import all song data" and finally got a successful scan and Music IP function within LMS once again. The scan required 3 hours and it's unclear if I will need to use this method going forward, but at least I have access to my MIP library in LMS once again.

    Tunein Radio still has vanished without explanation (as has "podcasts" and also my previously created player "groups"). I'm at a loss as to why installing Material Skin would lead to any of this, but otherwise it is clearly the best GUI for LMS I have used. I hope it proves stable for me in the long run.

    Any suggests for resolving the disappeared Tunein Radio welcome.

  2. #4742
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,328
    Quote Originally Posted by rivrwing View Post
    Yes, I have had the same report from others, it is clearly "my issue".

    After much effort to gain Music IP functionality I attempted a "clear library and rescan", as I had feared this failed and left me with no library except for playlists created outside of MIP. It interestingly showed that it did indeed import all tracks in my Music IP library, but it did not add them to the LMS library. Odd.

    In the end I reconfigured MIP in server settings to "import all song data" and finally got a successful scan and Music IP function within LMS once again. The scan required 3 hours and it's unclear if I will need to use this method going forward, but at least I have access to my MIP library in LMS once again.

    Tunein Radio still has vanished without explanation (as has "podcasts" and also my previously created player "groups"). I'm at a loss as to why installing Material Skin would lead to any of this, but otherwise it is clearly the best GUI for LMS I have used. I hope it proves stable for me in the long run.

    Any suggests for resolving the disappeared Tunein Radio welcome.
    You definitely should not need to import all song data from MusicIP. Hard to tell what is wrong with your LMS. I would start from scratch and reinstall it

    Sent from my Pixel 3a using Tapatalk

  3. #4743
    Quote Originally Posted by slartibartfast View Post
    You definitely should not need to import all song data from MusicIP. Hard to tell what is wrong with your LMS. I would start from scratch and reinstall it

    Sent from my Pixel 3a using Tapatalk

    I am considering it but no time right now. I may wait for an official release of LMS 8.0.

    Do you use ôrandomö song mix in material skin? I have it selected for continuous, but it will only play the number of tracks I actually specify each time I select ôrandomö. It seems to default to 10, and if I enter zero it loads 10. Previously using the default GUI it would also load a smaller amount but my interpretation was that it continuously added using the final track as a "seed" for the continuing mix which gave a more interesting flow that changed course in interesting ways rather than using the same original seed for a lengthy but specified mix duration (my observation has been that random is not truly random and I presume the integrity of the mix is somehow managed by MIP?).

  4. #4744
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,328
    Quote Originally Posted by rivrwing View Post
    I am considering it but no time right now. I may wait for an official release of LMS 8.0.

    Do you use ôrandomö song mix in material skin? I have it selected for continuous, but it will only play the number of tracks I actually specify each time I select ôrandomö. It seems to default to 10, and if I enter zero it loads 10. Previously using the default GUI it would also load a smaller amount but my interpretation was that it continuously added using the final track as a "seed" for the continuing mix which gave a more interesting flow that changed course in interesting ways rather than using the same original seed for a lengthy but specified mix duration (my observation has been that random is not truly random and I presume the integrity of the mix is somehow managed by MIP?).
    I have used random song mix and as you say the playlist starts with 10 songs and adds more when necessary. Random song mix has no link to MusicIP though.

    Sent from my Pixel 3a using Tapatalk

  5. #4745
    Quote Originally Posted by slartibartfast View Post
    I have used random song mix and as you say the playlist starts with 10 songs and adds more when necessary. Random song mix has no link to MusicIP though.

    Sent from my Pixel 3a using Tapatalk

    Random does not seem to add titles as you are experiencing, and as was my previous experience. More and more it seems an LMS reinstall may indeed be in order, when I can find time to configure it. I'd like to install LMS 8.x on top when it becomes stable and see if that resolves things.

    I never have seen it stated that MIP was involved with random mixing, but the mixes seem to make an uncanny sense more often then not. Thanks for clarifying that is not the case.

  6. #4746
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,328
    Quote Originally Posted by rivrwing View Post
    Random does not seem to add titles as you are experiencing, and as was my previous experience. More and more it seems an LMS reinstall may indeed be in order, when I can find time to configure it. I'd like to install LMS 8.x on top when it becomes stable and see if that resolves things.

    I never have seen it stated that MIP was involved with random mixing, but the mixes seem to make an uncanny sense more often then not. Thanks for clarifying that is not the case.
    Does everything work if you uninstall the material skin plugin?

    Sent from my Pixel 3a using Tapatalk

  7. #4747
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,328
    Does the shutdown server feature work? I tried it on my Raspberry Pi and the server is still running.

    Sent from my Pixel 3a using Tapatalk

  8. #4748
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,871
    Quote Originally Posted by slartibartfast View Post
    Does the shutdown server feature work? I tried it on my Raspberry Pi and the server is still running.
    Just tried, and works for me. All the feature does is send the "stopserver" JSONRPC command to LMS. Perhaps your systemd service file is set to restart?
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

  9. #4749
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,328
    Quote Originally Posted by cpd73 View Post
    Just tried, and works for me. All the feature does is send the "stopserver" JSONRPC command to LMS. Perhaps your systemd service file is set to restart?
    I can shut the server down from putty with
    sudo service logitechmediaserver stop

    Sent from my Pixel 3a using Tapatalk

  10. #4750
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,871
    Quote Originally Posted by slartibartfast View Post
    I can shut the server down from putty with
    sudo service logitechmediaserver stop
    That's a different command. Material cannot call sudo commands - it calls the built-in LMS 'stopserver' command. This, I assume tells LMS to start. It's possible systemd notices this, and restarts the service. I guess one way to tell would be to look at the uptime of the service. Anyhow, Material is working as designed - its using the LMS APIs. You can, if you want, add extra commands to Material - see the 'Custom menu entries' section of https://github.com/CDrummond/lms-mat...ed-Information
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •