Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 12

Hybrid View

  1. #1
    Junior Member
    Join Date
    Aug 2018
    Location
    Salop, UK
    Posts
    19

    Error installing LMS on piCorePlayer

    After installing LMS onto piCorePlayer 4.0.0 on a RaspberryPi, "Start LMS" fails with error:

    [...]
    [ INFO ] The following CPAN modules were found but cannot work with Logitech Media Server:
    Audio::Scan (loaded 1.02, need 0.93)
    [...]

    This problem only appeared a couple of days ago and pCP has not changed. LMS is the current package that is downloaded by the pCP installer.
    I have tried with three different recent versions of pCP and get the same error. The pCP installation is the default. On a second (working) Rpi player I removed LMS then reinstalled and now have the same error.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,421

    Error installing LMS onpiCorePlayer

    > [ INFO ] The following CPAN modules were found but cannot work with
    > Logitech Media Server:
    > Audio::Scan (loaded 1.02, need 0.93)


    Do you know what LMS version was installed? Would you be able to press
    the "Nightly Update" button?

    You might need to update to a nighly build manually. Just follow the
    instructions on https://www.picoreplayer.org/how_to_upgrade_lms.shtml.
    That should get it working.

    --

    Michael

  3. #3
    Junior Member
    Join Date
    Aug 2018
    Location
    Salop, UK
    Posts
    19

    Now working

    [QUOTE=mherger;923129]> [ INFO ] The following CPAN modules were found but cannot work with
    > Logitech Media Server:
    > Audio::Scan (loaded 1.02, need 0.93)


    Do you know what LMS version was installed? Would you be able to press
    the "Nightly Update" button?

    You might need to update to a nighly build manually. Just follow the
    instructions on https://www.picoreplayer.org/how_to_upgrade_lms.shtml.
    That should get it working.

    --

    Hi Michael

    I couldn't easily add the version number to my post because I couldn't get LMS to run. The Nightly Update button also returned an error.
    However, your fix worked. I was perhaps wrong footed because LMS now seems to be looking for an earlier version of the module.

    Many thanks, David

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,421
    Quote Originally Posted by DeeToot View Post
    I couldn't easily add the version number to my post because I couldn't get LMS to run. The Nightly Update button also returned an error.
    However, your fix worked. I was perhaps wrong footed because LMS now seems to be looking for an earlier version of the module.
    Are you saying it's working or not?
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  5. #5
    Junior Member
    Join Date
    Aug 2018
    Location
    Salop, UK
    Posts
    19
    Quote Originally Posted by mherger View Post
    Are you saying it's working or not?
    Sorry, yes, the manual update works.
    And now Additional Browse Modes is working properly again .

    Thanks again, D.

  6. #6
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,060
    I might need to update the base LMS installation. If the Audio Scan 1.02 binary is present, will that break older versions of LMS?
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •