Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 11

Hybrid View

  1. #1
    Junior Member
    Join Date
    Sep 2018
    Posts
    12

    Couple of problems - lastfm and what was that tune?

    I just set this up, and the last.fm account is a new one. It's weird, if I am playing a song on Tune.in and look at the last.fm website it says "scrobbling now" but never commits the track. If I play a song in my music library (an mp3 or something) it scrobbles it properly. Is there a setting or something I am doing wrong?

    2nd issue LMS 7.9.1 'stable' - I can't enable 'what was that tune' i check the box, restart the app, and it's not checked.

    thanks again.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,314

    Couple of problems - lastfm and whatwas that tune?

    > I just set this up, and the last.fm account is a new one. It's weird,
    > if I am playing a song on Tune.in and look at the last.fm website it
    > says "scrobbling now" but never commits the track. If I play a song in
    > my music library (an mp3 or something) it scrobbles it properly. Is
    > there a setting or something I am doing wrong?


    Yes, you have to got the AudioScrobbler settings to tell it to scrobble
    radio content, too. By default this is disabled as many people only want
    to scrobble what they like to listen to, as to not mess up their
    listening profile. If you only care about what you did listen to, then
    you can disable that behaviour. If you want to use Last.fm information
    to eg. create customized tracks based on your listening behaviour, then
    you should leave it disabled.

    > 2nd issue LMS 7.9.1 'stable' - I can't enable 'what was that tune' i
    > check the box, restart the app, and it's not checked.


    Are you running LMS on a QNAP by chance? If not, what else? Check your
    server.log, too.

    --

    Michael

  3. #3
    Junior Member
    Join Date
    Sep 2018
    Posts
    12
    on last.fm … that makes sense.

    edited … (my iPad can VPN into home, and I'm at work - Grabbed a bit of the log and posted it)

    Code:
    [18-09-21 09:17:16.1689] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-09-21 09:17:23.0078] main::init (387) Starting Logitech Media Server (v7.9.1, 1522157629, Fri Mar 30 12:17:59 WEDT 2018) perl 5.014001 - MSWin32-x86-multi-thread
    [18-09-21 14:38:04.8034] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-09-21 14:38:13.0098] main::init (387) Starting Logitech Media Server (v7.9.1, 1522157629, Fri Mar 30 12:17:59 WEDT 2018) perl 5.014001 - MSWin32-x86-multi-thread
    That's what happens when I check the box and restart the server.

    Server is Windows 10 Pro latest build
    Last edited by Qnetso; 2018-09-21 at 11:47.

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,844
    Quote Originally Posted by Qnetso View Post
    on last.fm … that makes sense.
    You do it from LMS web interface
    Settings/last.fm AudioScrobbler/Scrobble Internet Radio

    In the old old days AudioScrobbler/Last.fm did not want plays of tracks that were not selected by the end-user to be counted. There is even a separate flag to include when scrobbling so called "Internet radio" to indicate that being the source so that they could discard it (but show it in the Now Playing) area.

    Now you make the choice and last.fm doesn't really care.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  5. #5
    Junior Member
    Join Date
    Sep 2018
    Posts
    12
    Thanks got last.fm squared away...

    What Was That Tune still seems broken - is it possible something is down that delivers that plugin? I ask because in one of my earlier installs I installed it without issue.

    I've now made a VM to test a fresh install of LMS to install just the "what was that tune" plugin. Same issue, Official LMS or 7.9.1 stable.

    Steps to recreate:
    1. install LMS (either official or community edition)
    2. Official only - enable 3rd party plug ins
    3. Check box for "what was that tune"
    4. Restart server as requested by LMS

    5. Get this as a result:
    https://1drv.ms/u/s!ArZ2KnVG8vwYq8h7PNcr_pWJJp0QXQ

    From here on out you can click enable and restart as much as you want, it will just keep on saying "updated plugins available", with it unchecked once it restarts

    As a comparison I did enable the PlayHLS plugin, which works. I then went looking for the plugin I find it (PlayHLS) here: C:\ProgramData\Squeezebox\Cache\InstalledPlugins\P lugins

    Shouldn't I expect "what was that tune" to show up there as well?


    Also is there a place to learn about making plugins? do you need to know perl?


    Thanks Again!
    Last edited by Qnetso; 2018-09-22 at 21:46.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,314

    Couple of problems - lastfm and whatwas that tune?

    Could you please send me a copy of your server.log.zip file
    (Settings/Information)?

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •