Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38
  1. #1
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,105

    LMS 7.9.2: updated SQLite module v1.58

    I just pushed a change which shouldn't be of "public interest" just yet.
    I've updated DBD::SQLite, the library we're using as the database
    backend for the music library, caches etc. to version 1.58. While it's
    supposed to come with some performance improvements, you'll likely not
    notice them.

    The reason why I'm announcing this here is the fact that I had to
    re-build the module myself. Something I don't like to do, and therefore
    don't do often. In particular building for Windows was a bit of a
    challenge. Therefore this little warning: please speak up should you see
    any issues with the new database backend.

    The new binaries currently are only available for macOS (Perl 5.18,
    64-bit only), Windows, Linux x86_64/5.10 and armhf/5.20. paul-1 was kind
    enough to build for pCP, too. But it might take a while before he's
    releasing that update. But it's on its way.

    These are the only platforms I have access to. I'll add more platforms
    as you speak up and tell me about your needs.

    If you can't wait, feel free to grab the latest code from
    https://github.com/Logitech/slimserv...ublic/7.9/CPAN and
    build it yourself. On Linux this should should be pretty straight
    forward. Let me know about your findings!

    --

    Michael

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,954
    Quote Originally Posted by mherger View Post
    I just pushed a change which shouldn't be of "public interest" just yet.
    I've updated DBD::SQLite, the library we're using as the database
    backend for the music library, caches etc. to version 1.58. While it's
    supposed to come with some performance improvements, you'll likely not
    notice them.

    The reason why I'm announcing this here is the fact that I had to
    re-build the module myself. Something I don't like to do, and therefore
    don't do often. In particular building for Windows was a bit of a
    challenge. Therefore this little warning: please speak up should you see
    any issues with the new database backend.

    The new binaries currently are only available for macOS (Perl 5.18,
    64-bit only), Windows, Linux x86_64/5.10 and armhf/5.20. paul-1 was kind
    enough to build for pCP, too. But it might take a while before he's
    releasing that update. But it's on its way.

    These are the only platforms I have access to. I'll add more platforms
    as you speak up and tell me about your needs.

    If you can't wait, feel free to grab the latest code from
    https://github.com/Logitech/slimserv...ublic/7.9/CPAN and
    build it yourself. On Linux this should should be pretty straight
    forward. Let me know about your findings!

    --

    Michael
    Armhf/5.24.1 for Debian Stretch would be nice if possible.

    Sent from my SM-G900F using Tapatalk

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,105

    LMS 7.9.2: updated SQLite module v1.58

    > Armhf/5.24.1 for Debian Stretch would be nice if possible.

    Would that be Raspbian on Pi or some other platform?

    --

    Michael

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,954
    Quote Originally Posted by mherger View Post
    > Armhf/5.24.1 for Debian Stretch would be nice if possible.

    Would that be Raspbian on Pi or some other platform?

    --

    Michael
    OSMC on Pi so I assume it is close to Raspbian.

    Sent from my SM-G900F using Tapatalk

  5. #5
    Senior Member
    Join Date
    Jul 2005
    Posts
    320
    Installed on Windows 10, and all seems well so far in light use (I did a full rescan and later an incremental when I ripped a new CD).

  6. #6
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,454
    The pCP binaries are armhf/perl5.24 I'm going to be out of town for a few days, so I don't want to release in our main channel...... just incase there are problems. For those that want to test on pCP

    Download these two files and overwrite the extension located /mnt/mmcblk0p2/tce/optional

    https://dl.dropboxusercontent.com/s/...erver-CPAN.tcz
    https://dl.dropboxusercontent.com/s/...AN.tcz.md5.txt

    Then reboot.......if you run into problems and want to revert, you can just run

    pcp-update slimserver-CPAN and it will pull the current released copy from our repo
    Last edited by paul-; 2018-09-14 at 12:34.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,105

    LMS 7.9.2: updated SQLite module v1.58

    > https://dl.dropboxusercontent.com/s/...erver-CPAN.tcz
    > https://dl.dropboxusercontent.com/s/...AN.tcz.md5.txt


    Thanks Paul! FWIW: I've been running these files for a few days now,
    without the slightest hiccup.

    --

    Michael

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,105

    LMS 7.9.2: updated SQLite module v1.58

    > OSMC on Pi so I assume it is close to Raspbian.

    New builds with binaries for 5.24/armhf are up. Please give it a try.

    --

    Michael

  9. #9
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,954
    Quote Originally Posted by mherger View Post
    > OSMC on Pi so I assume it is close to Raspbian.

    New builds with binaries for 5.24/armhf are up. Please give it a try.

    --

    Michael
    Updated to 7.9.2 - 1536927057 and SQLite version is still 1.34_01.
    Perl version is 5.24.1 - arm-linux-gnueabihf-thread-multi-64int

    Sent from my SM-G900F using Tapatalk

  10. #10
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,954
    Quote Originally Posted by mherger View Post
    > OSMC on Pi so I assume it is close to Raspbian.

    New builds with binaries for 5.24/armhf are up. Please give it a try.

    --

    Michael
    If I search for sqlite.pm after updating all I find is

    Name:  sqlite.JPG
Views: 237
Size:  34.4 KB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •