Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27
  1. #21
    Junior Member
    Join Date
    Jul 2020
    Posts
    7
    squeezelite-log.txt

    here we go...

    copied the console output to a txt file.

  2. #22
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,586
    Quote Originally Posted by RCJ View Post
    squeezelite-log.txt

    here we go...

    copied the console output to a txt file.
    Please give 1.9.7-1265-beta2 a try. Still only runs on picoreplayer.

    If it fixes both the vorbis ogg segfault and static when resampling, I'll build a 1.9.7-1265 release which should work on buster as well.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  3. #23
    Junior Member
    Join Date
    Jul 2020
    Posts
    7
    Congrats!!
    Static gone, Segfault gone.

    Did you see what was going on by looking at the log file. To me, it looked pretty non-diagnostic..

    Looking forward to the raspbian 10 version.

    Thanx, Robert

  4. #24
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,586
    Quote Originally Posted by RCJ View Post
    Congrats!!
    Static gone, Segfault gone.

    Did you see what was going on by looking at the log file. To me, it looked pretty non-diagnostic..

    Looking forward to the raspbian 10 version.

    Thanx, Robert
    Not specifically, but the log did allow me to setup a test environment similiar to yours to reproduce.

    The same issues existed in the opus decoder, both should be fixed in 1.9.7-1167.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  5. #25
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,125

    Build Squeezelite

    Quote Originally Posted by ralphy View Post
    Not specifically, but the log did allow me to setup a test environment similiar to yours to reproduce.

    The same issues existed in the opus decoder, both should be fixed in 1.9.7-1167.
    My bad, I screwed up on this one with an incorrect test. I have pushed a change on squeezelite-esp32, let me know if you want a PR on squeezelite. But you're right as well, FRAME_BUF should be disabled by default on non-embedded systems
    Last edited by philippe_44; 2020-07-27 at 16:07.
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  6. #26
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,586
    Quote Originally Posted by philippe_44 View Post
    My bad, I screwed up on this one with an incorrect test. I have pushed a change on squeezelite-esp32, let me know if you want a PR on squeezelite. But you're right as well, FRAME_BUF should be disabled by default on non-embedded systems
    Thank you. I've merged your opus and vorbis decoder changes from the squeezelite-esp32 project in version 1.9.7-1269.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  7. #27
    Junior Member
    Join Date
    Sep 2014
    Posts
    3
    Quote Originally Posted by Matt4 View Post
    Thank you, I may have been dealing with 2 failures at once, the bug you mention and building in an environment that wasn't compatible. I found another post that mentioned Raspbian has a few old libraries that prevent this from working. After moving back to Tiny Core and finding https://soundcheck-audio.blogspot.co...ne-part-5.html all of my build issues are solved and I was able to build successfully.

    Thanks for the fantastic project.
    Hi, just wondering what version of tinycore you are using. It doesn't seem that all of the dependencies are listed for v11.x so I am thinking I need to use 9.x but just wondering if this is what you used.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •