Home of the Squeezebox™ & Transporter® network music players.
Page 82 of 98 FirstFirst ... 3272808182838492 ... LastLast
Results 811 to 820 of 974
  1. #811
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    607
    Another strange one - I've configured the Rescan Library plugin to do a daily full scan but it doesn't appear to work. No scan happens in the log and the library.db is untouched. It worked fine on Windows (TM). ;-)

    I can't see anything amiss in the server or scanner logs. Any ideas what could be wrong?

    E2A I spotted under Tweaks that crond isn't running - is that required?
    Last edited by mr-b; 2019-04-25 at 15:21.

  2. #812
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,993
    The server settings should fire it internally. Cron is not needed.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #813
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    607
    OK - very strange. I did some digging and uncovered something about how LMS used a different location for config or somesuch after resizing the partition - https://forums.slimdevices.com/showt...l=1#post921571

    Since I'd resized it previously and encountered some odd log entries, I wondered if I might be experiencing similar? (I admit that I'm grasping at straws here)

    [19-04-16 10:10:31.8259] Slim::Web::Template::SkinManager::_fillTemplate (337) Error: file error - failed to create compiled templates directory: /usr/local/slimserver/Cache/templates (mkdir /usr/local/slimserver/Cache: File exists at /usr/local/slimserver/lib/Template/Provider.pm line 863.

    If no one has any diagnostic suggestions I'll start from scratch.

  4. #814
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,932
    Under Settings/Advanced/Logging you could enable Info (or higher) for
    (scan.scanner) - Media & Playlist Folder Scanning
    It should then put something in the logs when timer becomes due ... unless it thinks that scanning is already in progress.

    From /Slim/Plugin/Rescan/Plugin.pm
    Code:
    sub executeRescan {
    	my $rescanType = ['rescan'];
    	my $rescanPref = $prefs->get('type') || '';
    
    	if ($rescanPref eq '2wipedb') {
    
    		$rescanType = ['wipecache'];
    
    	} elsif ($rescanPref eq '3playlist') {
    
    		$rescanType = [qw(rescan playlists)];
    	}
    
    	if (!Slim::Music::Import->stillScanning()) {
    
    		main::INFOLOG && logger('scan.scanner')->info("Initiating scan of type: ", $rescanType->[0]);
    
    		Slim::Control::Request::executeRequest(undef, $rescanType);
    	}
    }
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  5. #815
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    607
    Tried changing the log level but there's nothing there - nor in server.log.
    The pCP time is correct.

  6. #816
    Had an odd USB drive issue the other day. My piCorePlayer installation currently uses two SanDisk 128GB memory sticks as storage, plugged into the upper 2 USB sockets of a Pi 3 B. To update them I power the player down and update the files from a PC.

    When I came to do this this week after adding or changing a few albums, the particular drive couldn't be seen by piCorePlayer at boot up, it was as if the drive wasn't plugged in at all. Eventually, after almost 5 minutes, the drive showed up under dmesg, and it could finally be mounted.

    I presume this is a hardware issue with the drive itself.

  7. #817
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    607
    Quote Originally Posted by mr-b View Post
    OK - very strange. I did some digging and uncovered something about how LMS used a different location for config or somesuch after resizing the partition - https://forums.slimdevices.com/showt...l=1#post921571

    Since I'd resized it previously and encountered some odd log entries, I wondered if I might be experiencing similar? (I admit that I'm grasping at straws here)

    [19-04-16 10:10:31.8259] Slim::Web::Template::SkinManager::_fillTemplate (337) Error: file error - failed to create compiled templates directory: /usr/local/slimserver/Cache/templates (mkdir /usr/local/slimserver/Cache: File exists at /usr/local/slimserver/lib/Template/Provider.pm line 863.

    If no one has any diagnostic suggestions I'll start from scratch.
    I stopped LMS, cleared prefs and cache (default held on pCP Boot Disk), ran the setup wizard again, aborted the initial scan, configured Rescan Library and it then triggered at the right time.
    So it looks like the prefs/cache reset did something to fix things screwed up by the partition resize.

    As an aside, I found that both the rescan plugin and the library network disk mount configs were preserved despite the prefs/cache reset, which was unexpected. I'd assumed that the reset would clear everything.

  8. #818
    Member
    Join Date
    May 2009
    Location
    FL
    Posts
    30

    AES67 driver for ALSA

    Feature Request :

    This is a fairly new release so I don't know if any of the dev team has caught onto this yet.

    Ravenna have just released linux drivers and source for implementing Ravenna/AES67 on linux. I have been eager to see this happen for quite sometime. I hope one of the devs are interested enough to take this one on-board and include in piCorePlayer.

    https://merging.com/products/alsa_ravenna_aes67_driver

    Source
    https://bitbucket.org/MergingTechnol...-alsa-lkm/src/
    LMS 7.9.1, Slimdevices Silver Transporter, 1 * SB Touch, 2 * SB Duets, 2 * SB Boom, 1 * SB Radio, 1 * Wandboard Quad, 2* Pi 3 + HiFiBerry-Amp+ Official Touchscreen + PiCorePlayer, (RIP SB Classic & SB Radio)

  9. #819
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,200
    hi lesliew,

    Have "they" got it included into Raspbian?

    Once they have it included in the Raspbian Linux distribution it will be available in pCP.

    regards
    Greg

  10. #820
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,932
    Quote Originally Posted by lesliew View Post
    Ravenna have just released linux drivers and source for implementing Ravenna/AES67 on linux. I have been eager to see this happen for quite sometime. I hope one of the devs are interested enough to take this one on-board and include in piCorePlayer.
    Does it need their "Butler" component?
    If yes - then there may well be problems because:
    "Architecture
    While the Butler OEM build may be build for multiple architecture (ARM, ARM64, x86, x86_64), the public Butler is built for the x86_64 architecture only"
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •