Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,512

    Instability in Windows build

    For the last couple of years I've been mostly using only the compiled Windows EXE build. I update the server to a beta build exactly once a month, on the 1st, on two different servers running Windows 2008 R2 Standard.

    Today I found the server unresponsive, and on examining Windows services found it in the 'stopping' state. Unable to get it stopped, I was forced to reboot the server. This has happened one time before on the same server, and one time on the second server.

    Below is the end of the most recent server log. It may have something to do with new/change scans, which I have scheduled to run each night via the 'Rescan Music Library' plugin, or maybe not.

    Code:
    [18-08-21 05:16:30.9244] Slim::Music::Artwork::__ANON__ (309) updateStandaloneArtwork finished in 0.931213140487671
    [18-08-21 05:16:30.9880] Slim::Music::Artwork::precacheAllArtwork (619) Starting precacheArtwork for 0 albums
    [18-08-21 10:27:11.4688] main::init (387) Starting Logitech Media Server (v7.9.2, 1533033975, Tue Jul 31 14:08:13 WEDT 2018) perl 5.014001 - MSWin32-x86-multi-thread

  2. #2
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,512
    Just to clarify, it's happened on both servers one time previously with this same build, earlier this month.

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,118

    Instability in Windows build

    > Today I found the server unresponsive, and on examining Windows services
    > found it in the 'stopping' state. Unable to get it stopped, I was forced
    > to reboot the server. This has happened one time before on the same
    > server, and one time on the second server.


    With 7.9.2, too, or some older build?

    > Below is the end of the most recent server log. It may have something to
    > do with new/change scans, which I have scheduled to run each night via
    > the 'Rescan Music Library' plugin, or maybe not.


    Are you using any 3rd party plugin which might hook in to the scan? Eg.
    my Music & Artist Information plugin? It seems the scan is run in the
    main server process, which should hardly ever happen.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •