Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Senior Member
    Join Date
    Aug 2005
    Posts
    108

    My server locked up with playing from WavInput.

    About a week ago I installed the plugin WaveInput (v1.04) seems to work good. But 2 times now don't know why my server just locks up and I have to turn off the power and back up. It's a Ubuntu server.

    Looked at the LMS error log and here is the last part of it if this will say why it locked up not sure.

    Code:
    [18-08-07 06:36:08.2851] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [18-08-07 18:03:54.9767] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [18-08-07 18:03:55.1035] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [18-08-07 18:03:55.1039] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [18-08-08 08:16:23.1908] Slim::Networking::SqueezeNetwork::Players::_players_error (368) Unable to get players from SN: Couldn't resolve IP address for: www.mysqueezebox.com, retrying in 86400 seconds
    2018-08-08 08:20:09 squeezeboxserver_safe started.
    [18-08-08 08:20:10.8458] main::init (387) Starting Logitech Media Server (v7.9.1, 1522157629, Fri Mar 30 12:25:29 CEST 2018) perl 5.026001 - x86_64-linux-gnu-thread-multi
    [18-08-08 08:20:11.1525] Slim::Utils::IPDetect::_init (140) Warning: Couldn't call connect() - falling back to 127.0.0.1
    [18-08-08 08:20:11.2292] Slim::Utils::Misc::msg (1252) Warning: [08:20:11.2288] DBIx::Class::ResultSet::update_or_create(): Query returned more than one row.  SQL that returns multiple rows is DEPRECATED for ->find and ->single at /usr/share/perl5/Slim/Schema.pm line 1877
    [18-08-08 08:20:11.6549] Slim::Utils::Misc::msg (1252) Warning: [08:20:11.6546] Can't locate auto/Crypt/OpenSSL/RSA/autosplit.ix in @INC (@INC contains: /var/lib/squeezeboxserver/cache/InstalledPlugins /var/lib/squeezeboxserver/cache/InstalledPlugins /var/lib/squeezeboxserver/cache/InstalledPlugins /usr/sbin/Plugins/RaopBridge/lib /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/lib/5.26/x86_64-linux-thread-multi /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/lib/5.26/x86_64-linux-thread-multi/auto /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/lib /var/lib/squeezeboxserver/cache/InstalledPlugins /usr/share/squeezeboxserver/CPAN/arch/5.26/x86_64-linux-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.26/x86_64-linux-thread-multi/auto /usr/share/squeezeboxserver/CPAN/arch/5.26.1/x86_64-linux-gnu-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.26.1/x86_64-linux-gnu-thread-multi/auto /usr/share/squeezeboxserver/CPAN/arch/5.26/x86_64-linux-gnu-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.26/x86_64-linux-gnu-thread-multi/auto /usr/share/squeezeboxserver/CPAN/arch/x86_64-linux-gnu-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.26 /usr/share/squeezeboxserver/lib /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/sbin /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/ShairTunes2W/elib /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/ShairTunes2W/elib/5.26 /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/ShairTunes2W/elib/5.26/x86_64-linux-thread-multi /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/ShairTunes2W/elib/5.26/x86_64-linux-thread-multi/auto) at /usr/share/perl/5.26/AutoLoader.pm line 181.
     at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/ShairTunes2W/elib/Crypt/OpenSSL/RSA.pm line 11.
    [18-08-08 08:20:11.9684] Slim::Networking::Async::Socket::UDP::mcast_add (48) Error: While adding multicast membership, UPnP may not work properly: No such device
    [18-08-08 08:20:12.4788] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting http://www.mysqueezebox.com/api/sounds/v1/opml
    Couldn't resolve IP address for: www.mysqueezebox.com
    [18-08-08 08:20:12.4791] Slim::Plugin::Sounds::Plugin::_gotSoundsError (83) Error: Unable to cache Sounds & Effects menu from SN: Couldn't resolve IP address for: www.mysqueezebox.com
    [18-08-08 08:20:15.9506] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:2a:7c:a4, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    If any one sees any thing that my lock it up can you let me know.

    The wave input works good. Not sure it that's what locked it up but it's the last thing I changed from when it started to lock up and this is the 2nd time now.

    -Raymond Day

  2. #2
    Senior Member
    Join Date
    Aug 2005
    Posts
    108

    Seen a post that LMS fills RAM Looks like doing that too on my server.

    Been running Htop wile playing a Wave input and the Memory gradually fills up. I guess it's LMS.

    Name:  LMS htop fills up RAM.jpg
Views: 69
Size:  226.5 KB

    That screen shot shows it full.

    As I type this looks like one red bar went in the Swap part. It locked up before don't know if this is why.

    -Raymond Day

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,103

    My server locked up with playingfrom WavInput.

    > That screen shot shows it full.

    Not at all: it didn't even start swapping. It reports 987M out of 3.8G used.

    What I see from your server.log though is that you have a networking
    issue. LMS doesn't find any valid IP address, falling back to 127.0.0.1.

    --

    Michael

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,340
    I think the UPNPplayer doesn't like some streams - I've seen something like this with BBCiPlayer plugin. The UPNP player tries to collect as much data as it can but wavinput is infinite.

    Get onto Phillip - there are UPNP plugin settings to avoid this.

    When you have problems like this - break it down to components - does the problem happen with real SB player is usually the first step.

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,340
    Lookingh at log again - what sort of player are you using ? I quickly assumed Plugin:UPNP was Phillip's UPNP player but it's not.

    arecord has a lot of memory not LMS (in fact it look like Plex is using more memory than LMS) - what is wavinput playing to ? Has it been paused ? Did you have an player playing and then turned it off and the "power off" setting are "pause at power off ". This shouldn't be a prpblem as normally the Linux pipe buffer limit kicks in but you haven't given any info on your setup.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •