Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jul 2018
    Posts
    4

    Can't open iTunes files

    Just recently I started not being able to play my iTunes files. I get "Can't open file: <filename>". I have this problem using Squeezebox hardware (Boom and Duets) and Squeezeplay. I found out that if I use Squeezepad, it works fine. I've done a clean install with no change. Running the server on another Mac works fine. I've been running it on this Mac for over a year with no problem. Looking at the transcoder log, it appears that the hardware uses the faad command but Squeezepad uses something else. I'm not sure what this means.

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,265
    Assuming the iTune files are either AAC or ALAC and not MP3, and without more details on working /not workgin system (h/w, OS versions , LMS versions) this "feels" like the AAC transcoding chain is broken.

    Older SB player such as Boom and Reciver cannot play AAC natively so they need to be trasncoded. Newer player such as Touch and have AAC support but maybe not ALAC support. No idea about Squeezepad.

    Checking WebUI Setting/Advanced/FileTypes to see whether you have support for AAC and ALAC (apple Lossless) via Flac through "faad/flac".
    Looking at the transcoder log, it appears that the hardware uses the faad command
    This is not very clear. What log did you use player.source set to INFO is best and look for "tokenized command" log entry. Copy log entry to a post.

    Try using a Terminal window test whether the flac and faad executable in the LMS Bin directory actually run on your system.

  3. #3
    Junior Member
    Join Date
    Jul 2018
    Posts
    4
    Thanks for your reply.

    Older SB player such as Boom and Reciver cannot play AAC natively so they need to be trasncoded. Newer player such as Touch and have AAC support but maybe not ALAC support. No idea about Squeezepad.
    These files have been playing fine until one day they didn't. I did find out that MP3 files work (I converted one file) but I don't know if it's a good idea to convert my whole library.

    Checking WebUI Setting/Advanced/FileTypes to see whether you have support for AAC and ALAC (apple Lossless) via Flac through "faad/flac".
    AAC via FLAC says faad/flac. Apple lossless says faad/sox.

    Try using a Terminal window test whether the flac and faad executable in the LMS Bin directory actually run on your system.
    Yes.

    This is not very clear. What log did you use player.source set to INFO is best and look for "tokenized command" log entry. Copy log entry to a post.
    I set the server log set to transcoder in the LMS preference pane. Then I tried to play a song. I've attached the log entry; it's too big for the post.
    Attached Files Attached Files

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    16,265
    Quote Originally Posted by stevehan View Post
    I set the server log set to transcoder in the LMS preference pane. Then I tried to play a song. I've attached the log entry; it's too big for the post.
    Not sure what you meant "set to transcoder" but I'm assuming it is my instruction. Also - you can zip the log file and often it will then be small enoiugh to attach.

    If things worked in the past and now have stopped - something has changed. It may be as simple as a system update, security s/w change or more complex as changing system paths - if you can list what has changed. it will help find the "culprit".
    Please supply system setup OS version, LMS version etc.- there may be a common answer realting to version/system which an Apple user can answer. I do not have any Apple stuff.

    However, the attached log has good info.

    Code:
    [18-07-08 13:15:26.0671] Slim::Player::Song::open (559) Tokenized command: "/Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin-x86_64/faad" -q -w -f 1 "/Users/miradorback/Music/iTunes/iTunes Music/801/801 Live/12 Third Uncle.m4a" | "/Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin-x86_64/flac" -cs --totally-silent --compression-level-0 --ignore-chunk-sizes - & |
    [18-07-08 13:15:26.0768] Slim::Player::SongStreamController::new (31) live=1
    [18-07-08 13:15:26.0782] Slim::Player::StreamingController::_Stream (1265) 40:6c:8f:3a:56:0e: stream
    [18-07-08 13:15:26.0808] Slim::Player::StreamingController::_Stream (1302) Song queue is now 0
    [18-07-08 13:15:26.0814] Slim::Player::StreamingController::_setPlayingState (2357) new playing state BUFFERING
    [18-07-08 13:15:26.0817] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state STREAMING
    [18-07-08 13:15:26.0819] Slim::Player::StreamingController::_eventAction (303) 40:6c:8f:3a:56:0e: NextTrackReady - new state BUFFERING-STREAMING
    [18-07-08 13:15:26.0823] Slim::Player::StreamingController::_eventAction (303) 40:6c:8f:3a:56:0e: Play - new state BUFFERING-STREAMING
    [18-07-08 13:15:26.0894] Slim::Player::StreamingController::_eventAction (271) 40:6c:8f:3a:56:0e: StatusHeartbeat in BUFFERING-STREAMING -> Slim::Player::StreamingController::_NoOp
    [18-07-08 13:15:26.3207] Slim::Player::Source::_wakeupOnReadable (409) 40:6c:8f:3a:56:0e
    [18-07-08 13:15:26.3213] Slim::Player::Source::_readNextChunk (350) Read to end of file or pipe
    [18-07-08 13:15:26.3215] Slim::Player::Source::_readNextChunk (373) end of file or error on socket, song pos: 4413785
    [18-07-08 13:15:26.3216] Slim::Player::Source::_readNextChunk (378) 40:6c:8f:3a:56:0e mark end of stream
    [18-07-08 13:15:26.3218] Slim::Player::Source::_readNextChunk (386) Didn't stream any bytes for this song; mark it as failed
    [18-07-08 13:15:26.3219] Slim::Player::StreamingController::playerStreamingFailed (2228) 40:6c:8f:3a:56:0e
    [18-07-08 13:15:26.3222] Slim::Player::StreamingController::_playersMessage (789) Problem: Can't open file for:: file:///Users/miradorback/Music/iTunes/iTunes%20Music/801/801%20Live/12%20Third%20Uncle.m4a
    The command line shows faad and flac set up to to tramscode.
    It also show transcode chain is set up and then fails (markeed in red). THis type of failure is usually because faad and flac have failed. Can you test each of the following in a Terminal window and post the output from the test
    Code:
    /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin-x86_64/faad
    /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin-x86_64/flac

  5. #5
    Junior Member
    Join Date
    Jul 2018
    Posts
    4
    Quote Originally Posted by bpa View Post
    If things worked in the past and now have stopped - something has changed. It may be as simple as a system update, security s/w change or more complex as changing system paths - if you can list what has changed. it will help find the "culprit".

    The command line shows faad and flac set up to to tramscode.

    Code:
    /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin-x86_64/faad
    /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin-x86_64/flac
    faad fails with a missing symbol from a library file error. After messing around comparing two systems' files, I just reinstalled 7.7.6 from mysqueezebox.com (which I'm pretty sure I did before) and now it's working. Whew...

    Thanks for helping me out.
    Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •