Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    May 2018
    Posts
    11

    RPI 3 currently with HiFiBerry digi+ , change to Allo DigiOne

    Dear Community,
    I have two RPI 3 B systems with a HiFiBerry Digi+ Pro, one with a SSD and LMS and Samba serving the SSD so I can rip FLAC Files to it from my Windows PC, the other in my living room playing music from the RPI with LMS with the attached SSD.

    Question: I bought an Allo DigiOne. Can I simply take off the Digi+ Pro HAT and attach the Allo DigiOne HAT and then just change the Squeezelite Audio Output Device setting to use the DigiOne?

    Also, what do I change the Output setting setting to? I currently have it set to: hw:CARD=sndrpihifiberry and finally do the ALSA settings change from: 8 4 1

    Thanks!

    Regards
    Steve

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,245
    There is a chance that you could just swap them out and nothing else change, but they do use different drivers. The Allo Digione uses a reset signal on GPIO 17 in it's drivers, where as the hifiberry does not. The correct way is to change the driver and squeezelite output.

    What OS and kernel are you using?

    You need to change the boot config of your pi to: (config.txt on your boot drive)

    Remove the line
    dtoverlay=hifiberry-digi-pro

    Add this line
    dtoverlay=allo-digione

    Then for the squeezelite output
    set it to: hw:CARD=sndallodigione

    And we recommend alsa settings of 80:4::1
    Last edited by paul-; 2018-07-06 at 15:58.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://sites.google.com/site/picoreplayer/home

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    May 2018
    Posts
    11
    Quote Originally Posted by paul- View Post
    There is a chance that you could just swap them out and nothing else change, but they do use different drivers. The Allo Digione uses a reset signal on GPIO 17 in it's drivers, where as the hifiberry does not. The correct way is to change the driver and squeezelite output.

    What OS and kernel are you using?

    You need to change the boot config of your pi to: (config.txt on your boot drive)

    Remove the line
    dtoverlay=hifiberry-digi-pro

    Add this line
    dtoverlay=allo-digione

    Then for the squeezelite output
    set it to: hw:CARD=sndallodigione

    And we recommend alsa settings of 80:4::1
    THANK YOU VERY MUCH ! Will give this a try! Very much appreciated!

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •