Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jun 2008
    Posts
    19

    Problems with Tidal syncing My Favorites / My Playlists

    Hi all,

    I've noticed what I believe is a recent problem with the My Favorites / My Playlists in the Tidal plugin. When changing an existing playlist on the Desktop client, the added tracks will not show up on the playlist, only the previous ones that were there before. Same thing with removing tracks from the playlist. Now the interesting part is that the cover for the playlist does update with the cover from the added albums - which means communication is happening but the files within the playlist are not being updated. When adding or removing albums from My Favorites or adding / removing playlists from My Playlists, it also takes some time (I'd say around 15 minutes at least) for the list to update - I assume this will only update when "touching base" again with mysqueezebox.com. However, tracks within the playlists will not update at all. Changing the playlist name updates the name (after some time) but the files within the playlist don't update anymore.

    In summary, to test this issue try the following steps:

    1. On Tidal Desktop, create a new playlist and add 1 full album to that playlist
    2. Go to the Tidal plugin on LMS and (after some time) the new playlist show show up. Check the playlist has all files from both album you added.
    3. Now go back to Tidal Desktop and add a few tracks from another album to the playlist you have created before. Also rename the playlist so you will now when it's updated (say add a 2 at the end).
    4. Go to the Tidal Plugin on LMS and (after some time), the updated playlist should show up. The cover for the playlist should include the cover for the tracks you added. However, on the track list, they will not show up at all.

    Even if adding just one album to the playlist and later on removing some tracks, all the tracks will still show.

    This behavior was seen on both one of the latest 7.9.1 versions (30th March I believe) and on the latest 7.9.2 (1 Jun). I've enabled debugging for Squeezenetwork and Tidal plugin. Between 7.9.1 and 7.9.2 I notice 7.9.2 now uses https instead of http. Other than that I see no errors or problems there.

    Any light on what the problem may be?

    Nuno

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,005

    Problems with Tidal syncing MyFavorites / My Playlists

    > However, tracks within the playlists will not update at all. Changing

    Are you sure they don't update at all? Even after a day or two?

    If that changed, then there must have been a change/issue on Tidal's
    end, as I haven't touched mysb.com code in a while...

    --

    Michael

  3. #3
    Junior Member
    Join Date
    Jun 2008
    Posts
    19
    Quote Originally Posted by mherger View Post
    > However, tracks within the playlists will not update at all. Changing

    Are you sure they don't update at all? Even after a day or two?

    If that changed, then there must have been a change/issue on Tidal's
    end, as I haven't touched mysb.com code in a while...

    --

    Michael
    Hi Michael,

    Indeed after a couple of days it did eventually sync everything correctly. What I did find strange, and hence the report here, was the fact that the cover image for the playlist updated correctly with the added album which, for me, showed there was *some* synchronization. Can you let us know roughly how this synchronization works?

    Nuno

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,005

    Problems with Tidal syncing MyFavorites / My Playlists

    > Indeed after a couple of days it did eventually sync everything
    > correctly. What I did find strange, and hence the report here, was the
    > fact that the cover image for the playlist updated correctly with the
    > added album which, for me, showed there was *some* synchronization. Can
    > you let us know roughly how this synchronization works?


    I haven't looked in to the details of this. But different caches apply
    for metadata and artwork. Images are cached by your browser, or the
    client (squeezeplay on device, smartphone app or whatever otherwise).
    Query results we do cache on mysb.com. I thought we had less aggressive
    caching for user owned content, as the user there usually knows when
    things change. But I'd have to review the code more thoroughly to be
    sure that was the case.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •