Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,085

    Android APP not capturingbroadcast from Player

    Well, then your Android app is probably f... up. I think there have been
    other users who reported that after a clean re-install it did work again...

    --

    Michael

  2. #12
    Junior Member
    Join Date
    Jun 2018
    Posts
    8
    I tested to uninstall the app and install it again. right from the start, when I enter the app I can't see my squeeze players, if I hit apply in the server the immediately appear, same as before. I will try it out with a different phone just to rule out the possibility of being related with the phone itself.

    Just to be clear, on a different network, with only local disabled in the Android app and with "Don't announce Squeezebox players running in Spotify Connect mode in your network" disabled in the server, I should see the player in my phone! Correct!?

    I'm almost doing a script to hit apply every mint or so to solve the problem...

  3. #13
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,085

    Android APP not capturingbroadcast from Player

    Did you enable logging for plugin.spotty to see what's going on LMS side?

    --

    Michael

  4. #14
    Junior Member
    Join Date
    Jun 2018
    Posts
    8
    This is the logs

    Code:
    [18-06-07 17:46:41.0016] Plugins::Spotty::Connect::DaemonManager::startHelper (100) Need to (re-)start Connect daemon for b8:27:eb:63:0b:08
    [18-06-07 17:46:41.0022] Plugins::Spotty::Connect::Daemon::start (66) Starting Spotty Connect daemon: 
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/i386-linux/spotty -c /var/lib/squeezeboxserver/cache/spotty/b827eb630b08 -n OSMC-Sala --disable-audio-cache --bitrate 96 --player-mac b8:27:eb:63:0b:08 --lms 192.168.2.51:9000
    [18-06-07 17:46:41.7235] Plugins::Spotty::Connect::_connectEvent (275) Got called from spotty helper: volume
    [18-06-07 17:47:41.0041] Plugins::Spotty::Connect::DaemonManager::initHelpers (70) Initializing Spotty Connect helper daemons...
    [18-06-07 17:48:41.0042] Plugins::Spotty::Connect::DaemonManager::initHelpers (70) Initializing Spotty Connect helper daemons...
    [18-06-07 17:49:41.0037] Plugins::Spotty::Connect::DaemonManager::initHelpers (70) Initializing Spotty Connect helper daemons...
    [18-06-07 17:50:41.0061] Plugins::Spotty::Connect::DaemonManager::initHelpers (70) Initializing Spotty Connect helper daemons...
    [18-06-07 17:51:41.0018] Plugins::Spotty::Connect::DaemonManager::initHelpers (70) Initializing Spotty Connect helper daemons...
    [18-06-07 17:52:40.0051] Plugins::Spotty::Connect::DaemonManager::initHelpers (70) Initializing Spotty Connect helper daemons...
    [18-06-07 17:53:40.0047] Plugins::Spotty::Connect::DaemonManager::initHelpers (70) Initializing Spotty Connect helper daemons...
    I also tried changing the helper to spotty, by default it was using spotty-x86_64.

    I made a small test that it might point in the right direction. The player was showing in my android, I cut the connection from my server to the network, the player disappeared (that is correct, no connection), but after that it never appeared again. Can it be that for some reason my server is losing temporary the connection to the network/internet, and when it returns the plugin does not send the information of the connected devices again?


    If I force the execution of
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/i386-linux/spotty -c /var/lib/squeezeboxserver/cache/spotty/b827eb630b08 -n OSMC-Sala --disable-audio-cache --bitrate 96 --player-mac b8:27:eb:63:0b:08 --lms 192.168.2.51:9000

    The device appears, and it disappears when I exit, so the plugin must be failing for some reason. If I do a ps -aux I can still see the process running, so it didn't stoped

    Thank You
    Last edited by Soloam; 2018-06-08 at 01:52.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •