Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Senior Member
    Join Date
    Jan 2008
    Posts
    370

    CLI does not see LMS's proper IP?

    Hi,

    I'm running the latest nightly LMS 7.9.2 on Windows Server 2012R2. It gets the fixed IP 192.168.1.2 from the router.

    For example, the UPNP bridge plugin knows about this IP

    Code:
    [18-06-03 21:05:45.2127] Plugins::UPnPBridge::Settings::handler2 (257) reading: upnp_socket 192.168.1.2
    [18-06-03 21:05:45.2131] Plugins::UPnPBridge::Settings::handler2 (257) reading: log_limit -1
    but further down the log, it seems that the CLI on port 9090 is not aware.

    Code:
    [18-06-03 21:25:51.3718] Slim::Plugin::CLI::Plugin::cli_socket_accept (227) Begin Function
    [18-06-03 21:25:51.4576] Slim::Plugin::CLI::Plugin::cli_socket_accept (250) Access to CLI is restricted to the local network or localhost: 169.254.148.151

    The only peculiar thing about the machine on which the server runs is that there are 4 Ethernet ports on the motherboard, of which only one is connected. I've specifically opened up port 9090 on the motherboard and things like iPeng has always worked fine.


    How can I trouble shoot this? Philippe44 suggests this may be leading to problems with his plugin.

  2. #2
    Senior Member
    Join Date
    Sep 2005
    Posts
    2,603
    Quote Originally Posted by Wigster View Post
    Hi,
    Code:
    [18-06-03 21:25:51.3718] Slim::Plugin::CLI::Plugin::cli_socket_accept (227) Begin Function
    [18-06-03 21:25:51.4576] Slim::Plugin::CLI::Plugin::cli_socket_accept (250) Access to CLI is restricted to the local network or localhost: 169.254.148.151

    The only peculiar thing about the machine on which the server runs is that there are 4 Ethernet ports on the motherboard, of which only one is connected. I've specifically opened up port 9090 on the motherboard and things like iPeng has always worked fine.
    Hi,

    i would disable the 3 NICs and or would use ipconfig /all to find the NIC with that apipa Adress 169.254.148.151 and try it with conneting that NIC instead.

    you need to reboot the system more than once to get an idea if that nic is always the one lms is using.

  3. #3
    Senior Member
    Join Date
    Apr 2013
    Location
    UK
    Posts
    1,243
    https://en.m.wikipedia.org/wiki/Link-local_address




    Transcoded from Matt's brain by Tapatalk
    --
    Hardware: 3x Touch, 1x Radio, 2x Receivers, 1 HP Microserver NAS with Debian+LMS 7.9.0
    Music: ~1300 CDs, as 450 GB of 16/44k FLACs. No less than 3x 24/44k albums..

  4. #4
    Senior Member
    Join Date
    Jan 2008
    Posts
    370
    Quote Originally Posted by DJanGo View Post
    Hi,

    i would disable the 3 NICs and or would use ipconfig /all to find the NIC with that apipa Adress 169.254.148.151 and try it with conneting that NIC instead.

    you need to reboot the system more than once to get an idea if that nic is always the one lms is using.
    The other NICs have no IP assigned and the connected one is only 192.168.1.2 according to ipconfig.


    Sent from my iPhone using Tapatalk

  5. #5
    Senior Member
    Join Date
    Sep 2005
    Posts
    2,603
    Quote Originally Posted by Wigster View Post
    The other NICs have no IP assigned and the connected one is only 192.168.1.2 according to ipconfig.


    Sent from my iPhone using Tapatalk
    Did you ipconfig or ipconfig /all?
    Are the other NIC disabled or just unplugged?

    I dont believe lms would get itself a apipa adress out of nowhere - so check with /all.

  6. #6
    Senior Member
    Join Date
    Jan 2008
    Posts
    370
    I did it will /all and it’s not there.

    The thing is that the IP reported in the Information tab of the settings is the real one , 192.168.1.2, it’s just the CLI reporting it in the log....


    Sent from my iPhone using Tapatalk

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,085

    CLI does not see LMS's proper IP?

    > The thing is that the IP reported in the Information tab of the settings
    > is the real one , 192.168.1.2, it’s just the CLI reporting it in the
    > log....


    The IP address reported in the warning is supposed to be the address
    where the request came from... Is your CLI connection coming from the
    same system?

    --

    Michael

  8. #8
    Senior Member
    Join Date
    Jan 2008
    Posts
    370
    Quote Originally Posted by mherger View Post
    > The thing is that the IP reported in the Information tab of the settings[color=blue]
    The IP address reported in the warning is supposed to be the address
    where the request came from... Is your CLI connection coming from the
    same system?
    I guess this request is coming from Philippe's UPNPBridge, which indeed seems to assign to itself IPs in the range 169.x.x.x. The bridge *is* running on the same machine though.

    I have disabled all the Ethernet devices apart from the connected one and now this problem is gone. I guess from your reply Michael, that I should take this to Philippe44...

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •