Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Spotty help?

  1. #11
    Junior Member
    Join Date
    Jun 2020
    Posts
    7

    Unable to download Spotty

    Hi Michael,
    I wonder if you can help. Running LMS 7.9.1 on a Netgear NAS ReadyNAS 4. When I install 7.9.2 or later LMS isnt' working at all. However I see the Spotty Plugin under 3 party software but I can't install it.
    Tried som of your other plugins like What Was That Tune and that works fine, it's Spotty install that's the problem.

    Any hints?

    Kind Regards Leif

  2. #12
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,539

    Spotty help?

    > I wonder if you can help. Running LMS 7.9.1 on a Netgear NAS ReadyNAS 4.
    > When I install 7.9.2 or later LMS isnt' working at all. However I see
    > the Spotty Plugin under 3 party software but I can't install it.


    How would you see Spotty if LMS wasn't running? What package did you
    install?

    --

    Michael

  3. #13
    Junior Member
    Join Date
    Jun 2020
    Posts
    7
    Quote Originally Posted by mherger View Post
    > I wonder if you can help. Running LMS 7.9.1 on a Netgear NAS ReadyNAS 4.
    > When I install 7.9.2 or later LMS isnt' working at all. However I see
    > the Spotty Plugin under 3 party software but I can't install it.


    How would you see Spotty if LMS wasn't running? What package did you
    install?

    --

    Michael
    LMS is rundning under 7.9.1. It┤s the latest version that works. I bad to go back to that version.

    /Leif

  4. #14
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,539

    Spotty help?

    > LMS is rundning under 7.9.1. It┬┤s the latest version that works. I bad
    > to go back to that version.


    Most likely 7.9.1 would fain in some other, more subtle ways. Eg. it
    would fail to download Spotty due to outdated SSL libraries...

    It's probably time to think about alternatives to running LMS on the
    ReadyNAS. Eg. run LMS on a Raspberry Pi connected to the NAS.

    --

    Michael

  5. #15
    Junior Member
    Join Date
    Jun 2020
    Posts
    7
    Quote Originally Posted by mherger View Post
    > LMS is rundning under 7.9.1. It┬┤s the latest version that works. I bad
    > to go back to that version.


    Most likely 7.9.1 would fain in some other, more subtle ways. Eg. it
    would fail to download Spotty due to outdated SSL libraries...

    It's probably time to think about alternatives to running LMS on the
    ReadyNAS. Eg. run LMS on a Raspberry Pi connected to the NAS.

    --

    Michael
    Hovever it worked brefore about half a year ago. I didn't notice when it stopped working. Propably I have updated to 7.9.2 due to setting: search for new versions, but I have just used Mysqeezebox.com and Internet Radio lately so haven't
    tested Spotty. There's no way to install it manually or to update the SSL libraries? I can download it from a web browser but the NAS can't. Se the log:

    [20-06-07 22:49:52.6685] Slim::Plugin::Extensions::Plugin::findUpdates (307) Spotty action install version 4.1.1
    [20-06-07 22:49:52.6693] Slim::Plugin::Extensions::Plugin::findUpdates (307) PlayHistory action install version 1.0.7
    [20-06-07 22:49:52.6700] Slim::Plugin::Extensions::Settings::_addInfo (240) installing Spotty from https://downloads.nixda.ch/Spotty-4.1.1.zip
    [20-06-07 22:49:52.6940] Slim::Utils::PluginDownloader::_downloadError (217) unable to download Spotty from https://downloads.nixda.ch/Spotty-4.1.1.zip - Connect timed out:
    [20-06-07 22:49:52.6949] Slim::Plugin::Extensions::Settings::_addInfo (240) installing PlayHistory from http://www.herger.net/_data/PlayHistory-1.0.7.zip
    [20-06-07 22:49:52.9324] Slim::Plugin::Extensions::Settings::__ANON__ (147) PluginDownloader is still busy - waiting a little longer...
    /Leif

  6. #16
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,539

    Spotty help?

    > Hovever it worked brefore about half a year ago. I didn't notice when it

    SSL support on web servers has changed a lot recently. What worked a
    year ago might well no longer work today. Servers often require more
    recent protocols or certificates than what was available a while ago.

    > tested Spotty. There's no way to install it manually or to update the


    You can install it manually. But as I said: you're likely just going
    work around one road block just to hit the next.

    In LMS go to Settings/Information to find out where your "Plugins"
    folder is. Then grab a copy of the latest Spotty (see the link in your
    log file) and extract that file into that Plugins folder. Restart LMS.

    > SSL libraries? I can download it from a web browser but the NAS can't.


    Don't know how feasible updating those libraries on a ReadyNAS is. As
    mentioned many times before you better run LMS on a Raspberry Pi.

    --

    Michael

  7. #17
    Junior Member
    Join Date
    Jun 2020
    Posts
    7
    Quote Originally Posted by mherger View Post
    > Hovever it worked brefore about half a year ago. I didn't notice when it

    SSL support on web servers has changed a lot recently. What worked a
    year ago might well no longer work today. Servers often require more
    recent protocols or certificates than what was available a while ago.

    > tested Spotty. There's no way to install it manually or to update the


    You can install it manually. But as I said: you're likely just going
    work around one road block just to hit the next.

    In LMS go to Settings/Information to find out where your "Plugins"
    folder is. Then grab a copy of the latest Spotty (see the link in your
    log file) and extract that file into that Plugins folder. Restart LMS.

    > SSL libraries? I can download it from a web browser but the NAS can't.


    Don't know how feasible updating those libraries on a ReadyNAS is. As
    mentioned many times before you better run LMS on a Raspberry Pi.

    --

    Michael
    Thanks a lot for your explanaition, I will give it a try, tthere's not much to loose. Otherwise it will have to be an upgrade to a new NAS or a Rasberry as you said.
    Apriciate your help! :-)

  8. #18
    Junior Member
    Join Date
    Jun 2020
    Posts
    7
    Quote Originally Posted by Leifj63 View Post
    Thanks a lot for your explanaition, I will give it a try, tthere's not much to loose. Otherwise it will have to be an upgrade to a new NAS or a Rasberry as you said.
    Apriciate your help! :-)
    Hi again Michael,
    I ended up buying a new NAS, quite cheap a Zyxel 326 with LMS as a preinstalled app, but unfortunally the old 7.7.4 with no update option. I managed to install Spotty but get the message "Spotty requires the Perl module IO::Socket::SSL"
    I guess it was a misstake buying a Zyxel, it doesn't seem to have so much options to install what you like.

    Any hint on this one, what I've been reading there's not much help to get from Zyxel support?

    /Leif

  9. #19
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,539

    Spotty help?

    > I guess it was a misstake buying a Zyxel, it doesn't seem to have so
    > much options to install what you like.


    Use the NAS for what it is designed to be: a Network Attached Storage.
    And get a Raspberry Pi to run LMS on, reading the files from the NAS.
    It's pretty straight forward using piCorePlayer.

    --

    Michael

  10. #20
    Junior Member
    Join Date
    Jun 2020
    Posts
    7

    Synology

    Quote Originally Posted by mherger View Post
    > I guess it was a misstake buying a Zyxel, it doesn't seem to have so
    > much options to install what you like.


    Use the NAS for what it is designed to be: a Network Attached Storage.
    And get a Raspberry Pi to run LMS on, reading the files from the NAS.
    It's pretty straight forward using piCorePlayer.

    --

    Michael
    I switched the Zyxel to a Synology 218 play and now LMT 8.0.0 is running and also Spotty without problems. If/when I get problems with this NAS I will follow your advice and run it on a Raspberry instead.
    Thank's a lot for your advices.
    Cheers Leif

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •