Does anyone else get a Digest Mismatch error when trying to install the latest nightly build on Fedora 27 ?

Running transaction
Preparing : 1/1
Running scriptlet: logitechmediaserver-7.9.1-0.1.1520781386.noarch 1/2
Upgrading : logitechmediaserver-7.9.1-0.1.1520781386.noarch 1/2
Error unpacking rpm package logitechmediaserver-7.9.1-0.1.1520781386.noarch
Error unpacking rpm package logitechmediaserver-7.9.1-0.1.1520781386.noarch
error: unpacking of archive failed on file /usr/share/squeezeboxserver/CPAN/arch/5.20/i386-linux-thread-multi-64int/auto/DBD/SQLite/SQLite.so;5aa6f8bf: cpio: Digest mismatch
logitechmediaserver-7.9.1-0.1.1520781386.noarch was supposed to be installed but is not!
Verifying : logitechmediaserver-7.9.1-0.1.1520781386.noarch 1/2
logitechmediaserver-7.9.1-0.1.1519287262.noarch was supposed to be removed but is not!
Verifying : logitechmediaserver-7.9.1-0.1.1519287262.noarch 2/2

Failed:
logitechmediaserver.noarch 7.9.1-0.1.1520781386