Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7

Thread: aarch64

  1. #1
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,805

    aarch64

    I'm a bit confused with the situation with aarch64. I thought it was now supported, but I can't find a package that clearly talks about it. WHen using the "xxxxxall.deb" on my 64 bits ARM arch, it installs but does not run. Where shall I look?
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    aarch64

    > I'm a bit confused with the situation with aarch64. I thought it was now
    > supported, but I can't find a package that clearly talks about it. WHen


    There's no general support for aarch64, because that only defines the
    CPU architecture. The Perl binaries are always the combination of at
    least one more factor: the Perl version being used. What's your Perl
    version string?

    --

    Michael

  3. #3
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,805
    Quote Originally Posted by mherger View Post
    > I'm a bit confused with the situation with aarch64. I thought it was now
    > supported, but I can't find a package that clearly talks about it. WHen


    There's no general support for aarch64, because that only defines the
    CPU architecture. The Perl binaries are always the combination of at
    least one more factor: the Perl version being used. What's your Perl
    version string?

    --

    Michael
    I know this Perl binary thing too well, unfortunately with my plugins - this one is running 5.22.1
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    aarch64

    So far we only have binaries for 5.24+... what device is this? What OS?

    > Am 12.03.2018 um 20:33 schrieb philippe_44 <philippe_44.8e1ben (AT) no-mx (DOT) forums.slimdevices.com>:
    >
    >
    > mherger wrote:
    >>> I'm a bit confused with the situation with aarch64. I thought it was

    >> now
    >>> supported, but I can't find a package that clearly talks about it.

    >> WHen
    >>
    >> There's no general support for aarch64, because that only defines the
    >> CPU architecture. The Perl binaries are always the combination of at
    >> least one more factor: the Perl version being used. What's your Perl
    >> version string?
    >>
    >> --
    >>
    >> Michael

    >
    > I know this Perl binary thing too well, unfortunately with my plugins -
    > this one is running 5.22.1
    >
    >
    >
    > LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos
    > PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000,
    > ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi
    > B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010,
    > AppleTV 4, Airport Express, GGMM E5
    > ------------------------------------------------------------------------
    > philippe_44's Profile: http://forums.slimdevices.com/member.php?userid=17261
    > View this thread: http://forums.slimdevices.com/showthread.php?t=108809
    >
    >

  5. #5
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,805
    Quote Originally Posted by mherger View Post
    So far we only have binaries for 5.24+... what device is this? What OS?

    > Am 12.03.2018 um 20:33 schrieb philippe_44 <philippe_44.8e1ben (AT) no-mx (DOT) forums.slimdevices.com>:
    >
    >
    > mherger wrote:
    >>> I'm a bit confused with the situation with aarch64. I thought it was

    >> now
    >>> supported, but I can't find a package that clearly talks about it.

    >> WHen
    >>
    >> There's no general support for aarch64, because that only defines the
    >> CPU architecture. The Perl binaries are always the combination of at
    >> least one more factor: the Perl version being used. What's your Perl
    >> version string?
    >>
    >> --
    >>
    >> Michael

    >
    > I know this Perl binary thing too well, unfortunately with my plugins -
    > this one is running 5.22.1
    >
    >
    >
    > LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos
    > PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000,
    > ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi
    > B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010,
    > AppleTV 4, Airport Express, GGMM E5
    > ------------------------------------------------------------------------
    > philippe_44's Profile: http://forums.slimdevices.com/member.php?userid=17261
    > View this thread: http://forums.slimdevices.com/showthread.php?t=108809
    >
    >
    It's an odroid C2, running Ubuntu 16.04.3 - I'll try to find a way to have LMS running under Perlbrew

    (which I failed to do so far, many modules won't load)

    The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 Sub::Name)
    Last edited by philippe_44; 2018-03-12 at 21:34.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    aarch64

    > It's an odroid C1, running Debian

    I'm running a Debian 9.3 on a Rock64. Is there any update available for
    yours?

    In any case: you shouldn't have any problems building binaries yourself.
    Grab a copy of https://github.com/Logitech/slimserver-vendor and rund
    buildme.sh inside the CPAN folder. Then do something else while it's
    working hard for a while...

    --

    Michael

  7. #7
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,805
    Quote Originally Posted by mherger View Post
    > It's an odroid C1, running Debian

    I'm running a Debian 9.3 on a Rock64. Is there any update available for
    yours?

    In any case: you shouldn't have any problems building binaries yourself.
    Grab a copy of https://github.com/Logitech/slimserver-vendor and rund
    buildme.sh inside the CPAN folder. Then do something else while it's
    working hard for a while...

    --

    Michael
    Worked nice and easy

    Thanks!
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •