Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1

    Can't play stream through LMS; other players work fine

    I'm trying to play a particular stream (or series of) through LMS. They play fine through VLC or directly through a browser.

    One example stream is http://emit-media-production.s3.amaz...-rising_64.m4a

    The debug logs in from LMS are

    I've sniffed the network traffic on the server using tcpdump/wireshark and it _seems_ that the file starts streaming successfully (at least from a network perspective), but the LMS server isn't doing anything with it.

    Any ideas?
    Attached Files Attached Files

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,807
    You don't say what players nor which OS LMS you are using.
    The stream has a mime of audio/mp4 - this is an mpeg-4 enco0ded stream.
    Some mpeg4- stream cannot played natively by players which can natively play AAC (i.e. Touch, Radio, Squeezelite) .

    You could try disable "native" for "MPEG-4" file types and see if faad can handled the transcoding .

    If faad cannot handle - then you can set up a custom-convet.conf file to use ffmpeg / avconv dependingn your OS . Below assume Linux and avconv. You will lose skip forward to a time capability.
    Code:
    mp4 flc * *
    	# FRB:{BITRATE=-B %B}T:{START=-ss %s}
    	[avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -

  3. #3
    Quote Originally Posted by bpa View Post
    You don't say what players nor which OS LMS you are using.
    The stream has a mime of audio/mp4 - this is an mpeg-4 enco0ded stream.
    Some mpeg4- stream cannot played natively by players which can natively play AAC (i.e. Touch, Radio, Squeezelite) .

    You could try disable "native" for "MPEG-4" file types and see if faad can handled the transcoding .

    If faad cannot handle - then you can set up a custom-convet.conf file to use ffmpeg / avconv dependingn your OS . Below assume Linux and avconv. You will lose skip forward to a time capability.
    Code:
    mp4 flc * *
    	# FRB:{BITRATE=-B %B}T:{START=-ss %s}
    	[avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -
    Server is on Linux (ubuntu), and players are SB Radio, however, I've tried on a squeezelite softplayer and it behaves the same.

    I've tried setting the custom-convert.conf file as you suggested, but still behaves the same way, though the server log has this as it's final lines (before repeat the last line over and over)

    Code:
    [18-03-12 11:32:40.2372] Slim::Player::TranscodingHelper::checkBin (241)   Found command: [avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -
    [18-03-12 11:32:40.2373] Slim::Player::TranscodingHelper::getConvertCommand2 (428) Matched: mp4->flc via: [avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -
    [18-03-12 11:32:42.0055] Slim::Player::StreamingController::_eventAction (271) XX:XX:XX:XX:XX:XX: StatusHeartbeat in STOPPED-IDLE -> Slim::Player::StreamingController::_N
    oOp
    btw, which debug logs should I be looking at? I've set the ones that sound appropriate, but it's hard to tell exactly what's relevant here.

    I've also noticed the following line in the logs, which might be of concern:
    Code:
    [18-03-12 11:37:44.1884] Slim::Player::StreamingController::_playersMessage (789) Problem: Can't connect to server for:: http://emit-media-production.s3.amazonaws.com/pbs
    /5ft-high-rising/2018/03/10/0600/201803100600_5ft-high-rising_64.m4a
    Last edited by askvictor; 2018-03-11 at 17:40.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,807
    You'll get that error if you haven't disabled "native" for MPEG-4 file type.

    The log is player.source set to DEBUG and the snippets of logs are not enough as sometime it is message that are missing that indiciate problems.
    When giving a log - note time for start of test, do test and note time end of test and copy ALL message between those times into a text file, zip and then attach to a post.

  5. #5
    Thanks heaps! That seems to have fixed it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •