Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Member
    Join Date
    Feb 2015
    Location
    Ecuador
    Posts
    54
    Quote Originally Posted by mherger View Post
    > The curl command times out: curl: (7) Failed to connect to
    > repos.squeezecommunity.org port 80: Connection timed out


    Is your Pi's network (in particular the gateway) set up correctly? Would
    the same curl command work from a different computer?

    --

    Michael
    I also tried the curl command from my laptop, it timed out as well.

    Full disclosure - I also run pi hole (https://pi-hole.net/) ad blocker on the same pi. I've had pi hole and LMS running together for at least 2 years without any problem. The LMS problem persists even if I turn pi hole off.

    I also tried setting Google as the DNS server (8.8.8.8) directly in the router to totally bypass pi hole, and I still get the same problems with the plugin page and the curl time out both on the pi and my laptop.

    Other than that, it's a pretty vanilla set up.

  2. #12
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,176
    Quote Originally Posted by AngloCuencano View Post
    Raspbian Jessie Lite
    Quote Originally Posted by AngloCuencano View Post

    Full disclosure - I also run pi hole (https://pi-hole.net/) ad blocker on the same pi. I've had pi hole and LMS running together for at least 2 years without any problem. The LMS problem persists even if I turn pi hole off.
    Anglo

    Why are you running an ad blocker if using Jessie-Lite?

    Most people would run the Lite versions headless.

    Check your pm.

    Ronnie

  3. #13
    Member
    Join Date
    Feb 2015
    Location
    Ecuador
    Posts
    54
    Quote Originally Posted by Man in a van View Post
    Anglo

    Why are you running an ad blocker if using Jessie-Lite?

    Most people would run the Lite versions headless.

    Check your pm.

    Ronnie
    I do run the pi headless. The pi hole works as a network-wide ad blocker. My router refers all DNS requests to the pi, pi hole checks the domain against a blacklist, and only non-blacklisted requests are forwarded to the DNS. It speeds up page loading quite considerably.

  4. #14
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    3rd Party Plugins Missing

    What about

    curl -I http://www.herger.net/slim-plugins/repo.xml

    It's hosted on the same machine. If that works, but repos don't, then
    it's not a networking issue, but limited to the virtual host.

    --

    Michael

  5. #15
    Member
    Join Date
    Feb 2015
    Location
    Ecuador
    Posts
    54
    Quote Originally Posted by mherger View Post
    What about

    curl -I http://www.herger.net/slim-plugins/repo.xml

    It's hosted on the same machine. If that works, but repos don't, then
    it's not a networking issue, but limited to the virtual host.

    --

    Michael
    With the pi powered off and DNS in the router set to 8.8.8.8, issuing the curl command from my laptop fails (curl: (7) Failed to connect to port 80: Connection timed out) for both www.herger.net and repos.squeezecommunity.org. I can successfully ping both domains.

  6. #16
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    3rd Party Plugins Missing

    > With the pi powered off and DNS in the router set to 8.8.8.8, issuing
    > the curl command from my laptop fails (curl: (7) Failed to connect to
    > port 80: Connection timed out) for both www.herger.net and
    > repos.squeezecommunity.org. I can successfully ping both domains.

    That's odd. I'll double-check with my hosting service whether they were
    blocking some traffic.

    Can you access metanet.ch (my ISP)?

    --
    --

    Michael

  7. #17
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    3rd Party Plugins Missing

    Could you please PM me your gateway IP address?

    --

    Michael

  8. #18
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    3rd Party Plugins Missing

    > That's odd. I'll double-check with my hosting service whether they were
    > blocking some traffic.

    Oh... they just confirmed that your IP address had been blocked for
    unknown reason... could you please try again?

    --

    Michael

  9. #19
    Member
    Join Date
    Feb 2015
    Location
    Ecuador
    Posts
    54
    Quote Originally Posted by mherger View Post

    Can you access metanet.ch (my ISP)?
    With the pi and pi hole both running, I get this response when I run the command from my pi or from my laptop:

    Code:
    Lemur-Ultra:~$ curl -I http://metanet.ch
    HTTP/1.1 301 Moved Permanently
    Server: nginx
    Date: Tue, 13 Feb 2018 14:14:41 GMT
    Content-Type: text/html
    Content-Length: 178
    Connection: keep-alive
    Location: http://www.metanet.ch/

  10. #20
    Member
    Join Date
    Feb 2015
    Location
    Ecuador
    Posts
    54
    Quote Originally Posted by mherger View Post
    >
    Oh... they just confirmed that your IP address had been blocked for
    unknown reason... could you please try again?
    3rd party plugins are back. The problem may have been related to the pi hole. Occasionally, Google will complain about unexpected activity coming from my IP address, which I think is also related to the pi hole.

    Thanks for your help Michael.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •