Home of the Squeezebox™ & Transporter® network music players.
Page 51 of 62 FirstFirst ... 41495051525361 ... LastLast
Results 501 to 510 of 617
  1. #501
    Quote Originally Posted by digimaster View Post
    Logon by ssh shell, ( putty). Then do CD /share/*/.qpkg. Now do ./QLogitechMediaServer.sh stop. Next do rm -R SlimServer/. Now do . /QLogitechMediaServer.sh start.

    Through you completely wiped the LMS installation including the settings, and reinstalled LMS from scratch.
    Hi digimaster,

    do I understand you right that this way I would loose all individual settings ("completely wiped .... including the settings")? Is there no other way that would retain my settings? Or do you mean that this way I would keep my settings while LMS would be newly installed from scratch?

    Best regards
    Stefan

  2. #502
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Quote Originally Posted by steklo View Post
    Hi digimaster,

    do I understand you right that this way I would loose all individual settings ("completely wiped .... including the settings")? Is there no other way that would retain my settings? Or do you mean that this way I would keep my settings while LMS would be newly installed from scratch?

    Best regards
    Stefan
    If you need to install lms from scratch, but keep the settings. Do ./QLogitechMediaServer.sh clean and then QLogitechMediaServer restart. Will wipe the LMS, keep the settings and install LMS.

    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  3. #503
    I did:

    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] # ./QLogitechMediaServer.sh stop
    Stopping LogitechMediaServer [10999] in the Background.
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] # ./QLogitechMediaServer.sh clean
    use ./QLogitechMediaServer.sh start, stop, status, restart, backup, restore or failsafe ( use this when trouble with loading plugins )
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] # ./QLogitechMediaServer.sh restart
    Gone restart LogitechMediaServer !
    LogitechMediaServer is started in the Background on [14780] !
    Please wait a few minutes, before you try to access the webgui through http://192.168.178.65:9001 !
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] #

    But nothing changed. When I tell LMS to scan the music folder it's through with that within a second resulting in an empty library... Can it be there is something wrong with the command "./QLogitechMediaServer.sh clean"? It doesn't seem to have been executed, does it?
    Or would I better remove LMS completely and set up from scratch as you suggested first?

    Best regards
    Stefan
    Last edited by steklo; 2019-07-26 at 13:13.

  4. #504
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Quote Originally Posted by steklo View Post
    I did:

    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] # ./QLogitechMediaServer.sh stop
    Stopping LogitechMediaServer [10999] in the Background.
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] # ./QLogitechMediaServer.sh clean
    use ./QLogitechMediaServer.sh start, stop, status, restart, backup, restore or failsafe ( use this when trouble with loading plugins )
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] # ./QLogitechMediaServer.sh restart
    Gone restart LogitechMediaServer !
    LogitechMediaServer is started in the Background on [14780] !
    Please wait a few minutes, before you try to access the webgui through http://192.168.178.65:9001 !
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] #

    But nothing changed. When I tell LMS to scan the music folder it's through with that within a second resulting in an empty library... Can it be there is something wrong with the command "./QLogitechMediaServer.sh clean"? It doesn't seem to have been executed, does it?
    Or would I better remove LMS completely and set up from scratch as you suggested first?

    Best regards
    Stefan
    The best you could do build LMS from scratch. Did you ever used the QLogitechMediaServer.sh backup. If so there is a backup of all the settings including the library. So you can always restore the settings, even if you build lms from scratch.

    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  5. #505
    This is what I performed at the end of last year:

    First:

    [ cd /share/*/.qpkg/LogitechMediaServer ]
    [ rm -R SlimServer/ ]
    [ ./QLogitechMediaServer.sh start ]
    [ ./QLogitechMediaServer.sh stop ]
    [ rm -r SlimServer/Cache ], [ rm -r SlimServer/prefs ]

    Then:

    [ cp -RP /share/*/Multimedia/prefs SlimServer/ ], [ cp -RP /share/*/Multimedia/Cache SlimServer/ ]
    [ ls -l SlimServer/]

    Finally:

    [ chown -R squeezeboxserver SlimServer/ ] , [ chmod -R 0755 SlimServer/ ]
    [ ./QLogitechMediaServer.sh restart ]

    Does anything of that that help to restore the settings after I installed LMS from scratch?

    Furthermore I found you suggestions: For a backup do ./QLogitechMediaServer.sh backup, to restore ./QLogitechMediaServer.sh restore ! But I think I never did use this command lines.

    Best regards
    Stefan

  6. #506
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Quote Originally Posted by steklo View Post
    This is what I performed at the end of last year:

    First:

    [ cd /share/*/.qpkg/LogitechMediaServer ]
    [ rm -R SlimServer/ ]
    [ ./QLogitechMediaServer.sh start ]
    [ ./QLogitechMediaServer.sh stop ]
    [ rm -r SlimServer/Cache ], [ rm -r SlimServer/prefs ]

    Then:

    [ cp -RP /share/*/Multimedia/prefs SlimServer/ ], [ cp -RP /share/*/Multimedia/Cache SlimServer/ ]
    [ ls -l SlimServer/]

    Finally:

    [ chown -R squeezeboxserver SlimServer/ ] , [ chmod -R 0755 SlimServer/ ]
    [ ./QLogitechMediaServer.sh restart ]

    Does anything of that that help to restore the settings after I installed LMS from scratch?

    Furthermore I found you suggestions: For a backup do ./QLogitechMediaServer.sh backup, to restore ./QLogitechMediaServer.sh restore ! But I think I never did use this command lines.

    Best regards
    Stefan
    OkÚ have a look in the Multimedia directory, if prefs and Cache are still there. If so do the cp -RP command will restore settings. And if you got it running use the backup options. Now you can do and try anything with LMS. With restore you always restore you're settings.

    Have just done a test, with a new installation, and one using clear cache and then rescan. On both works. So the trouble must be on you're end.

    Are you using ACL, if so is the plugin for ACL installed?
    Send from my mobile Phone
    Last edited by digimaster; 2019-07-27 at 02:25.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  7. #507
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627


    How to add the Qnapclub store to the QNap App center

    The latest QLogitechMediaServer version!

    ================== QLogitechMediaServer version 2.09.06 ================================= 31-07-2019

    * Totally redesigned ownership, should fix error's in v2.09.01
    ( If you still get error, try touch .OLD in the .qpkg/LogitechMediaServer and restart QLogitechMediaServer )
    + New command-line option rollback. If ARCHIVE and there are releases file available, it will show a menu where you could choice the LMS version to rollback to.
    + New command-line option check. Will only check if a update is available, and downloaded it if available.
    + New command-line option upgrade. When there is a release file available, will upgrade lms to this. If LMS is running, it will be stopped !
    * When the PLAYLIST option is set, now will check on owner and rights in that directory !
    * It will now check which perl are supported by the installed LMS. And stop if no supported perl is found in LMS !
    * The GoogleMusic plugin git version can be installed, just do touch .GMUSIC or set GMUSIC=1 in .QLMS.conf
    in the .qpkg/LogitechMediaServer and restart QLogitechMediaServer.
    ( If GoogleMusic was installed through the Plug-in page, it will be removed ! )
    * Redesigned the way it try a restarts on crash, LMS will be start in failsafe mode on trouble !
    ( If you still have trouble on startup, try the new QLogitechMediaServer.sh clean option !
    + On installation will check if start-stop-daemon is installed, and can
    handle the chroot options. If not it will disable this function to be used !
    + Custom.pm will be placed on installation/upgrade
    Also edit Custom.pm some more, now only path which could contain music
    will show in LMS !
    + Added command-line option clean, will uninstall the installed LMS but keep the settings !
    ( Will ask if you're sure, before clean the LMS installation ! )
    ( After a clean on start, will install a new clean LMS installation ! )
    + In the .QLMS.conf file, now you could do UPDATE=/NIGHTLY=(release). (ARMX-09 and ARMX-19, only have perl 5.20)
    ( Keep in mind release lower then 7.9.0, have no support for perl 5.24/5.28 )
    If the options is not set right, it will do a normal update/nightly check.
    So only use 0/1 or ?.?.?, where ?.?.? should be something like 7.9.0 or higher !
    On restart will try to install that version, will downgraded if a lower version if set in UPDATE !
    After restart/start and up/down- graded, they will be set back to =1 !
    For example UPDATE=7.9.0, will install LMS version 7.9.0 on next started
    * Upgrade routine improved/adjusted, will do a better check and more future proved !
    When handling a up/down- graded, it will first remove the install LMS !
    * Manuel up/downgrading should now work proper.
    Just place a copy of logitechmediaserver-?.?.?.tgz in the Download share and restart QLogitechMediaServer.
    For NIGHTLY download the "Logitech Media Server: Unix Tarball (i386, x86_64, i386 FreeBSD, ARM EABI, PowerPC)" file !
    + Added extra option in .QLMS.conf. NOUPDATE if set, no update check will be done. Manuel update will still work !
    + Added extra control option OLD, which could be used when LMS crashes on startup.
    Will try to fix owner/rights on the SlimServer on the old way, but could causes pluging not to work proper !
    + Added new feature ARCHIVE. If set will keep the latest 5 installed versions of nightly build, and all the official builds !
    Very handy if you want to rollback.
    Just copy the wanted file from .qpkg/LogitechMediaServer/Backup/ to the download share/path of you're QNap )
    + Another new option is AUDIO, when set will use audio prg's supplied in QLogitechMediaServer installation !
    ( Normally LMS uses audio prg's, which are included in the release ! )
    + If LMS is started, it will also tell which release/version is started.

    ! IMPORTANT this version is still a BETA, it works great on my QNap ts-453a, but don't know about all the other QNap types !
    Having trouble PLEASE INCLUDED LOG'S, so i can find what's causing it on you're QNap ?
    And keep in mind, making/developing it in my spare time.

    More info go to ;
    The git websie for the GoogleMusic plugin!

    Questions or trouble regarding LogitechMediaServer itself , go to the SlimDevices forum website.
    http://forums.slimdevices.com

    More information on MusicIP, go to https://www.spicefly.com/ or http://forums.slimdevices.com

    No need to uninstall any old lms installations, from version 2.00.00, can be installed beside any other lms or perl installations.

    How to add the Qnapclub store to the QNap App center

    The latest QLogitechMediaServer version!

    Having trouble with latest version, you can do a downgraded.
    Download the version you want, from the website.
    And do a Manuel installation through the QNap app center.



    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  8. #508
    Junior Member
    Join Date
    Feb 2019
    Posts
    11

    QLogitechMediaServer version 2.09.06

    Did I miss something? I can't find the download link for 2.09.06

  9. #509
    Senior Member
    Join Date
    Aug 2008
    Posts
    152
    On my QNAPTS470 did a backup of my settings, then Remove from Qnap EU Store.

    Manually installed V2.09.05 beta X86_64.

    Code:
    [~] # /share/MD0_DATA/.qpkg/LogitechMediaServer/QLogitechMediaServer.sh restore 
    Please wait while we try to restore the settings !
    Stopping LogitechMediaServer [28051] in the Background.                         
    
    Restoring of QLogitechMediaServer & LMS settings are done !                     
    
    [~] # /share/MD0_DATA/.qpkg/LogitechMediaServer/QLogitechMediaServer.sh start
    ......  First let's check is there is a update for LogitechMediaServer.         
    Preparing the system to run LogitechMediaServer.                                
    Starting LogitechMediaServer in the Background.                                 
    LogitechMediaServer 7.9.2-1564745697 is started in the Background on [18251] !  
    
    Please wait a few minutes, before you try to access the webgui through http://10.0.5.1
    10.0.3.1
    192.168.1.22
    192.168.1.23:9001 !
    All worked fine for me, no reboot required.

  10. #510
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Now it should be there, was pending on approval at the QNapClub site !


    Quote Originally Posted by mjack View Post
    Did I miss something? I can't find the download link for 2.09.06

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •