Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 9 FirstFirst 1234 ... LastLast
Results 11 to 20 of 90
  1. #11
    Junior Member
    Join Date
    Aug 2017
    Posts
    28
    Perfect,
    thanks for the quick reply. Was just wondering, because until now, I always did a fresh install and never had a startup problem. Will try to find out, why pidof is not working. Kinda strange thing, because my nas is nearly "standard".
    A quick check from the terminal via admin gave me:
    /bin/pidof slimserver.pl
    3188


    Quote Originally Posted by digimaster View Post
    Very strange that pidof, not working correctly on you're QNap.
    Especially as at startup, the script does a check, if all needed commands are available.
    Should cause a completely other error, that a command is missing.

    But through you're input, adjust the script, to check on both ways.
    Will be included in next release.

    So thanks for pointing it out to me. ( was changed in v1.07.2, because older QNap systems )
    Next release will be out soon, working on to included the options for MusicIPServer.
    Last edited by blackbite; 2018-02-25 at 04:27.
    NAS: QNAP TS-451 QTS 4.3.4 (3x 4TB, RAID5)
    Services: QLogitechMediaServer 1.07

  2. #12
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    268
    Yes a strange thing, because from command line it works good.
    Question do you install it now from the QNapClub appstore or manuelly ?

    New release coming up this weekend, with MusicIPServer included.

    Quote Originally Posted by blackbite View Post
    Perfect,
    thanks for the quick reply. Was just wondering, because until now, I always did a fresh install and never had a startup problem. Will try to find out, why pidof is not working. Kinda strange thing, because my nas is nearly "standard".
    A quick check from the terminal via admin gave me:
    /bin/pidof slimserver.pl
    3188

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  3. #13
    Junior Member
    Join Date
    Aug 2017
    Posts
    28
    Hi Digimaster,

    First I have updated to 1.07.2 via appstore. But after having the start problems I returned to the manual clean install. The QNapClub appstore also shows some updates that are at least not compatible with my nas. I will keep doing future updates the manual way.

    With MusicIP I am totally not common. I have over 200.000 tracks in my library and have heard that scanning will last forever. So sorry that I can't help on that part, but I will test the 1.08.
    Thanks for all the hard work your doing here.



    Quote Originally Posted by digimaster View Post
    Yes a strange thing, because from command line it works good.
    Question do you install it now from the QNapClub appstore or manuelly ?

    New release coming up this weekend, with MusicIPServer included.
    NAS: QNAP TS-451 QTS 4.3.4 (3x 4TB, RAID5)
    Services: QLogitechMediaServer 1.07

  4. #14
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    268
    Is up to you, how i install it.
    Iḿ greatfull for all the input i get.
    And my goal is to let LMS work, with out all the fancy things.
    Want to make and keep is as pure as it can be.

    And hope that by this way, it will keep working without any big adjustments, also after a big upgraded from QTS.
    Hope will keep running without any maintaince on the installation.
    Looked a lot on the source and the way ssots/ssods was made, and trying to learn from it.
    But then without all the the addon off extra commands/programs.

    Quote Originally Posted by blackbite View Post
    Hi Digimaster,

    First I have updated to 1.07.2 via appstore. But after having the start problems I returned to the manual clean install. The QNapClub appstore also shows some updates that are at least not compatible with my nas. I will keep doing future updates the manual way.

    With MusicIP I am totally not common. I have over 200.000 tracks in my library and have heard that scanning will last forever. So sorry that I can't help on that part, but I will test the 1.08.
    Thanks for all the hard work your doing here.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  5. #15
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    268

    New release of QLogitechMediaServer V1.07.3 for Qnap QTS 4.2 or higher with x86/i*86/x86_64 ( 02-03-2018 )
    MDS5 check [ 8a64dd079748324cbaf15f4fd490ac78 LogitechMediaServer_1.07.3.qpkg ]

    ================= QLogitechMediaSever version 1.07.3 ================ 02-03-2018
    +Minor adjustment for Nas systems running on QTS 4.2 or lower, to handle several commands correctly. Fix for the “Check you’re configuration error” at startup.
    + Checked script with this info, and made some minor changes on other commands, so they will work proper even on QTS 4.2 and lower.
    + If exist renice will been done, at the start of the init-script.
    + Changed messages “Building from scratch”,”Upgrading” from warning to info.
    + Add the service MusicIP [1.8], for those who love this services. (Can be activated through the .QLMS.config file, or by doing [ touch MUSICIP ] in the .qpkg/LogitechMediaServer/ directory.) ( More info on how to use it, visited https://www.spicefly.com/) (I only supply away to install and run the services )
    + MusicIP is integrated in message’s and logs for QLogitechMediaServer.
    + When MusicIP is enabled and running, can be found in the resourcemonitor from QNap. (QmusicIPServer)
    Last edited by digimaster; 2018-03-14 at 12:05.

  6. #16
    Member
    Join Date
    Jan 2008
    Location
    Netherlands
    Posts
    63
    On my QNap TS-439 with QTS 4.2.6 I am trying to get your latest version to work with no succes the content of the logfile reveals some errors that there is no access to certain files, below I will post the content of that file.

    Code:
    [18-03-02 15:30:16.8844] main::init (387) Starting Logitech Media Server (v7.9.1, 1519287262, Thu Feb 22 09:27:46 CET 2018) perl 5.024000 - i686-linux-thread-multi
    [18-03-02 15:30:18.5495] YAML::XS::DumpFile (31) Warning: Can't open '/share/MD0_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/plugin-data.yaml' for output:
    Permission denied at /share/MD0_DATA/.qpkg/LogitechMediaServer/SlimServer/CPAN/YAML/XS.pm line 31.
    MusicIP fails also, maybe I have missed some critical steps to make it all in working order but I have no idea.

  7. #17
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    268
    Oke there could be some things giving trouble.
    First i would suggest to install it, without copy back old settings.

    Still getting errors, try following.Logon on to you're Qnap by ssh shell, do [ cd /share/*/.qpkg/LogitechMediaServer ]
    [ /bin/chown -R squeezeboxserver:everyone SlimServer/ ], [ /bin/chmod -R 0775 SlimServer/ ] and [ /bin/chown -R squeezeboxserver:everyone .MusicIP/]
    Now do [ ./LogitechMediaServer.sh restart ], and look at the messages.
    Still trouble, try a reboot first.


    Quote Originally Posted by HB64 View Post
    On my QNap TS-439 with QTS 4.2.6 I am trying to get your latest version to work with no succes the content of the logfile reveals some errors that there is no access to certain files, below I will post the content of that file.

    Code:
    [18-03-02 15:30:16.8844] main::init (387) Starting Logitech Media Server (v7.9.1, 1519287262, Thu Feb 22 09:27:46 CET 2018) perl 5.024000 - i686-linux-thread-multi
    [18-03-02 15:30:18.5495] YAML::XS::DumpFile (31) Warning: Can't open '/share/MD0_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/plugin-data.yaml' for output:
    Permission denied at /share/MD0_DATA/.qpkg/LogitechMediaServer/SlimServer/CPAN/YAML/XS.pm line 31.
    MusicIP fails also, maybe I have missed some critical steps to make it all in working order but I have no idea.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  8. #18
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    204
    Quote Originally Posted by digimaster View Post
    New release of QLogitechMediaServer V1.07.3 for Qnap QTS 4.2 or higher with x86/i*86/x86_64 ( 02-03-2018 )
    Works great here, thank you!

    Quote Originally Posted by digimaster View Post
    + Changed messages ôBuilding from scratchö,öUpgradingö from warning to info.
    QLMS 7.9.2@1.09b (digimaster) / QNAP 469L QTS 4.3.4

  9. #19
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    268
    Quote Originally Posted by dolodobendan View Post
    Works great here, thank you!



    Great how about Musicip?

    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  10. #20
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    204
    Quote Originally Posted by digimaster View Post
    Great how about Musicip?

    Send from my mobile Phone
    I'm sorry I can't be of any help here. I just run a pretty basic setting with everything I don't know disabled.

    The "scanning will last forever" part is not that encouraging, otherwise I would test it.

    (Maybe I'll give it a try this weekend, with just one library active.)
    Last edited by dolodobendan; 2018-03-02 at 10:04.
    QLMS 7.9.2@1.09b (digimaster) / QNAP 469L QTS 4.3.4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •