Home of the Squeezebox™ & Transporter® network music players.
Page 18 of 78 FirstFirst ... 816171819202868 ... LastLast
Results 171 to 180 of 773
  1. #171
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    700
    Quote Originally Posted by steklo View Post
    Thanks again!

    All commands seem to work now:

    <g/LogitechMediaServer] # ./QLogitechMediaServer.sh stop
    Stopping QLogitechMediaServer [13043] in the Background.
    <g/LogitechMediaServer] # cp -r /share/Multimedia/Cache SlimServer/Cache/
    cp -r /share/Multimedia/prefs SlimServer/prefs
    <g/LogitechMediaServer] # cp -r /share/Multimedia/prefs SlimServer/prefs
    <g/LogitechMediaServer] # ./QLogitechMediaServer.sh restart
    QLogitechMediaServer was already stopped !
    QLogitechMediaServer is started in the Background on [21026] !
    Please wait a few minuts, before you try to access the webgui through http://192.168.178.65:9001 !
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] #

    But in the end I'm still there with a naked LMS to be set up ;-(((
    Any idea what might be the reason?
    Looks like you are copping empty settings, or put them on the wrong place. Try ls -l /share/*/Multimedia/prefs, and ls -l SlimServer/prefs. Compare if it gives the same output.

    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  2. #172
    Hi,

    actually the outputs are different:

    [~] # cd /share/*/.qpkg/LogitechMediaServer/
    <g/LogitechMediaServer] # ls -l /share/*/Multimedia/prefs
    total 64
    -rw-r----- 1 admin administrators 3434 2018-12-08 18:22 clientplaylist_000000000000.m3u
    -rwxr-x--- 1 admin administrators 2965 2018-12-08 18:22 clientplaylist_b827eb7a989b.m3u*
    -rwxr-x--- 1 admin administrators 162 2018-12-08 18:22 favorites.opml*
    -rwxr-x--- 1 admin administrators 5340 2018-12-08 18:22 log.conf*
    drwxr-x--- 2 admin administrators 4096 2018-12-08 18:22 plugin/
    -rw-r----- 1 admin administrators 15907 2018-12-08 18:22 server.prefs
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] # ls -l SlimServer/prefs
    total 28
    -rw-r--r-- 1 squeezeboxserver everyone 162 2018-12-08 20:49 favorites.opml
    -rw-r--r-- 1 squeezeboxserver everyone 5339 2018-12-08 20:49 log.conf
    drwxr-xr-x 2 squeezeboxserver everyone 4096 2018-12-09 15:23 plugin/
    drwxr-x--- 3 admin administrators 4096 2018-12-09 14:58 prefs/
    -rw-r--r-- 1 squeezeboxserver everyone 6273 2018-12-09 20:50 server.prefs
    [/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer] #

    Still I haven't got a clue what it means to me.

  3. #173
    The folders "Cache" and "prefs" (which were created in the very first steps) are located in "Multimedia" ľ I think this is where they are supposed to be, isn't it?

  4. #174
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    700
    Quote Originally Posted by steklo View Post
    The folders "Cache" and "prefs" (which were created in the very first steps) are located in "Multimedia" ľ I think this is where they are supposed to be, isn't it?
    The prefs and Cache in the Multimedia directory, should a backup of a other installation. The proper place for LMS, should be, in the SlimServer directory.

    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  5. #175
    Quote Originally Posted by digimaster View Post
    The prefs and Cache in the Multimedia directory, should a backup of a other installation. The proper place for LMS, should be, in the SlimServer directory.

    Send from my mobile Phone
    Hi digimaster,

    yes I understand that these are the backups of the old installation which were created in step 1. But I guess that is where these backups are supposed to be in order to get copied into the new installation in step 2, right? But as it seems this does not work.
    I took a look into these folders and none of them is empty; they are filled with files and subfolders so that I guess they should be clean copies of the old prefs and Cache folders of the old installation. Still it somehow doesn't work to get them transferred in step 2 into the new installation.

    Do you have an idea what else I could try? In worst case I would have to set up LMS manually again.

    Best regards
    Stefan

  6. #176
    Senior Member
    Join Date
    Apr 2005
    Location
    Hampshire, UK
    Posts
    263
    Hi Digimaster,
    Everything was running well, but then I implemented Advanced Folder Permissions (ability to have different accesses to folders below the share level), and a few things stopped working (like not being able to play any music). I figured it is a permissions issue.. I noticed that the Squeezeboxserver userid was disabled, so re-enabled it. That allowed me to re-access the music. The old SSODS and MIP userid's were still on the system, so I removed them. My issue now is with Spicefly Sugarcube and MusicIP. MusicIP seems to be working fine (can call up 10002, and produce MusicIP mixes from within LMS). However, Spiceful Sugarcube which calls the MUSICIP API to fetch a new track/tracks comes up with a MUSICIP API error. I am guessing that this is a permissions issue as well. A few things:
    The LogitechMediaServer directory, and all of the files within are owned by Admin/administrators- and some directories including ,.config, and Musicipserverlog (and all subfolders and files). Folders Musicip and Slimserver are owned by Squeezeboxserver./everyone Is this correct?
    In resource monitor, running tasks, Logitechmediaserver tasks are running under squeezeboxserver, but musicip ip tasks (sudo is running under amin, and musicip is running under squeezeboxserver).

    If not, what's best way to set it correctly?
    Last edited by yeomanspc; 2018-12-09 at 17:17.

  7. #177
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    700
    Quote Originally Posted by yeomanspc View Post
    Hi Digimaster,
    Everything was running well, but then I implemented Advanced Folder Permissions (ability to have different accesses to folders below the share level), and a few things stopped working (like not being able to play any music). I figured it is a permissions issue.. I noticed that the Squeezeboxserver userid was disabled, so re-enabled it. That allowed me to re-access the music. The old SSODS and MIP userid's were still on the system, so I removed them. My issue now is with Spicefly Sugarcube and MusicIP. MusicIP seems to be working fine (can call up 10002, and produce MusicIP mixes from within LMS). However, Spiceful Sugarcube which calls the MUSICIP API to fetch a new track/tracks comes up with a MUSICIP API error. I am guessing that this is a permissions issue as well. A few things:
    The LogitechMediaServer directory, and all of the files within are owned by Admin/administrators- and some directories including ,.config, and Musicipserverlog (and all subfolders and files). Folders Musicip and Slimserver are owned by Squeezeboxserver./everyone Is this correct?
    In resource monitor, running tasks, Logitechmediaserver tasks are running under squeezeboxserver, but musicip ip tasks (sudo is running under amin, and musicip is running under squeezeboxserver).

    If not, what's best way to set it correctly?
    Sounds like everything is correct. You could try to stop Qlogitechmediaserver. And then do chown -R SlimServer/, now restart QLogitechMediaServer. It will take a bit longer to start, as it will try to corrected owner rights. If that won't work, you have to ask in the spice fly forum.

    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  8. #178
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    700
    Quote Originally Posted by steklo View Post
    Hi digimaster,

    yes I understand that these are the backups of the old installation which were created in step 1. But I guess that is where these backups are supposed to be in order to get copied into the new installation in step 2, right? But as it seems this does not work.
    I took a look into these folders and none of them is empty; they are filled with files and subfolders so that I guess they should be clean copies of the old prefs and Cache folders of the old installation. Still it somehow doesn't work to get them transferred in step 2 into the new installation.

    Do you have an idea what else I could try? In worst case I would have to set up LMS manually again.

    Best regards
    Stefan
    You should follow the steps from this post.

    https://forums.slimdevices.com/showthread.php?p=926206

    Then you will have the old setting in you're new LMS installation. Before doing so, would suggest to do [ rm -R SlimServer/] in the .qpkg/LogitehMediaServer directory. Then do [./QLogitechMediaServer.sh start], wait until it's says that is running. Now do [./QLogitechMediaServer.sh stop]. And now follow the instructions to copy back the settings. And look closely on the options. Then it should work.

    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  9. #179
    Hi digimaster,

    I tried to assemble the info you gave directly and those you linked me to ľ would you mind looking over it to see if I got it right:

    First:

    [ cd /share/*/.qpkg/LogitechMediaServer ]
    [ rm -R SlimServer/ ]
    [ ./QLogitechMediaServer.sh start ]
    [ ./QLogitechMediaServer.sh stop ]
    [ rm -r SlimServer/Cache ], [ rm -r SlimServer/prefs ]

    But then ľ should I use this:

    [ cp -R /share/Multimedia/Cache SlimServer/Cache/ ] , [ cp -r /share/Multimedia/prefs SlimServer/prefs ]

    or this:

    [ cp -RP /share/*/Multimedia/prefs SlimServer/ ], [ cp -RP /share/*/Multimedia/Cache SlimServer/ ]

    Finally:

    [ chown -R squeezeboxserver SlimServer/ ] , [ chmod -R 0755 SlimServer/ ]
    [ ./QLogitechMediaServer.sh restart ]

    Thanks again!

  10. #180
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    700
    Quote Originally Posted by steklo View Post
    Hi digimaster,

    I tried to assemble the info you gave directly and those you linked me to ľ would you mind looking over it to see if I got it right:

    First:

    [ cd /share/*/.qpkg/LogitechMediaServer ]
    [ rm -R SlimServer/ ]
    [ ./QLogitechMediaServer.sh start ]
    [ ./QLogitechMediaServer.sh stop ]
    [ rm -r SlimServer/Cache ], [ rm -r SlimServer/prefs ]

    But then ľ should I use this:

    [ cp -R /share/Multimedia/Cache SlimServer/Cache/ ] , [ cp -r /share/Multimedia/prefs SlimServer/prefs ]

    or this:

    [ cp -RP /share/*/Multimedia/prefs SlimServer/ ], [ cp -RP /share/*/Multimedia/Cache SlimServer/ ]

    Finally:

    [ chown -R squeezeboxserver SlimServer/ ] , [ chmod -R 0755 SlimServer/ ]
    [ ./QLogitechMediaServer.sh restart ]

    Thanks again!
    You should use,

    [ cp -RP /share/*/Multimedia/prefs SlimServer/ ], [ cp -RP /share/*/Multimedia/Cache SlimServer/

    And then do [ ls -l SlimServer/], where there should be a Cache and prefs directory.


    Send from my mobile Phone

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •