Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    Jun 2009
    Posts
    216

    Changing Media Server from ARM based QNAP to a Windows Server

    Hello. I have had my LMS running on my ARM based NAS for quite sometime and have decided to change it over to a windows server. I've installed LMS on the server, however, I can't seem to get the end points to connect to the new server. When I switch over to mysqueezebox.com and switch back, it automatically goes to the NAS LMS server. Any ideas here?

    (I also decided to do a clean install of LMS so I'll be manually re-entering in all the settings)

    Thanks much... darien
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,351

    Changing Media Server from ARMbased QNAP to a Windows Server

    > Hello. I have had my LMS running on my ARM based NAS for quite sometime
    > and have decided to change it over to a windows server. I've installed
    > LMS on the server, however, I can't seem to get the end points to
    > connect to the new server. When I switch over to mysqueezebox.com and
    > switch back, it automatically goes to the NAS LMS server. Any ideas
    > here?


    If old and new are in the same network, you should be able to "pull"
    them over using the player dropdown in the new server's web UI.

    Otherwise just shut down LMS on the old host. The players will start
    looking for a new server and let you connect to it.

    --

    Michael

  3. #3
    Senior Member
    Join Date
    Jun 2009
    Posts
    216
    Quote Originally Posted by mherger View Post
    > Hello. I have had my LMS running on my ARM based NAS for quite sometime
    > and have decided to change it over to a windows server. I've installed
    > LMS on the server, however, I can't seem to get the end points to
    > connect to the new server. When I switch over to mysqueezebox.com and
    > switch back, it automatically goes to the NAS LMS server. Any ideas
    > here?


    If old and new are in the same network, you should be able to "pull"
    them over using the player dropdown in the new server's web UI.

    Otherwise just shut down LMS on the old host. The players will start
    looking for a new server and let you connect to it.

    --

    Michael
    Thanks Michael. Is there anyway to pull the favorites over as well? I am realizing I had a lot and rebuilding it would take some time...
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,351

    Changing Media Server from ARMbased QNAP to a Windows Server

    > Thanks Michael. Is there anyway to pull the favorites over as well? I
    > am realizing I had a lot and rebuilding it would take some time...


    Check your old LMS' cache and prefs folders. It's called favorites.opml.

    --

    Michael

  5. #5
    Senior Member
    Join Date
    Jun 2009
    Posts
    216
    Quote Originally Posted by mherger View Post
    > Thanks Michael. Is there anyway to pull the favorites over as well? I
    > am realizing I had a lot and rebuilding it would take some time...


    Check your old LMS' cache and prefs folders. It's called favorites.opml.

    --

    Michael
    Very helpful. Getting close... I am experiencing some random crashes but not seeing anything in the log. Which logs should I set to debug in efforts to see what is happening when LMS stops...
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,351

    Changing Media Server from ARMbased QNAP to a Windows Server

    > Very helpful. Getting close... I am experiencing some random crashes
    > but not seeing anything in the log. Which logs should I set to debug in
    > efforts to see what is happening when LMS stops...


    Crashes on Windows? Can you narrow down when these happen? Are you using
    any 3rd party plugins?

    --

    Michael

  7. #7
    Senior Member
    Join Date
    Jun 2009
    Posts
    216
    Quote Originally Posted by mherger View Post
    > Very helpful. Getting close... I am experiencing some random crashes
    > but not seeing anything in the log. Which logs should I set to debug in
    > efforts to see what is happening when LMS stops...


    Crashes on Windows? Can you narrow down when these happen? Are you using
    any 3rd party plugins?

    --

    Michael
    It happens regardless of what I am playing (local music, deezer, pandora, etc...) and seems to happen when I scroll to Album Artists (I am using squeezepad on ios as my interface). Not all the artists pictures have come up, actually only the first few, and I am wondering if it has to do with the system trying to load the artist pictures. It appears as I am getting the following last log entry before it shuts down.

    Slim::Utils::Misc::msg (1255) Warning: [19:01:01.8912] Loading image from C:\PROGRA~2\SQUEEZ~1\server\HTML\Default\html\imag es\radio.png

    My third party plugins are (most of them are yours michael):
    - what was that tune
    - soundcloud
    - music and artist info (isn't this the one that allows artists pictures?)
    - music info screen
    - last mix
    - image browser
    - radio paradise
    - playlist manager
    - prevent system standby
    - settings manager
    - song scanner

    darien
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •