Home of the Squeezebox™ & Transporter® network music players.
Page 88 of 93 FirstFirst ... 38788687888990 ... LastLast
Results 871 to 880 of 927
  1. #871
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    743

    ================== QLogitechMediaServer version 2.25.00 ================================= 03-12-2021

    + Update routine changed, now besides nightly there is a developers option.
    ( Now based on lms-update.sh from picoreplayer source. Thanks to scala for pointing me on this ! )
    - Completly removed supported of gmusic/googlemusic. As that services has been stopped.
    ! Reprogramed timer functions.
    ! Under the hood, several small changes are done, and small error messages fixed.

    ! Changed some routines, to make it work for a futher releases with perl 5.32.
    ( Gone bring a new release soon, where al flavors will support Perl 5.32. )
    ( Keep in mind thats a lot of work ! )

    IMPORTANT works under QTS5, but one has to changed some settings in the QNAP configuration.
    Also after update it will install latest NIGHTLY if that set in .QLMS.conf.
    ( If 8.3 was installed, it will go back to 8.2.1 )
    If you want to uses the Developers version, you have to set #DEVELOPERS=0 to DEVELOPERS=1 in .QLMS.conf and restart QLogitechMediaServer.
    Keep in mind the developers versions, are pre/beta/developers release which could be buggy !.
    So if it not working, don't complain but go back to Nightly or Official release' s.
    Last edited by digimaster; 2021-12-03 at 06:40.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  2. #872
    Hi, what settings should we change in QTS 5?

    This is my log after the update:

    [11:02:08 04-12-2021] [QLogitechMediaServer] info : Building LogitechMediaServer from scratch, please wait a moment !
    [11:02:09 04-12-2021] [QLogitechMediaServer] info : No local time !
    [11:02:09 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ !
    [11:02:09 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ the old way !
    [11:02:10 04-12-2021] [QLogitechMediaServer] info : Starting LogitechMediaServer in the Background.
    [11:02:10 04-12-2021] [QLogitechMediaServer] info : LogitechMediaServer will be started with: [--daemon --httpport 9001 --user squeezeboxserver --pidfile /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/QLogitechMediaServer.pid --priority -10 --charset utf8 --quiet]
    sudo: /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/slimserver.pl: command not found
    [11:02:11 04-12-2021] [QLogitechMediaServer] warning : Could not start LogitechMediaServer in the Background.
    [11:02:11 04-12-2021] [QLogitechMediaServer] warning : LogitechMediaServer could not start, gone try again in failsafe mode !
    \e[41mPlease wait collecting some system info\e[0m !
    [11:02:21 04-12-2021] [QLogitechMediaServer] warning : LogitechMediaServer does not exist, in chroot file-system!
    [11:02:21 04-12-2021] [QLogitechMediaServer] info : Gone restart LogitechMediaServer !
    [11:02:21 04-12-2021] [QLogitechMediaServer] info : LogitechMediaServer is not running, or was already stopped!
    [11:02:34 04-12-2021] [QLogitechMediaServer] info : Building LogitechMediaServer from scratch, please wait a moment !
    [11:02:35 04-12-2021] [QLogitechMediaServer] info : No local time !
    [11:02:35 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ !
    [11:02:35 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ the old way !
    [11:02:36 04-12-2021] [QLogitechMediaServer] info : Starting LogitechMediaServer in the Background.
    [11:02:36 04-12-2021] [QLogitechMediaServer] info : LogitechMediaServer will be started with: [--daemon --httpport 9001 --user squeezeboxserver --pidfile /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/QLogitechMediaServer.pid --d_startup --failsafe --priority -10 --charset utf8 --quiet]
    sudo: /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/slimserver.pl: command not found
    [11:02:36 04-12-2021] [QLogitechMediaServer] warning : Could not start LogitechMediaServer in the Background.
    [11:02:36 04-12-2021] [QLogitechMediaServer] error : Can't start LogitechMediaServer, check the logs file in /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer!

  3. #873
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    743
    Quote Originally Posted by mnd View Post
    Hi, what settings should we change in QTS 5?

    This is my log after the update:

    [11:02:08 04-12-2021] [QLogitechMediaServer] info : Building LogitechMediaServer from scratch, please wait a moment !
    [11:02:09 04-12-2021] [QLogitechMediaServer] info : No local time !
    [11:02:09 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ !
    [11:02:09 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ the old way !
    [11:02:10 04-12-2021] [QLogitechMediaServer] info : Starting LogitechMediaServer in the Background.
    [11:02:10 04-12-2021] [QLogitechMediaServer] info : LogitechMediaServer will be started with: [--daemon --httpport 9001 --user squeezeboxserver --pidfile /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/QLogitechMediaServer.pid --priority -10 --charset utf8 --quiet]
    sudo: /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/slimserver.pl: command not found
    [11:02:11 04-12-2021] [QLogitechMediaServer] warning : Could not start LogitechMediaServer in the Background.
    [11:02:11 04-12-2021] [QLogitechMediaServer] warning : LogitechMediaServer could not start, gone try again in failsafe mode !
    \e[41mPlease wait collecting some system info\e[0m !
    [11:02:21 04-12-2021] [QLogitechMediaServer] warning : LogitechMediaServer does not exist, in chroot file-system!
    [11:02:21 04-12-2021] [QLogitechMediaServer] info : Gone restart LogitechMediaServer !
    [11:02:21 04-12-2021] [QLogitechMediaServer] info : LogitechMediaServer is not running, or was already stopped!
    [11:02:34 04-12-2021] [QLogitechMediaServer] info : Building LogitechMediaServer from scratch, please wait a moment !
    [11:02:35 04-12-2021] [QLogitechMediaServer] info : No local time !
    [11:02:35 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ !
    [11:02:35 04-12-2021] [QLogitechMediaServer] info : Fixing owner/rights for squeezeboxserver on SlimServer/ the old way !
    [11:02:36 04-12-2021] [QLogitechMediaServer] info : Starting LogitechMediaServer in the Background.
    [11:02:36 04-12-2021] [QLogitechMediaServer] info : LogitechMediaServer will be started with: [--daemon --httpport 9001 --user squeezeboxserver --pidfile /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/QLogitechMediaServer.pid --d_startup --failsafe --priority -10 --charset utf8 --quiet]
    sudo: /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/slimserver.pl: command not found
    [11:02:36 04-12-2021] [QLogitechMediaServer] warning : Could not start LogitechMediaServer in the Background.
    [11:02:36 04-12-2021] [QLogitechMediaServer] error : Can't start LogitechMediaServer, check the logs file in /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer!
    Could you send the output of ./QLogitechMediaServer.sh config?

    Verstuurd vanaf mijn Nokia 5.3 met Tapatalk

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  4. #874
    Quote Originally Posted by digimaster View Post
    Could you send the output of ./QLogitechMediaServer.sh config?

    Verstuurd vanaf mijn Nokia 5.3 met Tapatalk
    Here's the file, thank you.
    Attached Files Attached Files

  5. #875
    Junior Member
    Join Date
    Sep 2018
    Posts
    4

    Problems with Perl installation with ARM-x19.qpkg V2.25 on TS-212P

    Hi Digimaster,

    thank you, and all the other helpful people, for keeping the LMS universe alive.

    I just dared to change from flipflip's SSOTS with LMS 7.8 on my TS-212P to QLogitechMediaServer with LMS 8.3.0, and it was a bit scary ;-)

    To keep the drama low: it is now running smoothly, and with, at least subjectively, lower response times on the various players. The only loss seems to be some alarm settings, etc.

    However, there seems to be some trouble with installing Pearl 5.20.3 with version V2.25 of the QLogitechMediaServer. The installer seemed to run ok and reported a success, but in the various logs I always got the following error:

    Code:
    [QLogitechMediaServer] error: \e[41mThere is a error on Perl !\e[0m
    That was also about the only useful information I found in the log files. I went through all the suggestions in the README_ON_TROUBLE and looked at the shell script, etc, all in vain. Until I tried to install the earlier version (V2.21), with just worked fine. So for the time being, I will stay away from V2.25 on this particular CPU platform.

    As a side node, installing the V2.25 seems to have also completely removed my earlier installation (both SSOTS and LMS 7.8). Is this intended? It sounded different from the pre-install instructions. Still, some settings (e.g. Last.FM) seemed to have survived, but I guess they were stored on mysqueezebox.com rather than on my local QNAP NAS.

    Cheers,
    mucbox

  6. #876
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    743
    What i mean, whats the output of "./QLogitechMediaServer.sh config" if you run the command.


    Quote Originally Posted by mnd View Post
    Here's the file, thank you.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  7. #877
    Quote Originally Posted by digimaster View Post
    What i mean, whats the output of "./QLogitechMediaServer.sh config" if you run the command.
    Sorry, here it is. Maybe it did not finish checking the network, but it stayed like this for more than 5 minutes:

    [\e[34mQNAP info\e[0m] :
    QNap Model:\e[32m TS-231P\e[0m
    QNap Nas-System Platform: \e[32marmv7l\e[0m
    System: \e[32marm-unknown-linux-gnueabihf\e[0m
    QTS Version: \e[32m500\e[0m
    System String : \e[32mLinux NAS22CA37 4.2.8 #2 SMP Fri Nov 19 05:23:16 CST 2021 armv7l unknown\e[0m

    [\e[34mThe bash shell\e[0m] : GNU bash, version 3.2.57(1)-release (arm-unknown-l inux-gnueabihf)
    Copyright (C) 2007 Free Software Foundation, Inc.

    [\e[34mThe Qnap configuration\e[0m] :
    [QPKG Share] \e[33m/share/CACHEDEV1_DATA\e[0m
    [Packages Root] \e[33m/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer\e[0m
    Disc-space : A error occurred, please check [\e[41m/share/CACHEDEV1_DATA/.qpkg/L ogitechMediaServer\e[0m] !

    [\e[34mThe system mounts\e[0m]:
    tmpfs on /share type tmpfs (rw,size=16M)
    /dev/mapper/cachedev1 on /share/CACHEDEV1_DATA type ext4 (rw,usrjquota=aquota.us er,jqfmt=vfsv1,user_xattr,data=ordered,data_err=ab ort,delalloc,nopriv,nodiscard, noacl)
    tmpfs on /share/CACHEDEV1_DATA/.samba/lock/msg.lock type tmpfs (rw,size=16M)

    Error the [\e[41m/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer\e[0m] is not mo unted in chroot!

    [\e[34mNetwork check\e[0m] :
    \e[41mPlease wait!\e[0m

  8. #878
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    743
    Thats a strange error, has i have not changed any thing, regarding perl or files in the file-systeem.
    Could you please send me the output of "./QLogitechMediaServer.sh"

    And then one complety until its competly finshed ?

    Regarding SSOTS/lms 7.8, no QLMS does nothing with it.
    But some times you get a error message, and if you use a old conf of SSOTS QLMS wont start.

    On error i always sugest to do a compleet new install, to be sure nothing is bothering it.
    On updating from 2.21 to 2.25, it will always install a new version off LMS NIGHTLY.
    But al settings will be preserved.

    Quote Originally Posted by mucbox View Post
    Hi Digimaster,

    thank you, and all the other helpful people, for keeping the LMS universe alive.

    I just dared to change from flipflip's SSOTS with LMS 7.8 on my TS-212P to QLogitechMediaServer with LMS 8.3.0, and it was a bit scary ;-)

    To keep the drama low: it is now running smoothly, and with, at least subjectively, lower response times on the various players. The only loss seems to be some alarm settings, etc.

    However, there seems to be some trouble with installing Pearl 5.20.3 with version V2.25 of the QLogitechMediaServer. The installer seemed to run ok and reported a success, but in the various logs I always got the following error:

    Code:
    [QLogitechMediaServer] error: \e[41mThere is a error on Perl !\e[0m
    That was also about the only useful information I found in the log files. I went through all the suggestions in the README_ON_TROUBLE and looked at the shell script, etc, all in vain. Until I tried to install the earlier version (V2.21), with just worked fine. So for the time being, I will stay away from V2.25 on this particular CPU platform.

    As a side node, installing the V2.25 seems to have also completely removed my earlier installation (both SSOTS and LMS 7.8). Is this intended? It sounded different from the pre-install instructions. Still, some settings (e.g. Last.FM) seemed to have survived, but I guess they were stored on mysqueezebox.com rather than on my local QNAP NAS.

    Cheers,
    mucbox

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

  9. #879
    Quote Originally Posted by digimaster View Post
    Thats a strange error, has i have not changed any thing, regarding perl or files in the file-systeem.
    Could you please send me the output of "./QLogitechMediaServer.sh"

    And then one complety until its competly finshed ?

    Regarding SSOTS/lms 7.8, no QLMS does nothing with it.
    But some times you get a error message, and if you use a old conf of SSOTS QLMS wont start.

    On error i always sugest to do a compleet new install, to be sure nothing is bothering it.
    On updating from 2.21 to 2.25, it will always install a new version off LMS NIGHTLY.
    But al settings will be preserved.
    Do you mean "./QLogitechMediaServer.sh config" again, or some other command?

    "./QLogitechMediaServer.sh" returns:

    use ./QLogitechMediaServer.sh start, stop, status, restart, backup, restore, check, upgrade, clean, rollback, help or failsafe ( use this when trouble with loading plugins )!


    EDIT: while running "./QLogitechMediaServer.sh config", the network check doesn't seem to end, it has stayed in this step for 20 minute now.
    Last edited by mnd; 2021-12-04 at 05:31.

  10. #880
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    743
    Qnap changed some things in QTS 5, regarding acces of prg on the network.
    Have a got close look in the config pages of the webgui, otherwise go to the QNAP forum regarding this.
    The thing is i can not help you, as my webgui is in my native langue's.

    Thats what i found on the website of QNap.

    https://docs.qnap.com/operating-syst...-C124C405.html

    Quote Originally Posted by mnd View Post
    Do you mean "./QLogitechMediaServer.sh config" again, or some other command?

    "./QLogitechMediaServer.sh" returns:

    use ./QLogitechMediaServer.sh start, stop, status, restart, backup, restore, check, upgrade, clean, rollback, help or failsafe ( use this when trouble with loading plugins )!


    EDIT: while running "./QLogitechMediaServer.sh config", the network check doesn't seem to end, it has stayed in this step for 20 minute now.
    Last edited by digimaster; 2021-12-04 at 05:56.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 8.0.0 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.


    Thanks for the DONATIONS

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •