Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Mar 2006
    Posts
    22

    Deezer playing but no audio

    Occasionally when streaming from Deezer the audio stops but the player indicates that it's playing and progressing through the track. This seems to happen when I change albums or tracks.

    I thought this may be something to do with specific recordings but that doesn't seem to be the case.

    I just experienced this problem on Squeezebox Touch went and turned on my Squeezebox Receiver and got audio through both.

    I'm not sure which logs will help debug this. I have the Deezer log on Warn and have changed the "(player.source) - Player Source Audio & Conversion Logging" to Warn also. This is now telling me

    Code:
    [18-01-23 21:45:45.9397] Slim::Player::TranscodingHelper::checkBin (275)    couldn't find binary for: lame
    I haven't tried installed lame as I get audio most of the time and therefore wondering why this would solve the problem.


    Logitech Media Server Version: 7.9.1 - 1503129892 @ Thu Aug 31 04:39:14 UTC 2017
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.20.2 - x86_64-linux-gnu-thread-multi
    Audio::Scan: 0.95
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 2
    Player Model: Squeezebox Touch
    Player Type: fab4
    Firmware: 7.8.0-r16754
    Player Model: Squeezebox Receiver
    Player Type: receiver
    Firmware: 77

  2. #2
    Junior Member
    Join Date
    Mar 2006
    Posts
    22
    So I tried installing lame - no change, except no error message now.

    I've also done a bit more investigation playing with the log file settings (see the attached logfile extract).

    Playing Led Zeppelin, Mothership, I consistently get no audio with the first track (Good Times Bad Times), but it works fine with the next track (Communication Breakdown). Everything plays fine with the Deezer app on my phone.

    The most remarkable entries I can see in the log file are the lines after "new streaming state STREAMING"

    Code:
    [18-02-04 14:17:33.1432] Slim::Player::StreamingController::_Stream (1302) Song queue is now 0
    [18-02-04 14:17:33.1436] Slim::Player::StreamingController::_setPlayingState (2357) new playing state BUFFERING
    [18-02-04 14:17:33.1439] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state STREAMING
    [18-02-04 14:17:33.1649] Slim::Player::Source::_readNextChunk (373) end of file or error on socket, song pos: 0
    [18-02-04 14:17:33.1652] Slim::Player::Source::_readNextChunk (378) 00:04:20:23:6f:06 mark end of stream
    [18-02-04 14:17:33.1654] Slim::Player::Source::_readNextChunk (378) 00:04:20:17:8a:87 mark end of stream
    [18-02-04 14:17:33.1656] Slim::Player::Source::_readNextChunk (386) Didn't stream any bytes for this song; mark it as failed
    [18-02-04 14:17:33.1658] Slim::Player::StreamingController::playerStreamingFailed (2228) 00:04:20:23:6f:06
    [18-02-04 14:17:33.1661] Slim::Player::StreamingController::_playersMessage (789) Problem: Can't open file for:: deezer://110485626.mp3
    For Good Times Bad Times, and

    Code:
    [18-02-04 14:17:39.5702] Slim::Player::StreamingController::_Stream (1302) Song queue is now 1
    [18-02-04 14:17:39.5707] Slim::Player::StreamingController::_setPlayingState (2357) new playing state BUFFERING
    [18-02-04 14:17:39.5709] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state STREAMING
    [18-02-04 14:17:39.6915] Slim::Player::Player::_buffering (1140) Buffering... 0 / 204800
    [18-02-04 14:17:39.6939] Slim::Player::Player::_buffering (1140) Buffering... 0 / 204800
    [18-02-04 14:17:39.9752] Slim::Player::StreamingController::playerBufferReady (2258) 00:04:20:17:8a:87
    [18-02-04 14:17:39.9753] Slim::Player::StreamingController::_setPlayingState (2357) new playing state WAITING_TO_SYNC
    [18-02-04 14:17:39.9922] Slim::Player::Player::_buffering (1140) Buffering... 28945 / 204800
    [18-02-04 14:17:39.9942] Slim::Player::Player::_buffering (1140) Buffering... 206108 / 204800
    [18-02-04 14:17:40.2933] Slim::Player::Player::_buffering (1140) Buffering... 114829 / 204800
    [18-02-04 14:17:40.2937] Slim::Player::Player::_buffering (1141)   +output... 345976 / 1764000
    [18-02-04 14:17:40.2956] Slim::Player::Player::_buffering (1140) Buffering... 229824 / 204800
    [18-02-04 14:17:40.3944] Slim::Player::StreamingController::playerBufferReady (2258) 00:04:20:23:6f:06
    [18-02-04 14:17:40.3950] Slim::Player::StreamingController::_setPlayingState (2357) new playing state PLAYING
    [18-02-04 14:17:40.3953] Slim::Player::StreamingController::_Playing (361) Song 1 has now started playing
    [18-02-04 14:17:40.3960] Slim::Schema::RemoteTrack::get (392) deezer://110485628.mp3, title->Communication Breakdown - Led Zeppelin
    [18-02-04 14:17:40.3964] Slim::Player::StreamingController::_Playing (390) Song queue is now 1
    [18-02-04 14:17:40.6730] Slim::Player::StreamingController::playerTrackStarted (2180) 00:04:20:17:8a:87
    [18-02-04 14:17:40.7019] Slim::Player::TranscodingHelper::getConvertCommand2 (443) Error: Didn't find any command matches for type: mp3
    [18-02-04 14:17:40.9181] Slim::Player::StreamingController::playerTrackStarted (2180) 00:04:20:23:6f:06
    [18-02-04 14:18:35.0350] Slim::Player::Source::_readNextChunk (373) end of file or error on socket, song pos: 5945468
    [18-02-04 14:18:35.0354] Slim::Player::Source::_readNextChunk (378) 00:04:20:23:6f:06 mark end of stream
    [18-02-04 14:18:35.0357] Slim::Player::Source::_readNextChunk (378) 00:04:20:17:8a:87 mark end of stream
    [18-02-04 14:18:35.0362] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state STREAMOUT
    I guess the error at the end is when I changed tracks.
    Attached Files Attached Files

  3. #3
    Junior Member
    Join Date
    Mar 2006
    Posts
    22
    Can anyone else tell me if they have the same issue playing these tracks.

    I've tried various logging settings and can't get anything more insightful than below.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,785
    I don't use Deezer but your problem is indicative of transcoding problems. There should be no transcoding for MP3 for any player unless changes have been made to setupo or perhaps you have enabled bit rate limiting.
    To debug transcoding enable player.source to DEBUG.

    Make sure all FileType settings are at default - WebUI Settings/Advanced/FileTypes - there should be no "disabled" settings.

    Do not have players synchronised and do not have other players playing at the same time. Only debug one player at a time.

    Make sure bit rate limiting has been turned off for player - WebUI Settings/Player/Audio bitrate limiting set to "No Limit".

    No 3rd party plugin which mess with "audio quality" (i.e. change transcoding) such as BruteFir.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •